Iris smart plug not responding...how do I troubleshoot?


#1

I have an Iris smart plug that yesterday stopped responding to the app, and Alexa says is not responding to network commands. How do I troubleshoot. Thanks


(Michael) #2

Mine has done that a few times too. Sometimes unplugging for a few minute helps. Sometimes just hitting the on button helps too. If not you can run a replace on it through the app and it will remove and readd it with a different Zwave network ID.


(Jason "The Enabler" as deemed so by @Smart) #3

Well…

  • try unplugging it for about 20 minutes
  • try doing a reset on the plug and then have the have rediscover it. Do NOT delete it from the app, it’s zigbee so it should just go back to the same address.
  • try hitting it with a hammer, twice
  • try pressing the button on the device while discovering devices in the app.
  • try using a flame thrower, they fix everything

That’s all I’ve got.


(Bobby) #4

@jgirvine what @bamarayne said, just don’t start with the hammer or torch first. Unplug or rediscover should do it.


#5

This happened to me to a couple of times. I wonder if we’re starting to spot a trend here? I unplugged the device and plugged it in again holding the button down to re-pair it. The blue light would start to flash and after a couple of minutes, it would stop flashing. ST never paired the Zigbee part but it showed a new Z-Wave part. I configured the new Z-wave part and force deleted the “old” Z-wave part from the previous pairing. I tried it again, and the second time, ST found the Zigbee outlet so I configured it and it went back into the same slot.


#6

This may just have been a typo, but if you use the Z wave “replace” utility, the device will be re-added with exactly the same network ID. That’s the purpose of doing a replace, so you don’t have to individually change each smart app and routine that uses the device if you have to replace a defective unit.

If you remove and then add it again just like a new device, it will instead be issued a new zwave network ID.

Zigbee devices work differently because each device has its own unique ID. So no matter how many times you remove it from the network and then add it back again it will always have the same ID.


#7

Ok, I just checked (got busy with a major major problem (that will be another post here in a second) ) but it is a zigbee device, so there is no “replace” option. I have tried just pushing the button, that did not work, have now had it unplugged for about an hour, will go and plug back in in a minute… so then if that does not work I do a “remove”???
Thanks


#8

The Iris plug is very unusual in that it includes both a zigbee radio and a Z wave plus radio. It should show up in SmartThings as two different devices.

The zigbee radio is what controls the plug turning on and off.

The zwave radio is there only to act as a Z wave repeater. You can’t actually do anything with it.


(Bobby) #9

That really has no effect. If it doesn’t come back by just unplugging it for couple of seconds, it means that power cycling the device doesn’t work. Try rediscovering it without making any changes. If that doesn’t do it, then reset the device and run discovery.

By the way, I have 10 of them. And occasionally they get stuck. But usually quick power cycling fixes the problem. I haven’t had any problems with any of them in the past month (am also using the zwave too for each).


(Bobby) #10

What device type are you using? same question for @jgirvine


(Michael) #11

Well everytime I have done a replace I have gotten a new network ID on the device. The only difference is I didn’t have to update all my SmartApps with the new device.


#12

SmartPower Outlet


(Bobby) #13

Ok, that’s good, same here…


#14

That’s odd-- sounds like you’re doing a replace and then re-adding the device as well.

The purpose of the replace utility is so the device ID doesn’t change.

Note in particular:

This gives the new device the network ID of the failed one, so it works as a drop-in replacement with minimal reconfiguration.

It’s the fact that it has the same network ID as the old one that keeps you from having to update the smart apps.

If It seems to be doing something else, it might be good idea to contact support.


#15

I’m using @ady624 Enhanced Smart Power Outlet


(Realy Living Dream) #16

I’ve had this happen to ( I think ) every one of my Iris wall warts at least once. Pull it off the wall, put ST hub into discovery mode, then plug it back in while holding in the button until light flashes. Once light turns solid on back out of discovery and it should respond. If not lather rinse and repeat.
DO NOT press the button multiple times, since that resets the ZW , not the zigbee. Zigbee is reset by having the button pressed in while power is applied.