iPhone showing leaving and returning CONSTANTLY


(THE Erkelbot) #1

Hi community,

We recently moved, and are now having issues with presence sensing in the new house. At the old house, my wife’s phone would sometimes say she’s arrived, even though she was still at the office. Not great, but it was seldom happening…

Now that we’ve moved, the whole system is completely FUBAR. We will be home all day, and our iPhones safely parked on the counter. And despite this, we’ll get 100 notifications a day about us leaving and returning. I’ve tried;

  1. Removing users and programs linked to the user.
  2. Ensured all wifi and app permissions are correctly enabled.
  3. Firmware update on my hub.
  4. increasing the range of my geo-fence (1/4 mile+).
  5. There are more things too that now escape me…

I’m on an iPhone 5S, and my wife is on a 5. Both are the most recent software. As I said, mine didn’t really have any issues until moving, though my wife’s did on a rare occasion. Does anyone know what could be causing this? Is there a possibility of interference? But, how would that even work with CDMA and GSM signals?.. The Z-wave devices in the house seem to be working correctly.

That brings me to my last issue… I can’t actually equip and enable the new house with the z-wave alarm system because of the connectivity issues with the phones. The system used to arm itself for motion and door sensors when we were ‘away’ after performing ‘goodnight’. The trouble is that it shows us away…a lot. And says goodnight…a lot. I’m simply not hooking up the blaring siren to a system that’ll make us deaf after a week of use. Aside from that, our canine friends know the sound that ‘left’ and ‘arrived’ makes, and bark every time it happens. Sure, I can silence my phone, but I should have to put up with this nonsense…

I was going to equip the new house with Z-wave locks too, but I think that project is on hold indefinitely. There’s no way I’m allowing entry to the house tied to mobile presence at this point. I’ll just stick to good old-fashioned tumbler locks and deadbolts…

Anyone have the same issue with their iOS mobile presence sensing? And please don’t say “buy a presence sensor” – that’s a non-answer. Thanks!


iPhone left and returned without me last night, several times
(Hubert Simon) #2

I notice the same behavior with my android phones since 2-3 weeks. It was working flawlessly before that and I haven’t changed a thing on my side. Don’t know what could cause that.


(THE Erkelbot) #3

It’s awful. I don’t know what to dpi, short of widening my geofence to .5 miles +. That almost makes ‘presence’ moot at that point though…


(Beckwith) #4

@erkelbot

I noticed the same a couple of weeks ago when an update was supposed to reduce the issue according to release notes (but I didn’t have the problem). I contacted support and they said they were able to repeat it and passed it to their QA team.

I just sent an e-mail asking for an update.


(THE Erkelbot) #5

Thanks. I widened my geofence to .5mi+ now. It’s still happening… Sigh…


(Beckwith) #6

@erkelbot

You could try using Life360 as a workaround which doesn’t seem to have this problem.


(THE Erkelbot) #7

I could, but I hate piling on “solutions” instead of just fixing things right… I don’t get it… Location services look accurate in every other program on the phone. Why is the ST app and iOS not communicating right?..


(Edward Pope) #8

In moving have you considered how the hub it’s connected and aligned in your new home?

It sounds like it is losing Donal from your device?


(Beckwith) #9

Here is SmartThings support response:

“No update I’m afraid – I’m going to push again for the Exit Delay issue to get fixed. I’ll let you know the second it’s resolved.”


(THE Erkelbot) #10

Yep, I think I have taken that into consideration.

The hub is central to the home, and wifi is on 2.4GHz and 5GHz. Very strong signal throughout the property. I’ve reset the app to know my new location many, many times (many.) but still continue to get the coming and going message. If it was just my phone or my wife’s phone that would make me think it’s the cellular network experiencing some sort of anomaly, but it both of our phones. I’ve reset the phones, reset the router, reset the hub, disconnected the cellular data on both phones and reconnected them to towers to ensure all of the location accuracy is proper…still no luck.

Question though…when you say ‘aligned’, do you mean physical location in the home? Or is there some special trick I am forgetting about?


(THE Erkelbot) #11

Thanks, @beckwith I appreciate it!


(Edward Pope) #12

@erkelbot just a quick note here. I found the link that had some good ideas on how you can make some changes that might help you. It is a good read, and very informative about connectivity issues that you might be having.

Mind you, this is something to try. Not sure if it will resolve your problem,

The link is here


(Alex Christensen) #13

If you recently moved, the geolocation database on your phone may still think your router is at the old location. You may want to try changing the LAN side MAC address and see if that helps. I’ve seen that before when several friends and relatives have moved.


(THE Erkelbot) #14

Thanks all. Still having issues, but I’ll do some reading today and see if we can get to the bottom of things…

Interestingly enough, I did see the map where you set your geofence show me at my old address and then magically warp back to my new address, marking me away and then home quickly. I suspect there’s some remnant code that is out there somewhere tethering me to my old home location, despite having changed it manually and seeing it with the correct coordinates on the ST site. Perhaps @bazfumis right about the LAN and MAC addresses, so I’ll try troubleshooting them tonight and seeing is that helps.

I’ll reply back once I give more testing a try. Much obliged.


(Dan) #15

Same problem here on an S5. The whole “presence” concept with geofence and fobs is sufficiently unreliable that I would appreciate a simple widget for the phone that lets me toggle the Home-Away mode. Nothing fancy, nothing two-step, nothing bigger than one grid block. Just a simple on-off switch. That will at least make the system usable.

Dan


(THE Erkelbot) #16

Thinking about this a bit more…I can’t imagine the MAC and LAN addresses would make much difference, since it’s my cellular service that’s showing me elsewhere on my map in the ST app. I think there’s some hangup in the ST cloud that’s got me stuck at my old address. I tried clearing often visited places in my phone, but that didn’t help either. It’s super goofy…

AND, it’s only showing me at my old home when I am interacting with my geofence at home (within the circle). When I am at work – a substantive distance from both – I don’t run into the issue where it’s showing me at my old area. In fact, I NEVER have problems with locations services. It has to wither do with the ST system, OR the ST app that’s putting me at my old place…It just has to.


(THE Erkelbot) #17

It could though, I suppose. Since it sounds like it’s tricking my phone into thinking it may be elsewhere via that info.


(Beckwith) #18

@erkelbot

Location resolution on smart phones use a database of WiFi geo-coordinates as well as cell and GPS data. Thus, if you move a WiFi hotspot from one location to another, then yes, this can happen. This would tend to happen within buildings where GPS and cell tower signals get lost.


(THE Erkelbot) #19

Thanks. I think you may well be correct with this being the root cause. By chance do you have instruction how I can cleanse/reset the address in the router? I think it’s an ASUS. Much obliged for the help!


(Alex Christensen) #20

Jumping back and forth between the old and new locations like that is exactly what I’ve seen before when a wi-fi access point is moved. I don’t have an ASUS router connected to check right now, but every router I’ve ever used has a setting to allow you to edit the LAN and WAN MAC addresses. It is probably somewhere under the Advanced settings.