Iphone presence not working unless Smart-Things app left open all the time

Smart-Things has worked well for some time. Recently it stopped detecting mine and my wife’s iPhone reliably when we left or returned to the house. I verified that Smart-Things Location was set to Always. I finally discovered that it worked correctly as long as the app was open. Previously I could close the app as long as location was set to Always for Smart-Things. Any ideas ?

Did you recently update to ios15?

Gave up on SmartThings presence years ago. Life360 is way more reliable.

Yes , I recently updated to Ios 15 which is about when the problem started.

I’m having the same issue. Definitely started with the ios 15 update. Presence only recognized when app is running. Daughter’s ios 14 phone still works as expected.

I’ve removed and re-added the phones, deleted and re-added the automations. I’ve ensured locations set to always. Can recreate consistently.

Currently most of my home is using life 360 but we do have Iphones that are using Smartthings APP. On the Iphone check. Settings/privacy/location services/Smartthings. Make sure always is selected. And precise location is enabled. Sometime in the future of the Iphone will have a popup to let you know that Smartthings Is using your location in the background. Make sure to select yes or always. This last part is the problem I found with a family member’s phone. It kept switching back to only while using the APP.

i just created an automation using the iphone shortcuts that when i arrive at home it will launch the app and when i leave it will launch the SmartThings app. Ill see if this helps

After a couple of days messing with it I’m convinced it’s iOS 15 related. I have an iOS 14 phone that works flawlessly, our two iOS 15 phones are hit/miss at best. I’ve rebuilt just about everything short of reloading the phone. Oddly, if I setup a random presence that doesn’t do anything other than send a notification the other presence automations work - sometimes. Totally annoying.

This sounds a reasonable line of enquiry to follow, though perhaps not to quite that extent. I’m not an iOS user but I’ve been observing mobile presence on Android more closely of late, and in particular ‘linked places’. I am getting the impression that presence updates are something of a one shot thing at the time the phone is detected entering or leaving the geofence. There doesn’t seem to be much of an attempt to catch up and/or correct things later. So anything that might mean the app has interrupted internet access would seem to be of interest.

Oh well, maybe don’t do that then. It does seem worthwhile keeping Internet access in mind though. It’s all very well having access to the geolocation but you need to be able to upload the status.

Since adding an additional automation to send a notification when leaving or arriving the original presence automation has started working. I’m totally baffled. It was nice when you could see the status in the IDE but now it only shows as a placeholder.

The IOS 14 phone still shows the occupancy status.
Current States
occupancy: unoccupied
presence: not present

LOL, spoke too soon. My next trip presence failed to recognize I was away until I opened the app about 20 minutes into my trip. However, it did recognize when I returned home - go figure!

I have a case opened with support and will post any results here.

I offered something to try to another user today who reported it worked when they arrived home so with a one time as working… I can’t say it will permanently resolve the issue but if you wish to try…

note: before doing this, you make want to take screenshots of any automations/scenes using the mobile device for presence in case they need to be recreated.

do the following in the order they are presented…

  • turn off get location for the phone in the ST app
  • login to IDE and ensure the mobile device listing has been removed. if not, remove it.
  • uninstall the ST app
  • go to settings on your iPhone and reset network settings… don’t reset anything else. note: this will force you to set up wifi networks, bluetooth connections and any vpn settings but it also resets any mobile settings
  • reboot your iPhone
  • reinstall the ST app
  • enable get location for this phone in the ST app

and hope it works :slight_smile:

also: Placeholder is what you will expect to see with newly added mobile devices in IDE

You may want to wait until another ST issue is resolved first - that where automations/scenes have greyed out fields

This method is such a brutal hack that we shouldn’t have to do however it appears we can’t expect ST to fix this in any reasonable time. My presence is working 1 in 10 tries at the moment unless I keep the app open which I rarely think to do. I haven’t made use of Shortcuts before and seem to be struggling to sort it out. Any chance you could post a screenshot of the setup as I’d like to copy you.

I too am having the presence sensor issue, it only works if the app is open in the background. Even if the app is open in the background and hasn’t been opened in the foreground for sometime, presence doesn’t work. I don’t know what to do to fix it, I tried to add Life360 but smart things don’t let me select a place in the smartapp. Has anyone had any success getting presence to work reliably?

You can try the steps I posted above… 2 up from your post

I’ve been working with smartthings support providing logs and diagnostic info and they have identified the issue with the application and background refresh which is impacting the presence functionality. They hope to have a fix released in the next couple of weeks.

Fingers Crossed.

Lol. They promised me a beta version of the app to test the speed and functionality issues I have after they claimed to have found the issues. I’ve been waiting a month and a half, and no beta.