IP conflicts - Does each SmartThing get its own IP address?


(Jonathan Hochberg) #1

Until recently, I never had a problem with IP conflicts on my home network. Now, since I started using SmartThings, it happens on a regular basis - I’ll have devices lose connection due to conflicting IP assignments.

I’m willing to believe this is coincidental, because I was under the impression that the hub is the only thing that actually gets an IP address from the wireless router. Is that correct?

(We do have an ever-increasing number of non-SmartThings devices, and I’m almost ready to take the plunge and assign static addresses to everything.)


(Andy - United Kingdom) #2

I have a ‘rule of thumb’ - if it doesn’t leave the house it gets a static IP
This means my dhcp scope is quite small and easy to control
Most obvious thing is to look at your router to check if another device is trying to use the IP for your ST hub

Z-wave and Zigbee devices don’t use an IP from your network but do you have other wifi devices? Sockets? Bulbs?
If yes then these could be using up your dhcp scope


(Jonathan Hochberg) #3

Thanks - I think your rule is probably the way my thumb should be going, it’s just a matter of the doing.

Most of my smart devices are Cree bulbs; I think those are zigbee, so it’s probably a coincidence.

I appreciate the quick response!


(Lee Florack) #4

Although your ST Hub has an IP address on your local network, Most ST-connected devices do not run on IP and therefore don’t need or use an IP address. I can say for sure that all of my ST devices either are ZigBee or Z-Wave. So, if you’re getting IP conflicts, it’s not very likely that it’s related to ST. Local IP addresses are controlled by your router and if it’s in DHCP mode, it negotiates the addresses with each of your connected IP devices as they connect or come up for IP address renewal. You can also set the device to be static or have the router reserve an address. Anyway, if you’re having IP conflicts, you probably either have a bad router or a bad device that’s ignoring the router’s instructions (see a potential exception in the next paragraph). At various times, I’ve had one of each and have replaced them and the issue went away.

With all that in mind, another possibility is that 2.4 GHz frequency used by Wi-Fi and ZigBee devices can and do overlap at some points in their frequency spectrums and can interfere with each other (See diagram below). So, it’s possible that a frequency conflict is causing poor IP communication between the router and your IP devices and the router and IP device(s) are missing part of the negotiation data and are therefore creating an IP conflict. Normally however, IP signals are stronger than ZigBee signals and the ZigBee devices lose that battle. But who knows in your case? When I set up my IP network in my new home last year, I had to assign my router to specific non-conflicting bands because my ZigBee devices weren’t communicating well and my IP throughput was suffering badly. I didn’t have any IP conflicts as a result, but it’s not out of the question that bad communication - throughput in my case, couldn’t have resulted in IP address conflicts too.


(Steve Jackson) #5

Thank you for the reference table @lflorack . A handy reference for help in selecting a WiFi channel that doesn’t conflict with your ZigBee devices (and hopefully your neighbors).


(Lee Florack) #6

You’re very welcome.


#7

Im having a brain fart, trying to interpret the chart…So correct me if im wrong to summarize to avoid zigbee comms issues the wifi channels that should be used are channel 1, channel 6, or channel 11?


#8

Wi-Fi only has channel 1, 6, and 11 as distinct channels. You’ll always be using one of those.

We have two FAQs on how to select Wi-Fi channel to avoid interference with using the channels. Those should help clear up any confusion.

First, the basic simple FAQ:

Next, one with a lot more details, including other ways on reducing interference.

Both include pictures. :sunglasses:


(Lee Florack) #9

In addition with @JDRoberts excellent guidance (as always) and referenced articles, See the charts below - taken from the second article referenced by JD ( I was literally typing my response this when I noticed that JD had already answered and used the article I was referencing too! Good job @JDRoberts! )

Note that “WiFi’s three non-overlapping channels (1, 6, and 11) use the exact same frequencies as ZigBee channels 11-22.”

The second article referenced by JD is excellent and should help you along quite a bit. The resulting answer for your situation will be specific to your equipment, and their specific locations, etc. In my case, I had to change my router and access point channels to test how it affected both ZigBee and WiFi interference. It’s time consuming because it seems to take a while for changes to settle in and the results to be evident enough to make a choice which A/B setting is best. The results, however, result in more stable WiFi and ZigBee networks and performance. In my case, I ended up with my access point - which is closest to my ST Hub, set to channel 12 (2.467 GHz) and my router set to channel 3 (2.422 GHz). For whatever reason(s), those channels worked the best for me and my equipment, configurations, locations, etc.

Good luck!


#10

None of that wifi stuff would cause actual IP conflicts though. Are you SURE that IP conflicts are your problem, as that seems unlikely. If it is, there can be a couple of causes:

  • DHCP scope too small. IIRC, most SOHO routers use 192.168.x.100 - .254. So unless you have more than 200 devices that’s unlikely to be an issue
  • DHCP scavenging set too low, or lease time set too high. I don’t even think you can set scavenging in most SOHO routers, so I also doubt that’s the issue.
  • Static IPs set inside the DHCP scope. If the scope I listed above is like yours, than you cannot set a static IP inside the range of .100 - .254. It must be set below 100. This is probably the most likely cause.

There’s a reason that DHCP was created, and its that static IPs can quickly become a troubleshooting and/or management nightmare. Setup DHCP correctly, and then forget it exists.


(Steve Jackson) #11

For certain things I like static IP’s. My Honeywell thermostat, Canon printers, WD NAS, etc. I will either place these IP addresses outside the DHCP range (I usually only allocate 10 thru 100 for DHCP use) or let them get assigned initially via DHCP and then go into the router and subsequently reserve the assigned addresses so they stay with the device. Currently, I have a combination of both. The laptop and NAS are outside the range because I could actually set them, the others required that I used DHCP so I had to use the reservation method. Just my 2 cents.