Inovelli Fan Module Issues when mirroring virtual switch

When using the new Edge Driver for the Inovelli Light/Fan Module the manufacturer suggest to create virtual dimmer switches and use smart lighting to “Mirror” each switch with the Master. When I do this the switches dont work as previous.

Device - Inovelli channel1
Mirror - Virtual Light

  • Select Virtual Dimmer light
  • Virtual Dimmer light shows ON but device isnt on and Master Inovelli channel 1 does nothing.

Device - Virtual Light
Mirror - Inovelli channel1

  • Select Virtual Dimmer light
  • Light turns on.
  • Inovelli Master Turns on.
  • Fan turns on.

I haven’t seen any response from Inovelli, so wondering if anyone got this working?

  • are you using Routines or Smart Lighting to sync?
  • how did you create your virtual dimmer switch?
  • I am using SmartLighting app.
  • Created dimmer using vEdge Creator

I’d use a Routine rather than Smartlighting.

I don’t believe that Routines can sync dim levels.

@pmjoen the virtual dimmer device in vEdge has an option which allows it to only set the dim level without turning the device on. Are you running into this? Look at the Settings page for the virtual dimmer.


Ah, right, you can only set specific values for the dim level based on the trigger action(s). However, I don’t think you can “technically” sync dim levels in Smartlighting. You can have a physical device mirror the behavior of the virtual device which would give you the same effect. However, in my testing, any time I set the dim level of the virtual dimmer, it turns on, which in turn is mirrored to the physical dimmer setting both the dim level and turning it on. This is regardless of the setting for linking/not linking the switch to the dimmer in the virtual dimmer settings.

This is what I do and have done for years. Originally with the old virtual dimmers created with the IDE, then with Tod Austin’s vEdge virtual dimmer, now with Tod’s vEdge virtual light. I use the virtual dimmer as a sort of group and 90% of the time operate it via Alexa. With a virtual named Kitchen Ceiling and a Smart lighting sync rule, saying “Alexa, kitchen ceiling 50%” turns on three different physical dimmers and sets levels to 50%.

I can’t say from personal experience that you can use the Smart lighting sync rules to just sync two physical dimmers. I used them to sync physical on/off switches which mostly worked but if you sync both ways with two rules, it’s possible to generate a loop. I’ve moved those to Routines.

I’m not sure how this works with the current version of Tod’s virtual dimmer but for some recent version, you could set the dim level without affecting the on/off state of the device. This behavior was different from the old IDE virtual dimmers. I ended up switching mine to virtual lights where setting a dim level always turns the device on. They do come on at whatever level they were last on, then the dimmer level changes. There’s a discussion about this between Tod and me on the vEdge topic.

There are two virtual dimmer options in the vEdge creator, one with a switch and dimmer level and one that is dimmer level-only. The switch/dimmer combo has a setting to decouple switch from dimmer, but regardless of how that is set, changing the dimmer level on the virtual device turns it on and therefore mirrors to the physical switch.

The behavior of changing dim level turning on a device is new since the move to the Edge architecture and there doesn’t seem to be any way to override it. For the GE/Jasco dimmers, @philh30’s driver supports a default dim level which gives you control over what level the light is when it is turned on. This is important because when I previously had the default dim level at 99% and had my Routine at night turn it on at 1%, it would come on at 99% and then have the annoying jump/ramp down to 1%. I adjust the default dim level via Routines based on the time of the day so that if you push the button during the day, the light comes on at full level. Perhaps @TAustin could implement a default dim level in his virtual dimmers that could mimic the behavior of the GE/Jasco devices.

The virtual dimmer level-only device isn’t recognized by Smartlighting so there is no way to use it as the controlling device for the physical switches. Don’t know if @TAustin would know why the dimmer level-only device isn’t recognized by Smartlighting. Possibly because it doesn’t have an on/off capability.

The old IDE-created virtual dimmers always turned on when setting dimmer level. That matches what I’ve always seen on physical devices.

I thought Tod had left an option to change dim level without turning the device on. You should pop over to his thread and ask.

Use the the virtual light device - it is recognized by SmartLighting, and the linkage between switch and dimmer can be enabled/disabled.

1 Like

For both virtual switch/dimmer and light, if I set the dim level, the virtual device turns on and then mirrors the state to the physical device via Smartlighting. So what am I missing?

Trying to create a routine when the Virtual dimmer is turned on to set the inovelli channel 1 (Light) to on, but there is only an option for “Main” and not the channels. Here is the routine options and I believe this is an IOS bug:

Here is the Smart Lighting but this triggers main and all channels to update not individual channels:

I have posted in the Inovelli Community and submitted a help ticket.

1 Like

This seems to be the same problem that I reported a few weeks ago (on a different device).

1 Like

@harobinson I haven’t gotten any feedback from Smartthings or Innovelli on this.

What can I say. Instead of using Automations then you can use Rules which support multiple switches per device. That’s how I solved it for my use case.

1 Like