Inovelli dual channel outlet issues

Nevermind - What I had NOT done is MANUALLY change the device handler after pairing the device. This isn’t actually mentioned in the directions at the URL, so I’m assuming that SmartThings is supposed to automatically assign the custom device handler. In my case, it did NOT automatically assign the device handles, no matter how many times I excluded and re-paired the device.

Seems like you got it. Process is this for individual control:

1.) include device and let SmartThings assign default handler
2.) go to Ide and click into each of the 2 child devices. Delete each one.
3.) change the parent to the custom device handler earlier in this thread. SmartThings will automatically regenerate 2 new children and u will have individual control of 3 devices(the dual outlet, left outlet, and right outlet)

SmartThings really needs to have this as the default handler. Nobody wants three extra clicks to turn off or on a switch. The goal of these products are to make things easier… not more complex. I could go manually turn the switch off by hand quicker than I could dive through the extra menus.

1 Like

Good morning @mtkohl85 – very sorry about this, we’ll update the instructions on our website! I’m not sure how I missed writing that step in there :confused:

Glad you figured it out and if you have any further issues, please let me know. I’m happy to help!


Thank you VERY MUCH for this posting. I followed your steps here and all worked PERFECTLY! My scenario is: I had already installed the switch as per packaged instrux. I am using it for my Christmas Tree lights but needed ‘Devices’ to add to the new SmartThings scenes. I did need to delete the children (Haaa…that sounds funny yeah?) and they added back via the App as per your steps. This is my second Inovelli. My first one is used in my teenagers room connected to a radio alarm clock so I KNOW his alarm is set correctly and goes off. The other channel is connected to an air cleaner in his room so I KNOW it gets turned off when he gets up each day. GREAT PRODUCT!

Thanks for adding those extra steps to their handler process. Worked like a charm!

No problem. The inovelli products are great devices from a great company.

And not to mention, @Eric_Inovelli is always there to give a helping hand when things go a little awry.

Now only looking for the local processing to be added for these.

I am relatively new to ST and am having a hard time following all the implications of this thread. I want to have a Local Processing automations in the Smart Home Monitor framework control the individual channels. Would this be possible with the referenced device handlers (ST default and yours).

Good evening Richard,

First, thanks for taking the time out to write your question!

It can definitely be hard to follow (I’m still learning as well) when you’re first starting out, but this is an excellent community!

With that said, unfortunately with any custom handler (whether it is published by ST or not), you will lose local control.

In our case, in order for the plug to operate correctly on SmartThings, it requires a special handler. It’s been approved by ST and they went ahead and published it. What that means is that when you paired your device, you saw, “Inovelli 2-Channel” show up. If it wasn’t published, you would have seen whatever one ST thought matched our device (which I believe is, “Z-Wave Multi-Channel”) - however that one doesn’t work properly, hence why we created our own.

I’ll continue to reach out to ST to see if they can somehow include our handler so that local processing may occur. However, to my knowledge, there are no Multi-Channel devices that have this capability in ST.

Hope that somewhat helps! And thanks again for keeping the thread alive. I’m hoping someone from ST is reading :slight_smile:

Founder | Inovelli

1 Like

Thanks guys. I didn’t know anyone had replied until just now, I must not have set up my account to notify me (email) when someone replies. In any case, yes, I got it working.

HOWEVER, I had an odd thing happen a few days ago. I had to unplug my Innovelli for most of the day on Friday. When I plugged it back in, it never reappeared in the Smartthings app. Not even the single device. I find this odd, because when I originally set it up, it was plugged into a convenient outlet for setup purposes, but I had to unplug an relocate it at the time and had no issue. But for whatever reason, the entire setup was gone after having been unplugged for many hours. Routines that were tied to the Innovelli remained, but were obviously broken.

I got it set up again and it’s working now - but does anyone know why it was completely wiped from Smartthings?

Hey Matthew,

That’s certainly an interesting situation and I’ve actually never heard that one before. I’ve had a few devices unplugged for quite sometime and when I plugged them back in, they came right back (especially since I test a lot of random devices and then unplug them and forget about them).

Let me know if this behavior continues – I’m hoping it was just a bug or something!

Founder | Inovelli

Like @Eric_Inovelli, I also use the 2-channel outlet to control 2 floor lamps in the living room. However, today I noticed the outlet is not sending commands back to the hub for switch status. I’m not sure if this is called “polling” in ST terms. So, I am able to control the switches either from the ST app or from multiple ActionTiles panels, but because hub doesn’t know the current status, the ST app and ActionTiles panels show incorrect switch status if the on/off command is sent from any one of the apps/panels. I tried Z-wave repair and hub reboot but didn’t fix the issue.

I luckily am not having this problem as I just ran a test to see if the correct data was being retrieved from the SmartThings app after I had made a change from action tiles. Just wanted drop in to say, it seems this may only be affecting certain users at this time.

Hopefully someone here knows what you can try to get up and going again.

Good morning!

First, terribly sorry you’re having issues. Trust me, I’ve been in the same position as you and it’s not fun at all, so I can feel the frustration.

There’s actually a platform outage right now on SmartThings, which may be causing the issues you’re having. I had a couple other people reach out to me via email in regards to similar experiences (ie: switches not showing correct state) so I definitely think something is happening.

Keep an eye on the link above and when they fix the issue, please let me know if you continue to see this behavior. I currently am not experiencing this (I use Action Tiles on multiple tables as well) so I can’t duplicate the behavior, unfortunately.

Either way, we’ll figure this out once ST updates us with a status.

Very sorry again!

I started having a similar issue yesterday with all of my Inovelli 2 channel plugs. Yesterday, they all quit responding to my Amazon Echoes. When I opened the Alexa app and clicked on any of the switches, I got the message “Device is unresponsive”. When I opened the SmartThings apps, all of them had the red dot next to them and said “unavailable”. If I turn off the “device health” option, the dots go away and I can power them on and off within the SmartThings app, but I can’t control them with Alexa.

I have removed all of the plugs from SmartThings and done device exclusions on them within Z-Wave Utilities. I have then re-paired them with my SmartThings hub and they work properly again for an hour or so and then the issue returns. I’ve also rebooted the SmartThings hub and my router.

I’m hoping that Eric is right and that this is an issue on Samsung’s end and that it will be sorted out soon.

1 Like

Thanks. Could a platform outage affect a single device which is the case in my setup?

That’s my question as well. All of my other 25+ devices, including an Inovelli single plug dimmer outlet, are working just fine.

@fenerli and @darthclem – I honestly don’t know the answer to this question. Trust me when I say I completely understand the frustration this must be causing for you and I’m sincerely sorry. We haven’t received any similar complaints until two days ago when SmartThings went down and not everyone is experiencing this.

The only thing I can possibly think of for the explanation as to why only our plugs are effected is because we are using a custom handler (that we published via SmartThings).

What happens when you remove the device and then re-include it?

If you can hang with me through this outage, I would sincerely appreciate it. If it continues to give you issues, of course I’m happy to replace it! It’s just really hard to determine right now what’s causing the issues since myself, my engineers and the rest of my team are not experiencing this on their end, so it’s hard to replicate.

Obviously I want to help – I’m just not sure what to do until SmartThings fixes the issues.

I am having the same problem as of a few days ago: all 3 of my inovelli indoor outlets are showing status inactive, with the red dot. When I tried excluding and re-adding one, it is back online but the outlet on/off status isn’t being reflected back into the iPhone app even though the switch controls are working. None of my other devices attached to SmartThings are having any problems. Thanks in advance!

Hey everyone,

Ok, after talking to an ST engineer, we’ve found the issue and it explains why only Inovelli 2-Channel devices are affected.

Long story short, the calls to the child devices aren’t working properly.

In other words, the call to, “childDevice.sendEvent” is not returning anything and they have confirmed they are still having cloud issues (as you all know our custom handler operates in the cloud – vs locally – because it’s a custom handler)

For more info about the childDevice.sendEvent issues, please see here:

So, while I know this doesn’t help things work – it does explain why it’s not working (while your other non-multi-channel devices are).

Hang in there guys, we’ll all get through it together!



So I’ve just jumped headfirst in to SmartThings with a bunch of new devices and a Hub. I went with Inovelli for my controlled outlets, and I’ve been trying to go the custom handler route to get 3 separate controls. I followed Eric’s instructions here: and ended up with the exact same behavior - 1 master device with 2 sub devices. When I delete them in the IDE then use sprocket/save to re-add, they just come back as child devices. I also switched my custom handler setting to use “self-published” rather than published, but still, same behavior of 1 master with 2 child devices.

I had been using the “factory” provided handler, but I am having the same issue with that one as was described by some earlier posts, but I get the “device unresponsive” and the red dot so I figured I’d switch completely to the custom handler.

I will mention, the custom handler has done one thing better - in Alexa, the Ch1/Ch2 showed up as “My-custom-device-name (CH1)” rather than just “Inovelli… (CH1)”, so at least I can figure out which is which. This is with self-published custom code from erocm123.

I’ll also mention that the “status” of the Inovelli seems to get “stuck” in the app. That is, if I use the master to turn everything on, it sticks at “TURNINGON”, or to turn things off, it sticks at “TURNINGOFF”