Inovelli dual channel outlet issues

Good afternoon @brillat,

Thanks a ton for your support - you certainly picked a great week to jump head first into SmartThings haha! I promise, it’s normally a fantastic HUB and everyone on our team uses ST in their personal home.

Alright, now to figure out what’s going on - if you don’t mind, I’d like to recap what you said, so I can make sure I understand.

  1. You installed the handler made by @erocm1231
  2. However, you still aren’t seeing the child handlers, even after you deleted them in IDE and then re-engaged them via ST (and selected the correct handler)

Is the above correct?

Now, as for the unresponsiveness and incorrect state, yes, this is unfortunately due to the problem in my comment above, “childDevice.sendEvent” not working right now due to cloud issues. We’ll have to stay tuned on this one as the engineers I’ve talked to said they are working around the clock to fix it.

I’m hoping we can at least figure out the top part while we wait for the second part to be fixed.

Thanks for your patience!

Yes, that’s all correct. Custom handlers via copy paste from GitHub, just like your instructions, and I still get the default behavior. I even unenrolled and re-enrolled the device, but it keeps reappearing with child devices.

Also an item that is probably related to the “unresponsive” problem, no history shows up for these devices in the app, that is, it doesn’t show anything at all on the “recently” tab.

Note that even though it shows up as “unresponsive” it still actually works.

Hey @brillat, try this link and see if it works. I had another user have the same issue as you and when he installed this one, it seemed to work.

If so, let me know and I’ll update the link in the NZW37 setup instructions.

As for the latter half of the message, yes, I think you’re right in that the two are related. If I had to take a guess (and I’m out of my league here when it comes to coding) I would say since the call to the endpoints is not working, that would explain why nothing is showing up.

However, I do find it interesting that you’re able to control via Alexa. I’ll pass that on to ST.

So, not only is this working now with all 3 “things” listed, but also, the “unavailable” problem has gone away as well, so good news all around!

The only thing I changed also was the NAME of both apps in the code. I wanted to be sure I knew exactly which version of both the parent and child controllers was being selected, so I stuck a date at the end of the name. Note that this also means I’m not overlapping with the SmartThings existing “factory” controller apps as well, so if this fixes it for anyone else than perhaps there’s some bug in having overlapping script names.

Awesome, that’s great news!

Let me pass this along to others that are affected and see if it helps them. Please keep me posted on the unavailable status. As you can imagine our Amazon page has taken a hit, so I’d like to stop the bleeding!

Anyway, thanks for posting and I’ll look forward to seeing if this works for others.


Mine 3 outdoor showed “offline”, but were working great.
Just now I changed the handler to “Inovelli 2-Channel Smart Plug (Alternate)” and status is changed to “online” and seems to work perfectly.

This is fantastic news – looks promising! Thanks for reporting in :slight_smile:

Hey all – I’ve written some basic instructions on how to install this handler while we wait for ST to fix a few things.

It would be super helpful if you could report back if this works!

1 Like

Just popped in to investigate the same issue being reported here. Glad to see an active discussion going on, good stuff!

I don’t physically control my outlets at all, both my dual channels are operated by WebCoRE, which continues to operate them fine. I was just concerned by the behaviour in the ST app, so I’ll keep an eye here and read that link above.


Installed the Alternate device handler. The device in Smartthings app under My Home shows up with the parent and Channel 1 and Channel 2 as Child Devices under the parent. In the IDE the device handler shows the child devices as Inovelli 2-Channel Smart Plug (CH1) and Inovelli 2-Channel Smart Plug (CH2). When I want to include the device in a SmartApp they show up as Inovelli 2-Channel Smart Plug (CH1) and Inovelli 2-Channel Smart Plug (CH2). Alexa shows the parent as well as the child devices Inovelli 2-Channel Smart Plug (CH1) and Inovelli 2-Channel Smart Plug (CH2).

Hope that is not too confusing but should the child devices in My Home also be Inovelli 2-Channel Smart Plug (CH1) and Inovelli 2-Channel Smart Plug (CH2)?

Are you saying that you don’t see the parent (main) device along with the child channels in the “My Home” section of the app after installing the alternate handler?

If that’s the case, what worked for me was going into the IDE and clicking on the device. I then clicked on both child devices (one at a time) and deleted them. I then clicked “Edit” again, made sure the type was still set to the alternate DTH, and clicked update. This recreated the child devices and they appeared in the “My Home” section of the app after a refresh. Hope that helps!

I figured my explanation was a bit confusing. The parent does show up in ‘My Home’. The child devices are named Channel 1 and Channel 2 and are behind the parent. Everywhere else the child devices are named Inovelli 2-Channel Smart Plug (CH1) and Inovelli 2-Channel Smart Plug (CH2).

I was hopeful on the alternate device handler, and while it is better (definitely have 3 devices shown), but the “unavailable” problem still happens SOMETIMES. For example, an hour ago, it was unavailable. But right now, everything looks totally fine. I’ll also note that the “turningon” and “turningoff” statuses stay around for quite a long time (minutes) after changing state.

Chiming in with the Alternate custom DH. Master and 2 channel switches (all 3) now show up on My Home. I was easily able to change the names of the Child channels from the ST app (can also be done from IDE).

Also confirmed proper function in all of my ActionTiles panels and tablets.

Thanks for the outstanding support on your product @Eric_Inovelli!

1 Like

That did it! Thanks Rabman

Thanks for hanging in there everyone! Hopefully this gets fixed soon, but I’m glad to see the Alt version seems to be helping!

Eric. Thank you for posting this.

This is my very first reply, just joining this incredible great community. I’m new to SmartThings Hub. I do not own a hub but a Samsung Connect Home. I have tried using all Device Handlers for Inovelli 2-channel Switch and I could never make it work to get the child devices appear on the Things list until this new NZW37 Alternate script. THANK YOU

I purchased 3 of these, so far working great. I also encountered this problem reported by many users about devices showing unavailable on SmartThings App, but they used to work just fine after all. After applying this new device handler, it all seems back to normal, and finally I could get the Child devices show properly on the Main Tab by deleting the child device and updating the parent device.

I feel honestly curious about why no one is addressing the Samsung Connect App. which is used to set up a Samsung Connect Hub with smartthings hub included. After setting my first-gen Z-wave devices, they all work fine except the Inovelli 2-channel Switch. It is ridiculous. I added them on the Samsung Connect App, but after being added, they don’t work on this App. Then after opening SmartThings App, they work flawlessly. Even though they share same db at it looks like there is no smooth integration to make smartthings devices work transparently.

I cannot find users on this community mentioning the Samsung Connect Home (Wifi/SmartThings solution) device or this Samsung Connect App. Have you tested this?

Thank you for fixing the device handler script!!!


Hey @Marcus_R,

Fantastic! Glad to have you up and running. Crazy thing is that ST just fixed the issue, so the plugs will work without the Alt version :slight_smile: – but the Alt version does allow for you to put the endpoints on the, “My Home” section which I personally like!

Anyway, yes, the Samsung Connect app… from what I’ve been told by ST is that only official, “Works With SmartThings” (WWST) devices are able to work in the Connect app. They were working on opening this up to, “non-WWST” devices, but actually announced to us prior that they would be moving everything to the ST App anyway, so we didn’t press the issue.

The official announcement came out a couple of days ago:

So, while it is unfortunate that it won’t work now (even our normal plugs/switches, etc do not work in Connect), shortly everything will be integrated under the ST App.

Thanks so much for your support!


Hey, they sure did! Nice!!

I noticed last night that the 2-channel plugs are once again working as they should with ST and Amazon Echo. My tech challenged wife was thrilled that she can once again control our various master bedroom lights via the Echo.