Inconsistent presence detection with iPhones

My wife and I both have iPhone 5S running iOS 8.3 and the SmartThings mobile app is installed on both phones. We have setup presence detection for each phone and when it works, it works great. Trouble is, it is wildly inconsistent. Sometimes the presence detection just doesn’t work and it shows that one of us is home when we’re not (i.e., fails to recognize when the phone leaves the home), and other times it still thinks we’re away (i.e., fails to recognize when the phone arrives home).

The inconsistency is driving us crazy because we cannot seem to figure out why it works flawlessly at times and not at others. Searching online I can see that we are not alone in this frustration.

Has anyone been able to resolve this? Or at least suggest some reason for the inconsistency that we can work around somehow?



If you search the forums for “presence detection” you will find many topics on this. All coming to the same conclusion: it works great for some people and is, as you noted, wildly inconsistent for others. :pensive:

There are various existing tips for things that might help.

Here’s the official FAQ:

I myself switched to using a two device method for occupancy indication. This has proven much more reliable for me, but does require the extra device and is a little tricky to set up.

And one of the more active community topics with various different ideas:

You’re not alone. When your wife issues commands do they show your initials in hello home? Just curious in regards to my issue.

Worked great for me until about 3 app updates ago. They broke it completely. Subsequent updates have helped some, now it is at best inconsistent. No where near as good as it was 6-8 weeks ago.

1 Like

My wife never issues commands. She is more annoyed by my tech fetish and basically just tolerates that apps I install on her iPhone.


You are not alone, pre-1.7 worked flawlessly. Let me guess if you open the app you are then detected properly, this will last for a few days.
I have been in contact with support for weeks and they have told me the problem was fixed in 1.7.2. 1.7.2 did help a little but it’s still not like it was before. 1.7.3 was released yesterday which now has the option to be able to send your mobile presence logs to support. This proves they know there is a problem and can hopefully use this data to form a fix. For me, presence detection is the heart of my setup and it is very frustrating when it fails. I have been contacting them every time it fails and while they have been very nice in their responses, I am not convinced they fully know what the issue is yet.

PLEASE if you have issues, contact them! Don’t just say “well someone else already contacted them”. We need this fixed and need everyone having the problem to tell them so they can work it out.

I’m convinced that the app gets “stuck” and no longer reports your location, opening the app clears it right up. This works fine for a few days then gets “stuck” again requiring you to open the app again. This was never needed on the previous releases.
One of the main fixes I have been told is to logout and log back in especially when you update. My daughters phone has been the most problematic I think because she does not open the app very often. My wife has not updated since 1.6.8 and hers works every time.
Some people have asked them to re-release a pre-1.7 version as a second app just so people can get their systems back up and running, I don’t think this will happen. I happen to have a copy of the 1.6.8 release that I have went back to a few weeks ago and everything works fine but now I am using the latest on the hope I can help troubleshoot and get it working again. My patience are running thin though and may wind up just reverting.

1 Like

For some reason when my wife logs in all of her hello home actions show as issued by my initials. We’ve signed her out multiple times and support says they don’t see her as having signed in.

I am having the same issues. Very aggravating. I have to ask my son all the time to login into the ST app to get it to recognize him. Really thought it was just me. I contacted support and was told to delete him and re-add him. That was a nightmare process. In fact to this day I cannot get him added back in as visible a user in the ST app settings. When I try to add him back as a user it says he is already there but clearly he is not listed. I am reluctant to reach out to support because the last time they said it was not an issue on there end and that I had to delete and re-add. I have given up on the ST presence detection and now I manually switch modes if I cannot have him login. Sad.

I would definitely reach out to them. Aaron has been really helpful from a support standpoint but can only go so far. I had one time accidentally added an account for my daughter in the wrong place and it would not let me set her up in the app because the account already existed. I emailed support and they were able to delete the account and then I was able to create it.
I think it’s worth a try.

Can you try logging out (Menu Icon>My Account>Log Out) and back in to the SmartThing app to re-register the DNI? If you see continued issues with mobile presence, definitely shoot a note to, and maybe the support/relationship therapy team can help her be slightly less annoyed with you :smile:

Yep. My Wife and younger daughter never update apps. theres are the only ones working reliably. Mine works second best because I open the app. My oldest daughter is at school right now, but ST thinks she is at home. Her activity feed for her phone has 2 entries on 4/28 and nothing else.

If you all use the same Apple ID like we do you may be able to pull the app from your wife or daughters phone and install it on yours and older daughters until ST gets this figured out.