Implementing Cooper Aspire RF Panic Mode

Hi. Trying to implement Panic Mode for Cooper Aspire RF9540-N in-wall dimmer switch. This would also be relevant to other Cooper switches which have this capability.

The device implements Controlled Command Class Alarm

The only info I could find as to the implementation states

To set a device into Panic Mode (On-Off flashing at time intervals determined in the device configuration), send a Command_Class_Alarm, ALARM_REPORT command to the device with an Alarm Type of 1 and a value of 255. To turn off panic mode, send the same command as above with an Alarm Type of 1 and a value of 0.

See very bottom of

The relevant configuration parameters are:
2: Panic on time
3: Panic off time
6: Panic mode enabled

class physicalgraph.zwave.commands.alarmv1.AlarmReport allowed parameters are alarmType and alarmLevel, not value

Here’s what I’ve tried:

Added capability “Alarm”

def strobe() {
zwave.alarmV1.AlarmReport(alarmType: 1, alarmLevel: 255).format()


def configure()
zwave.configurationV1.configurationSet(parameterNumber: 2, size: 1, configurationValue: [3]).format(),
zwave.configurationV1.configurationSet(parameterNumber: 3, size: 1, configurationValue: [3]).format(),
zwave.configurationV1.configurationSet(parameterNumber: 6, size: 1, configurationValue: [1]).format()

No errors, but nothing happens on strobe() I wonder if the parameters for AlarmReport need to be something else, but cannot find any other documentation for the capability from Cooper.

Have you implemented this capability on your Cooper switch or would you have any ideas on how to approach this?

Thank you!

Got it working. Config parameters were not getting sent over to the switch. Will clean it up and post the DH.

Where can I find the DH for Cooper panic mode?