Ikea Tradfri Remote Control

I don’t think I’m using an edge driver (I’m not a developer).

In the IDE the remote name is ‘IKEA Remote Control’ and type ‘Ikea Button’.
The route is via the Ikea light to the SmartThings hub. Is this the same for you or are you using a different type?

In case it makes a difference, my Ikea lights are listed as type ‘ZLL Dimmer Bulb’.

try the Edge driver now it supports group binding.
check Ikea Styrbar Remote - #102 by Mariano_Colmenarejo

Is this the SmartThings ZigBee Button Edge Driver?

you need to install Mariano’s Driver and driver for remote. Currently Ikea Stryrbar is supported

Right, that’s why I asked about the other driver for the 5 button remote. Hopefully something will be supported for that soon.

well if you can install the ST cli and get logs , I can came up with the simple driver for the 5 button remote.

but fist make sure your light is using the Mariano’s driver

OK thanks, will give it a try and see if I can get them soon. Appreciate the help.

It you are referring to this button, it’s currently supported by stock edge driver already.


please read the topic, the goal is to have the direct binding (remote<>bulb) without a hub. Plus extended function using the hub.

this is something ST does not publish officially, but it’s part of the Zigbee protocol

1 Like

Apologies, I assumed the goal was local operation and this could be achived by either direct binding or edge driver. But I see the goal is direct binding itself.

1 Like

this is the driver for 5 button remote

What would be the trouble shooting steps for an Ikea 5 button remote that pairs easily to my v3 ST hub, shows up in my Android ST app (the newer app, latest version), reports battery life, but otherwise appears dead (no button presses or holds show up on the ST app, automations (routines) do not respond to button presses, no button presses show up in the live logging in graph.api.smartthings.com. I would be tempted to conclude there is broken hardware in the button but I have another Ikea 5 button remote that behaves the same way. This is all tested with fresh batteries, removing the device from the app, removing batteries, reinstalling batteries, adding the devices back to the app, renaming them, etc. with no change. Meanwhile, I have two other Ikea 5 button remotes on my hub that work great. Thank you for any suggestions.

Try leaving the device in the app, press button 4 times to reset and then add again. It shouldn’t rejoin as the same device and hopefully this time will configure correctly.

Thank you for the suggestion. Unfortunately, no luck. I also tried something I read in another thread: changing the DTH to the IKEA motion sensor, waiting a couple of minutes, then changing it back. That also didn’t work. I’m beginning to wonder if the remote is somehow, unintentionally, paired (by zigbee bind) to another zigbee device in the house and that’s why the button presses aren’t showing up in smartthings but the device itself does. OK, I probably have no idea what I’m talking about!

I’m having the same issue with V2 hub: added the remote, I can see battery percentage but the buttons don’t register any events or trigger any actions.

I’ve tried changing the type:

  • Placeholder (default)
  • Ikea remote
  • Ikea Tradfri remote (from a linked post)

None of them register any buttons.

I’ve also tried repairing it a few times.

Have you tried with Edge drivers?

1 Like

No. How do I install those?

Hi @Ash_Zade are you on the hub beta, if so it may be due to the latest beta firmware release.

I am seeing exactly the same, the device registers and shows connected but no button presses are registered.

I have 5 ikea dimmers, 1 Ikea remote (5 button) and 1 ikea remote (4 button)
The later 2 work fine after removing and adding again but the dimmers will not work.

The dimmers are all the 1st edition so maybe something to do with an older zigbee version.


I don’t think I’m on the beta. I’ve never opted into a beta program. I appreciate all the help btw.

Sorry for late reply

I send you the tutorial to join managed Edge Device Drivers: Preview | SmartThings-managed Edge Device Drivers

After joining edge drivers program you should enroll the edge drivers that you pretend.
For example: (NEW RELEASE) Version 5 of the Edge Beta Driver: Zigbee Switch Mc
[ST Edge/Beta] Buttons and remotes Edge Driver (Aqara,IKEA,Tuya)

Finally, you must add the device again to smartthings and it will associate one of the edge drivers that you enrolled.
Inside the device you can change the driver if you have more than 1 that have compatibility with your device.

Please, keep in touch if you need any more help.

1 Like