IFFFT and Virtual Switch

My goal is when my alarm system is set at night it will automatically turn any outdoor lights off that were left on.

Currently alarm.com sends an email when the alarm is set between 8PM and 4AM. IFFFT successully grabs the email and sends an turn off message to an ST virtual switch. The ST log shows that it received the command but it doesn’t actually turn anything off. IFFFT is authorized for the virtual switch and all the real switches under the virtual.

Will try an individual real switch to see if that works. My hope is to get the virtual working as I don’t wan to have to set up an IFFFT item for each individual light.

Thoughts?

Are you using a virtual or simulated switch? This isn’t specific to your case, but I know when I changed a bunch of simulated switches to virtual, all sorts of shenanigans ensued with WebCore. The issue I found was that WebCore was either not reading or not respecting the current state of the virtual switch but worked perfectly with simulated. Maybe try a simulated to see if that works?

It is simulated switch.

I’m a little confused, what does

all the real switches under the virtual.

Mean in this context? How exactly have you set up the real switches to mirror the virtual?

And can you see the status of the virtual switch change on its things icon in the smartthings app?

Sorry for the confusion. It is a simulated switch that I created in my account on the SmartThings website. In the SmartThings Android app it appears under Rooms and I added the outdoor switches to that. The simulated switch is available to Alexa and when turning it on/off from Alexa non of the lights turn on/off. So there lies the problem. My simulated switch doesn’t do anything.

Just having them in the same room won’t cause them to work together. They are just grouped together for the convenience of the person looking at the app. But it doesn’t make them turn on and off together. That doesn’t have anything to do with Alexa. When you just tap the virtual switch icon in the smartthings app, the physical switches don’t turn off, correct?

You need to set up smartlights automations so that the physical switches “mirror” the virtual switches.

2 Likes

Got it to work. Created routine that includes all the lights which is triggered by the simulated switch which in turn is triggered by IFFFT. Thanks for the help.

1 Like