Hue Dimmer Switch Connected to ST

All of mine are RWL021.

Any chance the switch is still connected to the hue bridge? You will need to remove from hue and reest to attach properly to ST.


Hi Matt,

It’s working now… not sure what i did differently this time though.


I was using this for about a week, but couldn’t get over the latency controlling my lifx bulbs via CoRE, compared to the near-instant control of Hue lights directly… Ended up switching out the 3 lifx in the hallway for Hue white & ambience, and I think the WAF will be much higher this way.

Anyway, I think my main issue was more related to depending on Dimmer -> ST cloud -> CoRE -> lifx cloud -> lifx bulbs. It was leading to unreliable operation, and the response was usually ~3 seconds or so. Feels like a really long time when you’re trying to turn the lights on on your way down the hallway :frowning:

But I may come back to this device later on, it would be nice to be able to have a little remote to run functions or routines from!

1 Like

Thanks to everyone who contributed to this, especially @mattjmiddleton for the pain-free screenshots of how to get it all set up. I think CoRE might have updated and changed one or two things but I figured it out (or perhaps I followed it wrong - where the instructions said “if hue dimmer is pressed, select blah blah” I couldn’t just say “if hue is pressed”, I had to say “if hue buttons 1, 2, 3 or 4 are pressed…” but that’s a minor thing.

Not yet set up any held states, I just wanted a switch for the bedroom light that can live on the wall behind the bed that either of us can operate.

So now for £19.99 I’ve got a four button switch that I bought off the shelf in the UK, rather than £30+ mail order or £20 sent from China in just 60 days…

For anyone reading this doing the same thing as me - if you buy a dimmer standalone, then follow the instructions to pair it carefully. You need to hold a button, search for it, name it, then reset the dimmer with a pin, and search again (don’t remove it from ST, so it won’t find anything, but the light will stop flashing).
I didn’t do this as I thought I knew better - WRONG. The button presses aren’t detected until the second search.

1 Like

There are quite a few button devices available for both the US and the UK that work well with SmartThings. :sunglasses: See the following list. (Devices are generally marked with region.)

No matter what I do, I can not get st to find my dimmer, not even a a generic thing. Any suggestions?

My switch does not connect to Smartthings Hub either, I got a V2 hub

This was just posted by a community yesterday and it works great for me so far. Adds each dimmer as a device for you and very easy setup.

1 Like

My understanding though, is that this solution you’ve linked to requires a Hue Bridge?

Thanks @Sticks18! My understanding of this code you’ve written is to link the Phillips Hue dimmer remote directly to smartthings without a hue Bridge, is that correct?

Initially (Oct 2015) you said that this wasn’t totally stable, how’s it working now, 2 years later? Is this a reliable way for me to use the Hue 4 button dimmer switch with Smartthings?

Also, how does this implementation work compared to this one:

I’m not sure if anything has changed. That remote is sitting in a bin somewhere since it wouldn’t stay connected. The newer integration you link to might be a better option. Hopefully that thread talks about reliability.

Yea, it seems like there’s been a few people saying that the other code works reliably, others saying it doesn’t.

I set mine up yesterday and programmed in two sets of lights. (On and off and one colour so 5 buttons).

It disconnected a couple of times as I was working on it (I think it happened when I would press too many buttons too fast), so I just pressed the reset button on the bottom and then it reconnected.

But it was still working this morning. I’ll post on that thread if it disconnects during normal use.

Has anyone been able to get the Hue Dimmer to pair with a ST2 hub running firmware 18.22?

I’ve been trying with and without a device handler and while the dimmer thinks it is paired (light goes from flashing orange to green) the hub never sees a new device. I can pair the dimmer with a Hue hub and have done both the short reset (1 second on setup switch).

I have a pile of these dimmers and it would be great to use them with the ST hub.

I’ve had a Hue RWL021 dimmer set up for quite some time, using smart lighting to do different things with each of the 4 buttons. It’s been very stable and works well.
I’ve recently tried to add another dimmer - directly to ST, I have others connected to Hue Bridge - and really struggled. Like some other posters I couldn’t get it to recognise more than one button. Tried switching DTH between Sticks18 and digitalgecko but still could not get the “numberOfButtons: 4” to show up in “Current States”.
I finally managed to get it to work by temporarily switching it to the “Zigbee Button” DTH. This added the magical 4 buttons and then when switching back to the Sticks18 DTH it stuck. I’ve now been able to add automations to Smart Lighting that are of type Button, device Remote, and Button number 1-4.
Hope this helps others setting up these remotes.

1 Like

So I’ve struggled this last week on this. I installed sticks18 DH and pair the switch to ST but couldn’t get it to do anything. I then noticed that I wa getting a light on button press so I assumed battery may be dead, replacement battery have not helped. Started again today deleted device, reset it, paired it, set the device type all good but still no lights on button press and looking at live logs ST isn’t getting anything. I’m trying ZHA DH now but signs are that it’s the same. Any ideas?

Doh!! It’s amazing what sitting down with a cup of coffee on a Saturday can fix.

I had missed this simple comment

If you have to assign the custom device type manually, you will need to reset and re-pair the remote by following step 2 above. Do not delete the device in ST! Just reset and re-pair.

Working light a dream

1 Like

I cant find the Hue dimmer switch in the list of device handels?

Hay, im at the same point, I can pair it, change the device type but it doesnt do anything. No battery or switches to select or activity.

You say reset and re-pair without deleting the device but I dont understand how to do that?

I can reset the switch bit it still doesn’t do anything.

Been a while since I did this…

Here are the steps outlined very close to the top of this thread, once paired reset switch and repair as per step 2 .

Once this device handler is created and published in your IDE, you can pair the remote to ST. To pair:

  1. If this remote was a standalone dimmer switch package. With the remote very close to the ST Hub, go to the Marketplace in the ST App (rightmost icon along bottom) and press Connect New Device. Once ST starts searching press and hold the ‘On’ button on the remote until the light flashes green. The remote has paired.
  2. If the remote came paired to Hue White bulbs or step 1 doesn’t work correctly. Use a paperclip/staple to press and hold the pinhole setup button on the back for approximately 10 seconds. The light should blink green/red/green then slowly blink red/orange noting that it is ready to pair. Press Connect New Device in the Marketplace to start ST searching for a new device. The remote will blink green when it joins the network.

I have been using the Hue dimmer switches for a while and a few weeks back I got a new phone and the smartthings app and login in to the new app had all my devices and they are working fine except the dimmer switches.

I have re-sync them to ST but now it does not show 4 buttons anymore. I tried both groovy’s and the closest I get is Sticks18 to show “Pressed, Double Pressed and Held” and that only works for the one button. I also tried other sugestions on here like changing to ZigBee Button and then back and re-sync but to no avail.

Any suggestions?