Hub not showing up on graph.api.smartthings.com

Glad to hear that it is working for you now. Have fun with the custom code! It really is the best part about SmartThings, IMHO (and this Community, of course!)

Dan’s suggestion worked for me as well. Seems very counter intuitive to go that route but it is correct.

Just my luck, it didn’t work for me. I have no idea what happened. It’s been months since I’ve logged in but now I see no Hub. My location shows up but no hub and no devices. This whole mess is rather frustrating and I have a significant number of years of systems and application development under my belt. You’re asked to choose from either of 2 accounts to log in with then you’re asked again which of 2 accounts you wish to log in with only to be finally presented with an actual login screen with both a username and password field. And if that doesn’t get your blood boiling, they hit you with one more log in screen that says “One Account, Enjoy All!” Well I’m definitely not enjoying this one bit. 4 screens just to log in??? Seems very excessive. Then under hubs (where the hub I added a long time ago should be) it says I should use the app to claim my hub yet I see nowhere in this app to do such a thing. Is calling them up my only option at this point?

When did you purchase/create an account with the SmartThings Hub? If was before May it was created using a SmartThings account. If it was after, then you created your account with Samsung. I ask this because you joined community in September.

They are in the process of converting everyone over who had a previously created ST account.

Anyway, if you only created one account, then only one of the links will work.

You need to log off any and all browsers that you are logged in with whatever account you saw no location or hub on, then goto

https://account.smartthings.com

And log in from there. It will redirect you to the appropriate shard (ie: graph.api, graph-na02-useast01, etc…) that your account was created to use.

Your location and hub are not lost.

If you can’t figure it out, then simply give support a call.

2 Likes

I’m fairly certain it was before May. I remember there never being the option to sign in with other accounts. But I’ve already tried what you suggested and even removed my stored credentials just to be sure (even though I created both the same). I can see a location in both but no hub or devices in either. Selecting Samsung account, I do not get a 4th login screen like I do under Smartthings account but on that 4th login. The only thing I can think of is that somehow my accounts are in some kind of awkward state and they’re getting crossed, thus logging me into the wrong one every time. I’ll just give them a call. Thanks though.

1 Like

What happens when you login to the SmartThings Mobile app?

“This” definitely happens. An ActionTiles customer reported it… But a few days later said it all cleared or synced up.

Hopefully Support can confirm there’s no serious issue or hurry the process along…

1 Like

@WB70 The mobile app works just fine.

@tgauchat This is actually good news then… that I’m not an isolated case anyway. Searching for this issue seems to bring up a great many hits; frustrating that they are dealing with it in this way but I’m sure there’s some sort of logic behind it. I’m going to try and give them a call today if I get some free time.

2 Likes

Ok. You will be just fine then. If you are able to see all of your devices from the app, I guarantee support will be able to get you synced back up from the IDE side.

1 Like

I haven’t read through all of this thread but have you tried the following.
Log in at https://graph.api.smartthings.com/
Then click on My Locations at the top and then on HOME in the next screen.
This should take you to the shard that your account is on.
Make a note of the new address and use this for future logons to your hub.

Like I said, not sure if you have tried this but if not, give it a try.

It looks like ST is messing with a lot of this in their consolidation effort. In the past, I have never been able to use this to allow me to redirect and have always used the other page and would be directed to my shard that was useastxx. Now if I click in the link above and it redirects, it keeps me directly on the main shard, no more na02-useast01.

That’s pretty bizarre. Have a feeling this is all part of the account migration and storage of everyone and trying to consolidate everyone into the same place, which comes at a pain for some folks.

Thanks for posting. That might fix the few above having issues. Enlightening.

1 Like

Well this is weird but I called them, they simply had me reboot the hub. I logged back into account.smartthings.com and it showed up. o_0 Oh well, at least it’s showing now. However, at the same time I updated my Gear S3 and installed Samsung Connect… was going to try out the new smartthings integration. However, since my hub is already registered to another account (again, even though it’s the “same” account) it will not register it with Samsung Connect. sigh If my Google sleuthing is accurate, I would have to unregister the hub from my smartthings account, thus deleting everything in it, and register it with Samsung Connect (going through my entire device setups all over again)… only then should I be able to go back and forth between Connect and Smartthings while retaining all my settings and devices. This is utterly ridiculous. There is only one other company with which I risk an aneurysm over and that would be Logitech. If the hardware weren’t in my category of “exactly what I want”, I’d stay far away from them. The logic behind their software (Logitech) and attempts at integration/consolidation (Samsung) completely escape my understanding. I understand that more often consumers are forced to become beta testers but this is rather insane. So anyway, at least I can see my hub in my smartthings account now but as for Samsung Connect on my S3… no soup for me, yet, I suppose. This thread was definitely helpful though, thanks guys.

2 Likes

Thanks a lot. Selecting Samsung account instead of Smartthings account solved my problem. Now I see my hub.

2 Likes

Same problem here. Tried all the suggestions and still no sign of my hub. Using the phone app i can’t add another hub HELP!

You need to be logging into https://account.smartthings.com

This will redirect you the correct shard that you should be on. If it does redirect you to the graph.api… url, then you need to goto Locations and select your Location and then it will redirect from graph.api… to your correct url.

No same result. I must be missing something, when i click on location all i get is the chance to look at the details. I dont get taken to another site or redirected anywhere.

When you login to https://account.smartthings.com what shard (url) do you end up in?

https://graph.api.smartthings.com/

Did you log completely out of IDE before logging into the url I gave you?

And close all browser windows related to IDE.

Are you in the UK or the US?

Most new SmartThings users all have their account associated to a shard like na02-useast1… or na04-useast02…etc…