Hub messes up my wifi


(Roger) #1

I needed to disconnect my ST hub v2 cause every time it’s connected my whole internet speed turns into turtle speed. What’s causing this and how can I fix it cause it looks like I’m the only one with this problem lol


(Nathan Curtis) #2

How close is your hub to your wifi?

Zigbee and 2.4Ghz wifi definitely overlap in channels.

  1. try to keep your hub away from your WiFi AP
  2. try to keep your wifi and Hub off of overlapping channels. You can’t change your ST hub’s channel but most Wi-Fi APS allow you to change the 2.5Ghz channel…

#3

I’m sure that’s very frustrating. :disappointed_relieved: It’s definitely not normal. WiFi is so Much more powerful than zigbee that it’s very difficult for zigbee to interfere with Wi-Fi: it’s almost always the other way around.

I would suspect instead that it’s actually an ethernet issue and for whatever reason the hub is hogging all the bandwidth.

I suggest just getting in touch with smartthings support. They should be able to see if your hub is doing anything unusual.

https://support.smartthings.com/hc/en-us


(Qvae) #4

it’s unlikely, but can happen, but what might be happening is simply an IP conflict between the hub and the device that you are actually trying to use. Log into your router admin and look at what your hub IP is and if anything else is using that IP or has a blank IP…or if your hubs IP is blank. If that’s the case, just assign everything on your network a static IP, that’s what I did because of conflicts with my entertainment systems. You’ll have to research static IP if you are unfamiliar. Good luck.


(Roger) #5

Looks like things improved when I moved it to a different room than the router.