HRT4-ZW / SRT321 controlling Z-Wave Device Multichannel 2nd channel (Fiabaro FGS221)


(Alan) #1

Hi

We have a double relay zwave switch from Fibaro FGS 221
We also have two SRT321 zwave thermostats

Both devices are connected to the smartthings zwave network.

We are trying to set up the association between the first thermostat at S1/O1 of the relay switch, and the second thermostat to the S2/O2 relay switch.

We’ve succsfully set up the association on the first thermostat by putting it into “A” association mode, and flicking the S1 switch 3 times on the relay switch.

However, the problem is with the second thermostat.
Flicking S2 3 times doesn’t seem to do anything, so the only option is to flick S1 which also assocates the 2nd thermostat with O1 instead of the desired O2.

I’ve logged into the web portal edit both the thermostat devices, to try change the userAssocatedDevice to the node associated with O1 and O2. So the first thermostat I’ve set the userAccociated Device to “0A-ep1” and the second thermostat is set to "OA-ep2"
I’ve left them to ensure the wakeup has been called on the devices and would have expected them to be aware of these configuration changes.

However, the second thermostat is still switching the O1 and not the O2

There switch is setup as a general "Z-Wave Device Multichannel"
The thermostats are setup as “SRT321 Thermostat” type using the device handler provided by meavydev

Any ideas on how I can get the second thermostat associating with the O2 on the dual relay switch?