How to stop echo speaks in the middle of telling story

Hi ,
I have couple of pistons that when I detected an intruder it flashes the lights and do some other things.
I want to add echo speaks so when intruder detected it will talk or play a song or something so the intruder hopefully will think that people in the house and leave and if he get in it will play some crazy audio that hopefully will make him run .

The problem I’m facing is that I cannot stop the playback once it’s started .
I used command PlayTellStory() and it started but then I wanted to stop it once I disable alarm so I used stop or mute and unmute but it didn’t work .

What am I doing wrong ?

Thanks

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.