SmartThings Community

How to get Samsung motion sensor to turn on light?


(Charlie) #1

I’m following the same procedure in this Youtube video and it’s not working. I created a turn on and off light routine in the app but when motioned is detected nothing happens. Any suggestions?


(Jimmy) #2

Wow that video was annoying. And isn’t showing the reccomended method either. In the Classic app, go to the marketplace and under SmartThings reccomends use Smart Lights. Also check and make sure your motion sensor is registering motion events correctly.


#3

Here is the official knowledgebase article. It has instructions for both versions of the mobile app. :sunglasses:


(Charlie) #4

Under SmartThings Recommends, it has Light Bulbs, Locks, Outlets, and Thermostats only. There is no Smart Lights option.


(Charlie) #5

Where do I find the “Smart Lights”?


(Jimmy) #6

choose the SmartApps tab, not Things


(Charlie) #7

Thanks for the additional clarification. Okay, so I got it created but when I clicked save and done. I do not see what I’ve just created under Dashboard, My Home, Automation/SmartApps tab, Automation/Routines tab, or Marketplace SmartApps tab. Where do I see the routine so I can later refine/edit?


(Jimmy) #8

You should have an entry under Automation >Smart Apps called “Smart Lighting”


(Charlie) #9

Thanks, Jimmy! I’ll test it tonight.


(Charlie) #10

How do I override the routine? For example, sometimes I want to always have the light on regardless. Is there a way to do this instead of simply removing the routine? It would be best, for example, if I manually turn on the light then regardless if the sensor sense motion or not, the light will always be on.


(Jimmy) #11

A couple options:

  1. create a mode (i.e. “Automations Off”) and set the automation to not run in that mode
  2. create a virtual switch and set the smart lighting rule to not run when that switch is on
  3. add additional sensors/devices and make the rule more robust

(Charlie) #12

How do I create a mode? Is it under Automation/SmartApps? And how do I create virtual switch? What are the differences between mode, rule, routines, and scenes?


(Jimmy) #13

(Charlie) #14

So, how do I configure different modes? I don’t think I’m using the classic version. On the icon, it just said SmartThings.


(Jimmy) #15

You have to create modes by logging in to the ide. Https://account.smartthings.com


(Charlie) #16

Okay, I think I need more info on this. Okay, let me know if the following steps are incorrect.

  1. Log into SmartThings IDE
  2. Click My Device Handler
  3. Create New Device Handler
  4. In the Name field type something like Automation Off
  5. In the Capabilities, check Switch
  6. In the Custom field, what do I type in? Or do I need to type in this field?
  7. Do I need to put anything in the Join Fingerprints field and Device Handler Settings?

Help is much appreciated. I think it’s pretty much useless if there is no way to override the sensor. Imagine you’re washing dishes and all of the sudden the whole kitchen goes dark. That’s very frustrating.


(Jimmy) #17

Device handler is the wrong place. Go to location tab.


(Charlie) #18

Thanks for that clarification. Okay, so how/where do I “set the automation to not run in that mode”?


(Jimmy) #19

It’s at the bottom of the smart lighting rule under more options.


(Charlie) #20

Thank you so much for your patience. So, I found the mode “Kitchen Automation” under More Options/“Only when mode is” and I set to “Kitchen Automation”. However, where do I change it to “not run”?