How to get a WeMo Switch back online?

I have a WeMo switch which is working with the WeMo app but offline in ST app. Not only is it offline the WeMo connect doesn’t show the correct name. it shows the old name before it was removed from ST and WeMo app and repaired with a new name and IP address. I can’t get the WeMo connect to show the correct name. Any suggestions would be welcome. Here is what I tried.

  1. Turned off power to switch, turned back on
  2. Used button on device to restart WiFi
  3. Used ST to try to find the device with Labs WeMo connect

I don’t want to have to remove all my WeMo devices and the Connect app as I have many automations. I am hoping Super LAN Connect will be released soon as that is my only hope unless someone has any ideas.

You can use [RELEASE] Enhanced Wemo (Connect)

Do I have to use all the DH or just the SmartApp? I installed the SmartApp and it can’t find all my devices. It found 1 out of 4. Do I have deselect them in the old WeMo Connect? OK it only found one device I checked it and when I went done it threw an error. Any ideas?

Also what are the settings for GetHub I tried:
Mujica SmartThings,Ule/wemo . Master

You must to use the smart app connect (who search the devices) and every device type you have , if you only have a switch you only need the switch device handler, etc

You must to confirm your wemo devices are visible, they must to be config correctly with the wemo app, I suggest you to use the ios app Browse UPnP to verify your devices are availables.

Would you please provide the IDE Github settings? Thanks.