Honeywell ZW3005 Dimmer Fade Rate

I have 5 Honeywell ZW3005 Z-Wave Plus dimmers (made by JASCO) connected to a SmartThings v3 hub. When I turn them on or off through the SmartThings mobile app, they instantly change to whatever level is selected. This occurs through the On/Off button in the application or when in a scene.

These are for a theater where I would like a smooth fade to the newly selected level. I have tried several DTH including Chris Nussbaum’s Nutty-SmarthThings. None seem to be actually able to change the fade rates, despite many having the parameters to do so. I contacted technical support for JASCO and SmartThings and both said it was impossible.

I have tried Leviton DZ6HD which work a bit better (that is their default fade rate is not jarring)

Has anyone been able to setup these dimmers to have slow fade rates recently (last 12 months)?

Updated status…

I found that using the SmartThings Classic app with Chris Nussbaum’s Nutty-SmarthThings DTH did allow me to set parameters on the Honeywell ZW3005 Z-Wave Plus. However, the resulting fade rate is jittery.

I tried also the Leviton DZ6HD with Jason Xia’s DTH (jasonxh - Leviton Decora Z-Wave Plus Dimmer). I was able to change the fade rate using the Classic app. The Leviton DZ6HD has a very smooth fade which would solve about 50% of my problem. However the fade rates on both of these seem to only apply to On/Off, not to anything triggered from a scene. Other postings seem to come to the same conclusion, which I assume is a fault of the ST implementation (using setLevel without the ability to supply a duration parameter).

Most Z wave devices have two different parameters for fade rate and ramp rate: one which is used when the switch is physically pressed and one which is used for network commands such as scenes.

If you get the parameter setting information from the device manufacturer, you should be able to set them with the Z wave tweaker.

[BETA] Z-Wave Tweaker

Remember that you need to set both the number of steps and the interval. If you only have one step, it doesn’t matter what the interval is it’s going to jump to 100% each time.

From one manufacturer:

Dim Rate Adjustments
Both the number of steps (or levels) that the dimmer will change and the timing of the steps can be modified to suit personal preferences. The timing of the steps can be adjusted in 10-millisecond intervals. As an example, the default setting for parameter 8 is “3”. This means that the lighting level will change every 30 milliseconds when the Dim Command is received. A value of 255 would mean that the level would change every 2.55 seconds. Combined, the two parameters allow dim rate adjustments from 10 milliseconds to 4.2 minutes to go from maximum-to-minimum or minimum-to-maximum brightness levels.

And don’t get confused about zwave “setlevel.“ That just means the device is dimmable. It doesn’t tell you whether or not the ramp rate is adjustable.

Thanks @JDRoberts. I tried the following for the ZW3005

  • zwaveSteps = 1
  • zwaveDelay = 50
  • manualSteps = 1
  • manualDelay = 50

and indeed it takes about 50 seconds to dim from 99% to 0% when using the On/Off button in the app (either version). That is what one would expect 50x10ms = 500ms. The fade rate is working using On/Off in either app. However, in the ZW3005 each change is associated with a flicker in the bulb (I am using LEDs). I imagine if I were using incandescent bulbs that flicker would not be noticeable. It is more noticeable in the lower levels of lighting. The Leviton DZ6HD seems to have figured out how to smooth out those level changes with the same configuration.

So while I’ve succeeded in setting device fade rates that work from on/off button presses in either app, when I tie them together in a scene and turn on the scene, the levels jump from wherever they previously were to the new level without any intervening steps. I found other posts mentioning this problem.

The reason I mentioned setLevel was that I thought v2 introduced the << duration> > parameter:

zwave.switchMultilevelV2.switchMultilevelSet(value: level, dimmingDuration: duration).format(),

I am still new to this, so I appreciate all your feedback. Now wondering if I should be looking at HomeSeer or Hubitat hubs which both seem to be have built in support for fade rates within scenes.