SmartThings Community

Honeywell WiFi Thermostat Setup Guide

honeywell
thermostat

#18

You need to create a Device Handler, not a device. That should fix your issue.


#19

Great, how do I do that?


#20

Same website you were at earlier, here is a direct link. It is best to familiarize yourself with it.

https://graph.api.smartthings.com/ide/devices

click on “Create New Device Handler” then you will see “From Code” and from there you can paste the code.


#21

I tried that, Device Handler is not present, it’s simply not listed as an option. My screen reads: Location, Hubs, My Devices, Documentation


#22

[deleted] .


#23

sorry these are more detailed


#24

Yeah, so that’s great once you get to the area where it says create a Device Handler, but my screen does not show “Create Device Handler”, or anything of the sort, that I can’t really do much with that. The key here, is that Device Handler is not showing on my screen. It mentions to log in to developer account–How do I do that? How do I create one? I have logged in and created some profiles for other devices in the past, so I don’t know if that means I have a developer account or not. Can’t seem to find “Log in to Developer account”. I would guess that is where the problem might be.


(Bob Strenger) #25

You should see the following options in a bar at the top of the web page.
“My Locations - My Hubs -My Devices - My SmartApps - My Device Handlers - My Publication Requests - Live Logging - Documentation”

If you’re not seeing that, I have no idea. I’m not logging into anything special. simply going to the following link an logging in here: https://graph.api.smartthings.com/login/auth

After that, if you’re still not seeing what I listed above (in this reply, )I’d recommend you file a support ticket with SmartThings to help. To me, that’s not normal.


#26

what steps did you follow and where did you create your account?

was it created here:
https://graph.api.smartthings.com/


#27

The Developer account was the issue–I don’t know what steps I used to create it, as I did it over 2 years ago. I had to click around, go to developer tools, find BECOME A DEVELOPER, click on a link, and then it said ACCESS GRANTED–so it looks like I wasn’t a developer. Once I clicked on the link, the other menu items appeared, to include Device Handler. I will now give it a try. Thanks :slight_smile:


#28

TOTAL CONNECT API is still not there, TOTAL COMFORT API is however there, twice. Is that the same thing? Are the two entries the same?


#29

just make sure u have the latest code from the first post and follow the instructions :slight_smile:


#30

Right, that is where the problem is—The instructions call for selecting TOTAL CONNECT API from the list from TYPE. That label is not there. However, there are 2 listings of TOTAL COMFORT API, so I am asking, is that the same thing? If so, which one do I choose (they are right on top of each other at the bottom)? I just picked one while I have been sitting here, and when I went to complete it, I got an error message that states SOMETHING WENT WRONG.


#31

Delete what ever you have in ST for Total Comfort API, then follow the instructions at the top. Pay attention to the name of the device handler that is created. That is going to be the same name you select later on in the drop down. The name can be anything, the goal is to make sure you are using the correct code and selecting the correct device handler for that code. The device handler will be at the bottom of the list just as its noted in the first post.


#32

I have followed the instructions listed above, exactly how they are listed.
I was able to add it now by selecting TOTAL COMFORT API, which again is NOT what is listed in the instructions. It is listed under my THINGS, however the Temperature and and other areas are now just blank. there is a fan Icon with AUTO (its green at current), another greyed out circle with a leaf, two versions of greyed out up and down arrows, A red circle that says HEATING, another blue circle with a fan on it, and a greyed refresh icon (U turn arrow). There are 3 empty boxes at the bottom and top, with a – in the middle. That’s all that I have showing.

My concern is that the TOTAL COMFORT API is not the right setting, as TOTAL COMFORT seems to refer to a different Honeywell model, than TOTAL CONNECT. Either which way, I can’t really do anything with the app in it’s current state–Not sure where to go from here.


(Bob Strenger) #33

The directions have helped countless others and I’ve done my best to help people with an otherwise far more difficult process. I can’t guarantee some part of the process didn’t get changed. You have to look beyond that sometimes.


#35

I’m with you SuperBob, the directions were fine. The only thing is the specific TYPE Total Connect API is not there, so I don’t know what that’s all about. The Total Comfort API is there, and that is ultimately what I selected in absense of anything else, however it appears to not be working. The directions are pretty straightforward, don’t know what to say. Who is the person/party that would put the Total Connect API in the list? Maybe they took it out?

I spoke to Honeywell in January at CES, and they mentioned they would be bringing on support,to include this line of thermostats with systems like SmartThings. In fact, the rep stated they get calls about it every week. It was supposed to hit 1Q2016, so when I saw this post originally, I thought maybe they had got it figured out.


#36

did you click on the refresh tile as mentioned in the first post? did you edit the device in the mobile app and make sure the settings mentioned in the first post are correct? did you look at the logs in IDE as you created the device handler and hit refresh?

For the record my device type is also “Total Comfort API” and I have the same code you copied from Github and all works well for me.


#37

I did, but that is interesting that you used that different type and it worked for you. What thermostat model do you have?


#38

I have a RTH8580WF but it uses the same API you are trying to connect to :wink: I think you need to tinker more to get it to work. I bet we are using the same code if you used the github link from the first post.