Honeywell Evohome UK / Smartthings Integration


Been using Evohome and Smartthings together for some time, using the codersaur App and Device Handlers. Moved over to the new App seemingly OK.

In the past week though, noticed that the pistons had stopped changing the temps when the mode changed. So have been doing some digging.

Tried alternate apps, etc. Nothing made any difference.

As a hail mary, tried deleting one of the Thermostats with a view to adding it back in (in case there was anything lingering around). No option to add it back in again. So clearly (in my head anyway) the obvious thing now was to delete the original evohome app. This has taken all the thermostats with it, leaving me with none. Tried adding an instance of the app back in, it connects fine, but now cannot see a way to add the thermostats back in as devices. There are no real notes in this respect on the GitHub and honestly cant remember if we did anything special last time. Tried just adding Devices, but its limited to only one type of thermostat for Honeywell, and thats not ours.

Anybody with any ideas?

Go to the bottom, read the last 100 posts. You can make it work, only to set the temperature, but nothing more. Also the card outside doesn’t work.


Thanks for coming back to me. I read that thread earlier but my problem seems more fundamental in that I can’t physically add the devices back in so I don’t even have the luxury if it works or not.

I’m still tinkering to see if I can make any difference to it. Will revert if I do.


Check the threat again, i posted a modified handler a few hours ago