Home Assistant smartthings integration - all devices unavailable

I am a home assistant user and have been for a while … some time in the past I had the smartthings integration running but decided to remove it as it didn’t help much. As I now have some additioanl smart tags I wanted to give it another go so tried the install again … (SmartThings - Home Assistant) … all of the devices (13 of them) I have show up in the device list in home assistant when I enable the integration but the status of all of them in home assistant is “unavailable”.

The error in the log I see is WARNING (MainThread) [homeassistant.helpers.dispatcher] Unable to remove unknown dispatcher <bound method DeviceBroker._event_handler of <homeassistant.components.smartthings.DeviceBroker object at 0x7f9b048feaa0>>

I tried regenerating my token but still the same issue.

I followed the process to download and run a python script hass-smartthings-remove · PyPI which, after much messing about with different versions of python and different instruction sets I believe I have done (eg the script ran without an error). I checked by using an old token that I previously deleted from my samsung account and got a “not auth” error so as it did not return an error from my current token assumed it worked ok

Anyone got any wisdom on solving this or is the only approach to just give up and do without it …

I have searched through various posts on the topic and found I need to become familiar with python

tagging @nathancu @philh30

1 Like

Did you use the token removal tool before trying to set up the integration again?

Hi - Thanks - I used the delete function on the smartthings page showing the tokens
https://account.smartthings.com/tokens … I don’t know if you mean the same thing. I also ran the python script that is supposed to tidy up … if there is something else I should have done then please let me know.

Finally managed to get this working … multiple runs of the delete script, reboots of HA and it finally installed (6th smart token) … I found what you meant by deleting the smart app in “automations” of smart things - that was not intuitive as I expected it to show up in “linked services”

It all seems a bit flaky …

Disappointed to find that smart tags are not supported as that was the driver to try again.