Help with the CT101 Termostat

Hi all,

I am new-ish to the SmartThings community, I am familiar with the android app, the Ide site, and can copy/past device handlers.

Sorry if this issue has already been addressed else where, but I could not find anyone having this same issue or if the did mention it it was in a tread of 700+ comments.

1.The issues I am experiencing is, I installed the CT101 and CAN get to to add to my hub. It will poll and read the status of the battery and the current temperature, but it will not allow me to control the thermostat from the app. Such as, when I want to turn it on/off or change the temperature. If I go to the thermostat it self I can manually turn it on and change the temperature there, but not from Smartthings. When it originally pair it paired as the CT100 and used that device handler, not the CT101. I have tried the Z-wave thermostat and the Z-wave thermostat with battery stats handler, but neither one helped with the issue of being read only and not able to control the thermostat.

  1. The thermostat will randomly become unavailable in the app, but once I start finger jamming things on the thermostat it will normally link back up.

3.I have tried to use the general device exclusion to remove the thermostat and add it back on to my network multiple times. Some times is will say that it has been removed from the network, but the “link” will still be displayed.

The thermostat being ran with batteries only and does not have a c wire.

Any suggestions or help would be greatly appreciated

1 Like

Sounds like you thermostat hasn’t paired properly. Most likely the thermostat is too far from the hub, bring it closer to better yet add a z-wave repeater in between. It’s best if it’s powered via C-Wire instead of batteries for a better experience.

If you’re going to exclude it, after excluding reboot your hub before pairing it again.

1 Like