Help with my zigbee light bulb code (Ecosmart) but would work with others

Awesome, thanks for the update!

Hey @workmonk I noticed that the presets at the bottom of the colour “wheel” are all white and a yellow and orange. Is there a way to change these presets to the other common colours? Sorry for my ignorance if this feature is there and I’m just missing it.

Never mind. Just found out if you swip to the left you find more presets. Just giving other’s a heads up incase I wasn’t the only fool who missed this. Lol.

1 Like

I’m just regurgitating from another thread for the Ecosmart RGBW lamps but thought maybe someone in this thread might be able to help, see below.

Wow these lamps are weird (RGBW anyway) I’ve tried every device type in IDE and the ones here and no matter what they can’t get whites correct, and never turn on 100% from a routine or Smart Lighting.

Also with any device type when I run a routine or use Smart Lighting it will show the correct color temperature in SM (but the bulb is way off) and if i just touch the slider in the position it’s in the lamp will go to the correct level and temperature.

Any one have any input…?

Thanks for the tip! I had no idea! Ha

I’ve also had issues where the colours are off when using a smart app, but I honestly haven’t tried to fix it. I have Circadian smart app on most of my lights and so sometimes it overrides the other apps and that was my guess as to why mine were doing funny things.