Help Removing Alexa Helper

It appears I’ve messed up installing and configuring Alexa Helper and now would like to remove it. I currently have two virtual switches created and one scenario. I’ve tried removing the virtual switches from the ST app but that fails with no error message.

When I attempt to delete the scenario using the ST app I receive “unexpected error”. Attempts to remove the virtual switches using the IDE result in “Invalid http status code returned: 503”. If the scenario itself is accessible from the IDE I have yet to discover where.

Is there another process that will allow me to delete these items? Your help would be greatly appreciated.


I’m sure that’s very frustrating. :disappointed_relieved: Whenever you have a problem with a custom smart app, you will get the quickest help if you ask in the author thread where you got the original code. Not only will the author get tagged when a new post is added, but other people who are using the app may be able to help. :sunglasses:

First, why would you want to unistall it …haha…sorry…had to be ‘that guy’.

Anyway, there is a specific order in which things need to be removed:

  • First, remove all switches from the Scenarios…this is VERY important
  • One at a time, remove the scenarios…If they fail to go away, you can do this in the IDE
  • Next, in the IDE or in your SmartThings app, delete the individual virtual switches you may have created with Alexa Helper. Now, here is a caveat…if you use that virtual switch in any other app you and you can’t remove the switch then you MAY not be able to remove the app. Check other apps like CoRE to see if you are using them

Once all of the switches and scenarios are gone you SHOULD be able to delete the app.

Sorry this is so difficult.

1 Like

Hi Michael,

Those are pretty much the steps I tried. Oddly, about an hour after I posted my help request I went back and was then able to delete the virtual switches (without error this time) and then was able to remove the scenario. Something changed, obviously.

There’s still something off though – when I attempt to select the “MichaelStruck : Alexa Switch” device handler from within the IDE I get an error stating “Access Denied. We’re sorry, but you are not authorized to perform the requested operation.” I can still select either of the Alexa Helper SmartApps in the IDE without error. I suspect this is an issue where SmartThings support will need to get involved.

Thanks again for your reply. I do really appreciate your dedication to the project - not something I see very often. Oh, and I only wanted to uninstall so I could re-install and get it right this time. :slight_smile:

It still sounds like you have a switch that is being used somewhere else in your smartthings app…I am glad, however, it is looking better. Let me know how you make out with this.

@MichaelS Same problem here. Unable to remove the device handler in IDE and getting a Access Denied error. The smartapp removed successfully as well as the virtual switch and scenario. However, I had one of my other devices tied to the scenario it created. Could that be why it is giving the error? I’d rather not remove and re-add the device because of this but will if that’s the only solution.

When you say device, are you talking virtual switch?

Checked the IDE just now and although it gave me Access Denied last night, it’s suddenly not in the Device Handler section anymore. Who knows…

I have seen that a few times where if there is an issue on the ST side things ‘magically’ happen.