Help needed with Sylvania dimming switch to use two buttons

The zigbee Button installed in your hub is the production driver and It has not activated your fingerprints.

Note the driver has not channel download assigned.

You need install it from smartthings beta channel


In case you need the beta channel link:


Thank you!

1 Like

Thanks you!

1 Like

Another question. I have some virtual switches I made years ago. They still show as “virtual switches” in the ide and haven’t switched over to “placeholders” like most things. Am I going to have to delete those and recreate them some other way manually?… or will they convert automatically still? I have a few older smartthings contact/tilt/vibration sensors that did not automatically switch over too. Has everything that could be automatically migrated already done so and anything left I’m going to have to figure out manually at this point? Thanks

The automatic migration is not yet complete.

The only official mention of virtual devices is that they are looking into it. :thinking: So we don’t yet know if they will be automatically migrated or not.

If you want to manually create your own replacements, here’s the community FAQ on that:

FAQ: Creating Virtual Devices Without the IDE

Did you ever get this to work?

I have the same problem you have with Sylvania/ OSRAM Lightify 2 Button Dimming Switch. I was using it as a device that had Single Press, Double Press and Hold for both buttons. It seems some of our custom DTHs and their settings got migrated and hidden as I couldn’t find the settings for this switch and figured I would remove it and re-add it and see if it would let me reconfigure it.

It come up as a dimmable device now and there is not option for a driver, even if I install the beta edge driver and delete and re-add.


I have the same problem and removing and re-addind doesn’t help. I have 2 other switches that work and are listed as “ZigBee button”, but the one I tried to remove and re-add will not recognize the Edge driver.

I believe because the ID is wrong in the Edge driver.

It should be listed as “OSRAM Lightify Dimming Switch” the shouldn’t be a forward slash.

To be clear, I mean the driver lists the device ID incorrectly.

Do you know who can I contact to have them update this?

Hi @jabbajawz

Device in stock driver is this

- id: OSRAM/LIGHTIFY Dimming Switch
    deviceLabel: OSRAM Button
    manufacturer: OSRAM
    model: LIGHTIFY Dimming Switch
    deviceProfileName: two-buttons-battery-holdTime

You can install zigbee thing Mc driver to see fingerprints of your device

That’s what I’m saying. I already installed the Mc drivers to get less check in time and make my buttons last longer, but it doesn’t “fingerprint” because the stock driver has a slash in it.

I have looked up my device ID in the “Simple” device viewer and there is no slash. So it wouldn’t work because the IDs don’t match.

I don’t have a driver for buttons, only for the smartthings button samjin.

The id field is not used to pair device.

Only manufacturer and model fields are used to match and pair devices

    manufacturer: OSRAM
    model: LIGHTIFY Dimming Switch
1 Like

Aw Man… I thought I was on to something. I can’t use the “ZigBee Thing Mc” driver because there is no driver option. And the Simple Device Info Viewer doesn’t show a model field.

I still believe the “finger print” for the ZigBee button is wrong because there is no other Osram Lightify 2 button switch.

I guess I need to figure out how to find the model and maybe make my own driver if I want this to work.

Thank you for the timely responses.

The driver option does not appear in the menu or does it not show the zigbee thing Mc driver as compatible?

If not appears the driver option then is using a DTH and can see the fingerprints in IDE

The driver option does not show in the menu. It is also listed as DTH in the simple device info viewer.

It’s fairly common for a device which has the same model number on the box and looks exactly the same physically to be sold with multiple different fingerprints for different reasons. Usually they represent different firmware levels, but it can also be an OEM issue. Or just a matter of being sold in different distribution channels or regions. You can find several examples in the forum of devices that have multiple possible fingerprints, but since the fingerprint needs to match exactly, the drivers need to be updated for each.

Also…as it happens there are multiple Osram lightify 2 button switches manufactured, but they are sold in different regions, so most individual users will only know of one.


You make some good points, but I am familiar with both switches, but one is described as a “switch mini” while the one I have is sold as a 2 button dimming switch.

But you are right. The identical looking device sold under the same name could have a different model. I just need to figure out what that is.

1 Like

So I installed the Smartthings CLI and pulled the device information for my Dimming Switches that isn’t “fingerprinting” to the beta driver Zigbee Button. Below is the info that was pulled.

name": “OSRAM Lightify Dimming Switch”,
“label”: “Living Dimming Switch”,
“deviceManufacturerCode”: “OSRAM”,
“manufacturerName”: “SmartThings”,
“deviceModel”: “LIGHTIFY Dimming Switch”,

My plan was to create my own duplicate Zigbee Button Driver with the correct “fingerprint” information. Based on what you said above, my device should already be matched to the Zigbee button from the Smartthings Beta Channel, but it is not. It’s just showing as DTH.

2 out of my 3 switches work, but none of them fingerprints correctly. They all show as DTH. The only difference with the 1 that doesn’t work is that I removed and re-added it thinking that it would match a driver and it didn’t.

Unless SmartThings should be the manufacturer in the driver for it to fingerprint correctly.

Your device match with stock zigbee button driver fingerprints and must works fine

- id: OSRAM/LIGHTIFY Dimming Switch
    deviceLabel: OSRAM Button
    manufacturer: OSRAM
    model: LIGHTIFY Dimming Switch
    deviceProfileName: two-buttons-battery-holdTime

Try the steps in the following post. Do all 10 steps, including checking the IDE after removing the device. (Some people have found that a ghost remains that won’t go away until they delete it through the IDE. It doesn’t show up in the CLI listings, but it’s still enough to derail a new pairing.)

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022) - #3 by JDRoberts

Is the deviceProfileName a part of the fingerprint? If so that could be the problem. By looking at the fingerprint for my other devices that have a driver, the profile name for the button would be RemoteController. This seems to be the section that matches the deviceprofileName

“categories”: [
“name”: “RemoteController”,
“categoryType”: “manufacturer”

I thought IDE was shutdown? Is there someway to still access it and the custom DTHs?

I have done everything in the 10 steps except Checking IDE, because I cant. Still Doesn’t work