Help - Hub is on a different shard from App/IDE

(reposting as Akismet locked my previous thread while I was trying to upload photos)

I have two Hub V2s bought around 2015/2016 from the US.

They exist on graph.api. When I log into accounts.smartthings on my computer or my app, I get redirected to graph-ap02-apnortheast2.api. My hubs are not here. See image attached:

Trying to access their location on graph.api throws up a 500 internal server error:

  1. URL: /location/show/c9b78011-a76b-4358-be11-0d9d4e52dd3b
    Reference Id: 63c291a2-1489-48a6-96be-079e05027814

  2. URL: /location/show/40659464-8e44-451b-b381-b03761282cc4
    Reference Id: 97970b64-c0f7-4440-8ddb-a009917a2efd

The disappearance of the hub/devices from SmartThings app happened abruptly. I am not sure what is the trigger.

Some devices are no longer registered/showing up on the devices page.Some active devices that are there do not have event logs updated on the devices page (common stoppage time of event logging).

I am physically not available to reset the hubs as I am in another country. My property manager is not computer literate enough to reset the hubs and re-pair every device and set up all the automations from scratch.

Apparently the current automations still seem to work even though some of the devices do not show up on IDE (cannot verify this accurately).

Wondering if the following can be done:

  1. Migrating my hubs from graph.api to graph-ap02-apnortheast2.api on the backend. Apparently when I create a new location in graph.api, it automatically appears in ap02 as well, so I am not sure why my existing hubs don’t show up.

  2. Forcing my app to connect to graph.api. I tried doing this through VPN, but it appears that I get redirected to ap02-apnortheast no matter what country I try to spoof myself as being in.

Would really appreciate some help here, thank you very much!

Tagging @Brad_ST for help (as someone previously did on the locked thread).

Thank you!

Can you check again? The locations were removed from the service that presents them, I re-added them to the service and they should be working now. I am not sure how they got deleted. Is it possible a shared user tried deleting the locations?

  1. The only way to migrate would be to delete the hubs/devices/locations and recreate them. New locations show up in ap02 as your Samsung account is registered in AP. The locations must have been created manually in the IDE or were created in the Classic version of the app.
  2. A VPN wouldn’t impact this. As mentioned above, your account is registered in AP and that’s what dictates the server region.

Hi Brad, thanks for your help! The locations do indeed show up in ap02.

However, the hub and devices still do not exist in ap02, only in original graph.api.

Does that mean in order to get the app to control the hub and devices again, I need to re-pair everything in the app?

It is quite odd, given that all was fine up (full app functionality, with all hubs and devices present) up till last week.

There isn’t a way to move them to ap02 from the original graph.api. But I am unclear why it is necessary to move them. Do the locations not show up in the mobile app or are there control issues from the app? That might be expected due to the region differences but isn’t guaranteed.

The location shows up in the mobile app, but there are no hubs nor devices shown inside the app, so essentially nothing can be controlled.

I see. The devices weren’t synced properly, partially due to the locations not utilizing Rooms. I move the devices to a Room and tried my best to get things to sync but there can still be unexpected consequences due to the region difference. Hopefully that will get you by until you are able to reset things.