SmartThings Community

HELP - Did something happen TODAY to the SmartThings Cloud or Mobile App? (March 7, 2019) (Fibaro, Aeotec, etc stopped working)

I have the SmartThings Hub v2, and currently have installed about 3 dozen Fibaro light switches (Z-wave) and a handful of other devices. They have been stable for a few months now (though I still have another 70+ Fibaro light switches left to install). I use the Classic SmartThings app (though I have the new App as well - but it lacks a great deal of functionality).

When I got home tonight, I noticed something very strange. If I turned on/off a Fibaro via a physical switch, the lights turned on, and the app recognized the state change. But, if I tried to remotely turn on/off the Fibaro (via the Classic or New App), the screen flashed for a split second and the state did not change (and the lights themselves did not change state).

And this happened for all 3 dozen Fibaro switches. If I tried to use Alexa to remotely control the Fibaros, nothing happened (though Alexa sounded the tone that it uses when a command works).
Yet, I was able to turn on one of the Fibaros as recently as this morning via Alexa. Just cant figure out what could have happened sometime today.

I tried rebooting the Hub, as well as rebooting the App (and my iPhone), but nothing helped.
It sounds to me like there may be a problem with the SmartThings CLOUD, which somehow just started today. It is odd that the App detects a state change from the Fibaro switches, but I cannot use the App (or Alexa) to issue a command and cause a state change. Not sure when the Hub actually uses the cloud (other than for something like Alexa).

What is even stranger is that my few other devices (Kasa WiFi switches, an Aeotec Z-wave dimmer plug (similar to a Wemo) and the Samsung Button) all seem to work fine from the App. Only the Fibaro switches present this problem - but it doesnt seem likely that 3 dozen switches started to partially malfunction sometime today.

I just cant figure out what could be affecting only my 3 dozen Fibaro switches, and only preventing them from receiving a remote command (since they work fine from a physical switch, and even report their state correctly to the Hub and the App).

I will try Samsung tech support in the morning, but they have not been of much help in the past (and never respond after elevating an issue to a higher tier of tech support). Will also try Fibaro to see if they have any other thoughts.

Appreciate any thoughts from the community.
Thanks Dan

2 Likes

Possibly THIS:

I’m having what I suspect to be the same issue as you with just my fibaro dimmers and switches suddenly not working properly since last night (UK time), whilst everything else appears to be operating normally. Similar to you when I try to operate them via the app the on/off indicator in the app flashes quickly and then reverts to it’s prior state whilst the lights etc. do nothing. Never had this issue before (and they’ve been installed without any issues for about 8 months).

I’ve also rebooted the hub but to no avail.

It appears I’m still on the 000.024.00020 firmware.

Same problem here… my v3 is still version 024.00022… The only devices working is none Fibaro… will it be like this until saturday??
Geir.

I too am still on 000.024.00020.
So, if we didnt yet get the firmware update, how is it that we are having problems with the Fibaro switches/dimmers? Did something change on the SmartThings cloud?

Has anyone received the firmware update who uses Fibaro switches/dimmers?

Sure hope they resolve this soon.

Add me to the list. I have 6 Fibaro 2 dimmers. They all stopped responding 12 hours ago. Hub v. 2 UK client. Still on 024 firmware.

Having exactly the same issue, since sometime between 4pm and 7pm last night (UK time) all my Dimmer 2’s have been unusable via the app yet report current state fine when using physical switching.
Google Home Hub reports a successful command when using voice to issue an on/off or dim command but again no state change to the lights or in the app.
Still running v24 firmware as of this morning.

Same problem with a Fibaro Single Switch, still on v24 firmware.

Random theory:

SmartThings has made a back-end change to accommodate the planned new Hub firmware (v25.20). That change is incompatible with the current (v24) firmware.

I guess we’ll find out soon.

1 Like

I’m having exactly the same issue with Aeotec Nano switches, which also use the Z Wave protocol. Since sometime yesterday evening (uk time), most, but not all, of the switches will not respond to the app or to automations. Hub 2 on latest firmware. I experimented with one switch and unlinked it from the hub and then added it back. It was recognised and saved, but still fails to be actionable by the app. All switches work fine manually. Really tiresome.

I can confirm the same behavior on my end …
My Fibaro devices not working, I’m on v24 firmware.
Also my Aeotec HEM (Home Energy Monitor) dropped out and has not been reconnected since yesterday.

All my devices seem to b working, however I cannot log into the IDE and none of my webcore pistons do anything. I get an error 500 when I try to log in to the IDE.

My GE switches are working fine… but I have a couple of hardwired switches with custom handlers that won’t respond. They report status, and turn on when I press the physical button, but they won’t respond to commands via the apps (or from programmed automations)

Exactly the same issue. 70 plus Fibaro devices not responding. I really think Samsung has lost the plot. Need Amazon or Ring to come up with a new ZWAVE hub!

Has anyone written to ST support yet?

I tried to… the website didn’t give me a confirmation that my submission went through. Classic!

If you look at live logging on the " SmartThings Groovy IDE" page there is a java.lang.NullPointerException…
My roller shutters weren’t working today… in fact, none of the fibaros were working.
Just replace

private encap(physicalgraph.zwave.Command cmd) {
if (zwaveInfo.zw.contains(“s”)) {
secEncap(cmd)
} else if (zwaveInfo.cc.contains(“56”)){
crcEncap(cmd)
} else {
logging("${device.displayName} - no encapsulation supported for command: $cmd",“info”)
cmd.format()
}
}

with

private encap(physicalgraph.zwave.Command cmd) {
if ((zwaveInfo.zw == null && state.sec != 0) || zwaveInfo?.zw?.contains(“s”)) {
secEncap(cmd)
} else if (zwaveInfo?.cc?.contains(“56”)) {
crcEncap(cmd)
} else {
logging("${device.displayName} - no encapsulation supported for command: $cmd", “info”)
cmd.format()
}
}

on the fibaro handlers and everything should return to normal.
For the default fibaro handlers you must go to the github page, change them and recreate them, at least until they are fixed.
Somehow the zwaveInfo variable no longer contains a zw field…

2 Likes

Thanks for the report of these issues. We’re actively investigating and will fix this on the cloud side as soon as possible.

3 Likes

Yep same here. One of my fibaro smoke sensors stopped on monday reporting temperature and did not send woke up messages either. Yesterday they all (6) were gone. They are reporting temperature if I press middle button but simple device viewer says that they are not reporting anything anymore because nothing happens automatically from sensor to hub anymore. This is just so fu***** frustrating. People spend hours of thinking and fixing issue just to find out that your hub update might be causing this. I’m almost ready to jump off if there would be an alternative. This happens atleast 10 times in year and always I’m so stupid that I’m trying to find issue from my home network or z wave cloud or …aaarrgrghththththththththththth…

I have the same issue with my Fibaro relay switches and (EU) Wall Plugs (not on latest firmware yet). I see the following error in the log in respect of the relay switches:
‎18‎:‎28‎:‎37: error java.lang.NullPointerException: Cannot invoke method contains() on null object @line 472 (encap)
The IDE reports a similar error in respect of the wall plugs (with default DTH):
‎18‎:‎32‎:‎33: error java.lang.NullPointerException: Cannot invoke method contains() on null object @line 315 (encap)