Heatit Thermostat (Z Wave with Under Floor Heating)

It may be related to a combination of issues. We discovered an issue with the EU platform causing timeouts, the ST staff is looking into it and also working with heatit to enhance the st integration and bring out some additional features.

1 Like

Sounds promising (although this thread is over 3 years old - and I don’t remember Thermofloor ever releasing an official DTH)

Thanks for the info,
Guy

1 Like

hello. I bought the dh for z-trm2fx. The layout is great, but its keeps loosing connection eash 2 days. any solution?

Haven’t seen any issues here. Try bring your hub closer or add a repeater between the hub and the thermostat.
It could also be an issue with the hub, see this topic about the upcoming hub firmware which addresses something related to lost z-wave connections.

Hi, you can find the official DTH here:

We will have more heatit product integrations coming in the near future

1 Like

Here’s another one for Z-Water

I adressed the problem to Thermo-floor and they sent a new one. Now everything is working :slight_smile:

1 Like

Hi, A little update on the problem. I god a new thermostat from Thermo-floor 3 weeks ago, and everything was working well until yesterday. Now the new thermostat also lost its connection. I have a V2 hub, can it have something to do with that?

Try a different hub and also check if your hub is running the latest firmware. The recent hub firmware release had some notes about fixing an issue with zwave connections being lost/dropped.

Okey thanx

Will it work with the HeatIt V2 (Specifically Z-TRM2, not the fx), on a V3 ST HUB?

If you’re referring to the official integration below, yes it works with all smartthings hubs and the question about the older models was answered by maddie. Also we can pick up the conversation on that topic to avoid confusion.

they still do not work optimally. It works for a few days then the thermostats lose connection to the hub.

1 Like

The same happens to me, to both of my thermostats. Using hub V2.

I have to hubs, one V3 in my fathers house and my own V2. Both are using the classic app. And in both cases the termostat is offline after a few days.

1 Like

Does power cycling the device make it come back online again?

1 Like

No, it didnt.

I’ve been using this DH in the Classic app for a couple of years (thanks Adam!) but now I’m trying to use the new Smartthings app all I get is “A Network Error Occurred” when I try to open the device page. The thermostat is reporting correctly in the list of devices but not the config page.

I really have zero exposure to the Smartthings API and Groovy, so being lazy I am wondering if anyone knows if there is an easy change or set of changes to make it work (or is it just me?)

Hi Adam, I’ve been trying to tidy up my device types and point them at Github repositories where possible. However with your brilliant Heatit DH, it keeps telling me “File is not in any repository”. It’s also not finding it if I delete it completely and try to add again it from the repo.

Any ideas? I know this is going back into the dim and distant past…

Chris.

Hi!
I got 3 TRM2fx today. (Multireg…but their the same). Got two of them hooked up to the under floor heating and i payd for the Rboy device handler. Ive had Z-wave and smartthings for years and got lots of devices, virtual deviecs, device handlers etc. So I have followed every instruction correct. Device handler added and published, but I cant for the life of me get Smartthings to detect the damn things. Ive tried inclusion 100 times on each of them…Leds keep rolling…smartthing detects nothing. Ends upp in “Err” every time after 20 seconds. I got extended network and power cables for the hub so I am litterarly holding it centimeters from the thermostats. In the clasic app it says that the hub is running 000.028.00012 firmware.
Tried running the Fix Zwave network thingie as well…that just ran and ran for 10 minutes without anything happening. Also tried the general device exclusion and put them in include/exclude… nothing turned up there either. Anyone got any idea?