Having an issue setting one switch to toggle multiple switches (GE zwave switch showing multiple events)


#1

So I’m using the Smart Lighting app and trying to control some lights in my kitchen. I’ve successfully set it up to turn on/off 4 light switches by pressing one of them, and it works great. The problem is that in my activity, it constantly runs the app every few minutes. So even though the lights are all off, it will tell me it tells them all to turn off now and again to match the “master” one. It also does this for my linked porch lights. Click on the picture below to see the activity from the middle of the night. How do I set it up so it toggles on/off by me pressing it, but won’t try again until I toggle the switch. I hope this makes sense.


#2

There are unfortunately several things that can cause this. Since smart lighting is an official feature, you might want to just contact support.

https://support.smartthings.com/hc/en-us

If you want to start digging into it yourself, people here can help you also. Begin by posting screenshots of every page of your smart lighting automation.

Also, what device type handler did you use for your master virtual switch?

As far as doing your own investigation, do the following:

One) open the mobile app

Two) go to the “my home” view by tapping the icon with four little squares at the bottom of the screen

Three) choose “things” at the top of the screen

  1. look through the list until you find your virtual switch. Then tap on its name (not the icon on the left or the right of the name, just the name itself). This will open the detail screen for that device.

Five) on the detail screen for the master switch, tap on “recently” at the top. This will show the list of events for this device. Look to see exactly what is sending all the multiple commands.

  1. after you’ve had a chance to study recently logged on the devices details page, then tap the “smart apps” at the top of the same detail page. That will show you exactly which smart apps are associated with this device. You’re just looking to see if maybe you at some point set up a smart app or a routine that you’ve forgotten about.

#3

It’s a GE ZWave light switch that I have setup to trigger the other light switches in the kitchen. They’re triggered to go OFF when that switch is OFF, but why is it trying it after it’s already done it? It notices the switch is OFF after, say, 15 minutes, and triggers the rest to go OFF, even though everything was off from the last time it ran. It’s the only routine or smart app setup to use those switches.


#4

OK, the GE switch by default uses a zwave device handler type that has a problem where it treats every time it is polled as a physical on event from the switch even though the switch doesn’t turn on. This throws off anything which is “following” that switch and it’s a pain in the neck.

Fortunately, there’s a really easy fix, which is just to change the device type handler for that device to a different One that doesn’t have this issue.

Support can do this for you or if you are comfortable in the IDE you can do it for yourself. This is just a software assignment, you could switch it back anytime you wanted.

@sbdobrescu could say more, I believe he’s the first one who reported it in the forums.


#5

Awesome, thank you for your help!


#6

Just an update, support replied and said the bug would be fixed monday! Here is the email:

"Hey Greg,

Thanks for reaching out!

This is currently a bug in the way we poll the Z-Wave Switches. This should be fixed in the upcoming Hub update on Monday.

The issue is that we poll Z-Wave switches every 15 minutes and the bug is that depending on its state, it will re-run the automation it’s the “Controlling” switch of.

We will be correcting this issue with the next Hub update.

I’m going to leave this ticket open and wait and see if the Hub update corrects this issue.

Let me know and we’ll go from there.

Kind regards,

Jake K.
SmartThings Support"