Has anyone successfully paired the Third Reality Zero-Wiring Zigbee Smart Switch with Smarthings or Hue?

I’ve read the FAQ where they provide the DTH for the device handler but have not been successful into pairing it the hub. Has anyone been able to do it to provide some guidance here? Also somebody claims that they paired it with the Hue Bridge, but again no details.

Third Reality Zero-Wiring Zigbee Smart Switch

does it show up as a thing at all?

Nope, but maybe I haven’t tried long enough and with the switch really close to the hub. That’s the only thing left trying. Once it shows (if it does) then it should be easy. Just want to make sure I’m not missing anything and get confirmation from someone else that this is possible.

it looks like it uses a standard zigbee HA 1.2 protocol. Try resetting it and adding it close to the hub. Even without the device handler it should show up as a thing.


Thanks @Automated_House I’ll give that a shot and report back here as confirmation (or not) that this switch works.


OK, the best update that I could put in here: works like a charm! It just took ages to detect the switch which BTW I placed right on top of the hub (to quote a Youtube video that I watched earlier today "proximity is everything with Zigbee… LOL). Once I had it on top of the hub it took good 5 minutes to detect it but it did with the device handler I published before automatically.

The rest was very straightforward. Putting it in pairing mode is done pushing the button for 20 seconds and since the switch is battery powered you can bring from where it is and put it right on top of the Smartthings hub.

So to summarize if someone ends up in this thread:

  1. Create the device handler with the DTH and instructions in the Third Reality FAQ
  2. Make sure the switch is on pairing mode (very straightforward since the led is blinking and there’s only 1 led. If not in pairing mode, push the button for 20 seconds until it does blink. More details in the user manual.
  3. Place the switch on top of the hub or as close as you can
  4. Add as a thing in the app (more like search for things)
  5. Wait, Wait, Wait, Wait
  6. When detected, rename if you want and click ok.
  7. If the handler was not used (you will notice right away because of the default device join name for the switch in the code (RealitySwitch) go back to the developer portal and edit the device to use the handler.
  8. Voila

Thank you so much @Automated_House for making go back to do this with reassurance about the ZHA 1.2 protocol :smiley:


Cool! Since it looks pretty standard zigbee, it may work with the zigbee bulb or zigbee switch device type which may let it run local.


Thanks for the update. Please report back in a couple weeks on how this device is performing. I could use something like this in my house.

Hi @Maita I know you said a couple of weeks but I wanted to provide an update anyways. I originally used the handler provided by third reality which worked every once in a while with the smart lighting smart app to turn it on at sunset and off ant sunrise. Following @Automated_House advice I switched to the regular zigbee switch handler a voila: very stable and works great! I definitely recommend this guy for a regular switch setup or if you don’t have a neutral cable.


Thanks @maikelson
Based on your review, I ordered one and received it today. Pairing was pretty quick, but it hung up on “please wait” in the app. After logging to IDE, I switched it to the Zigbee switch and it seems to be working now.

I plan to test it for a couple of weeks. If it works well, I have a number of places I want to put these.

BTW, I saw on their Twitter feed that a new “plus” model is coming out soon.

I’ve had one of these for about a month, and I’m sad to say my experience has been less than pleasant. I installed the device handler and had no problem whatsoever pairing it. It worked like a charm exactly as I would expect it to for about a week, maybe less. Then one day it just quit working. By that I mean ST would not control it at all, either through the ST app or by voice with Alexa or Google Assistant. The button would still activate the switch, so I figured it was not a battery issue. I decided to remove and re-add the device to my hub. When I pushed the button to put the unit into pairing mode to add it, nothing happened. That’s when I decided to change the batteries. Once I installed a fresh pair, the switch functioned normally again. For another week. I have gone through three sets of batteries. This is unacceptable to me, and this drawback far outweighs the convenience of making this light smart.

I have returned the unit and before purchasing another only to have to go through the hassle of returning it again if it does the same thing, I wanted to get others’ experiences. Has anyone had this happen?

EDIT: On a whim, I decided to simply remove and reinstall the existing batteries. This restored normal functionality to the switch. This is still a problem that needs to be addressed, and I will be contacting Third Reality. I’d still like to know if anyone has run into similar issues with this thing.

I installed one yesterday in our kitchen and I’m digging the ease of install so far. Nobody seems to mind the small rectangular white block sticking on the wall so everything is good so far :slight_smile:

1 Like

Amazon has recently cut the price on these to $24.99, making them a very affordable option for renters or those of us without neutral wires.

I’ve had two working flawlessly for a couple of months.

1 Like

So I’m trying to create a zigbee switch device handler using the example code in Smartthings and I keep getting this error. Anyone know what this means?
Org.springframework.security.access.AccessDeniedException: Run Locally Permission not allowed for DeviceType: 5d28fd27-c57e-4276-91bf-3701696fd50a

You need to remove the run locally data from the metadata definition

total noob here. I followed the instructions, created the device handler, and it’s not pairing. Should I just repeatedly re-enter pairing mode and refresh the “find” screen on my mobile device?

They work pretty well. I have about 16 of them around the house.

Two things to note:

  1. If they stop working, try to replace the batteries. That seems to fix it.
  2. It will take a long time to pair usually. Just keep it in pairing mode with the RealitySwitch directly on the SmartThings hub and keep refreshing. Eventually it will appear.

Annoying thing though is sometimes it goes out of synch (on/off).

I am having problem after pairing one of these it instantly goes back into pairing mode. Anyone have issues like this?

Not sure if anyone is still looking at this thread, but I just got it placed it on the hub paired and I was done. No handler needed, as the link is broken anyway.

Works a treat!