Harmony Hub Issue with Echo/ SmartThings

Hello all!

Hope you all can help me out with the issue I will explain below.

I have a single activity called “Floor Fan”. This contains an IR controlled device.

The echo only allows the system to turn on a “scene”. A scene is what the harmony activities are imported s within the echo environment.

I have this scene (activity) called out in an Alexa routine for goodnight and good morning.

The goodnight works great! The good morning never works.

I have deduced Alexa can turn on a scene (activity) but cannot turn one off which is why it doesn’t work to turn the scene (activity) off in the morning.

Can you all help me with a work around within the harmony environment. I have not been able to find a way to send the power off from a 2nd activity as a workaround.

Also, I have this fan setup as an “entertainment device I believe within the harmony software.

I’m not sure I completely understand but let me take a stab at this:

In the Harmony app you have an activity called “Floor Fan” this activity can be turned on and off within the Harmony app.

One limitation in Harmony is that only one entertainment activity can be operating at a given time per Harmony Hub.

In the SmartThings ecosystem Harmony Activities show up as a switch (with a few extra options)

To access a Harmony activity in Alexa you would need to add it under “Switches”:

As an example Basement Apple TV is a Harmony Activity.

image

By checking the box above in the SmartThings integration Alexa will see that activity as a switch and I can say “Alexa, Turn on Basement Apple TV” to turn it on and can say “Alexa, Turn off Basement Apple TV”

This doesn’t work quite the same as the Harmony <> Alexa direct integration however it does allow you to directly control the Floor Fan via “Alexa, turn on” & “Alexa, turn off”

I personally have found that passing Alexa through SmartThings to Harmony was a little buggy. I ended up taking Harmony out of SmartThings completely and enabling the Harmony skill within Alexa. Things like “Turn on the TV” and “Turn off the TV” work every time now. Can also do “Alexa tell Harmony to pause” or volume up, down, etc and it seems to respond and work better. Then for home automation stuff I just give her another command. Rather have two commands that both work 100% then one that was buggy.

1 Like

I agree with however as of yet the Alexa <> Harmony direct integration only works with a single hub and alas I have more than one so if I want to control multiple hubs it requires a secondary integration (such as SmartThings).

I’m really hoping that Harmony will sooner or later get on board and or somehow incorporate room control.

I can already control individual Fire TV devices using specific Echo devices (such as on a main floor and/or in a bedroom.) and after a few hick-ups early in the adoption of the room specific light control I find that it works quite well and greatly simplifies controlling lights in a single room (such as a bedroom).

I will say that I also don’t generally use Alexa --> SmartThings --> Harmony interaction for voice control but do use the SmartThings --> Harmony interaction in automation (such as turning on the TV in the morning or ensuring that the TV is shut off when leaving to go to work.

I find that in that use case the SmartThings <> Harmony integration works great.

Ok I think my explanation of what I wanted must of been no good because I can see I’m getting responses all over the board.

So I use the harmony integration direct to Alexa.

However I can’t find a way to turn off the scene (Alexa uses the name “scene”, a “scene in Alexa is a “activity” in harmony) within the Alexa routine.

So I am looking to create a workaround within harmony somehow.

Hopefully I have simplified my query now.

Thank you all!!

You will need to set up a second Harmony activity that turns the device off. Then that will be imported to Echo as a second scene and that’s the one you will activate in the morning.

This can get really complicated depending on the combination of devices that you have, but here’s one example:

I almost forgot: there is an easy way to do this although it’s weird. :sunglasses:

For some reason, the Harmony app IFTTT channel will let you “turn off” a harmony activity. I don’t know why, since none of the other control methods do, but it does seem to work.

You still need a second command to trigger the off, but you would create a virtual switch in SmartThings and have that virtual switch turning off be the “if” in the IFTTT applet and the “end Harmony activity” be the “that.”

Then just turn that virtual switch on in your original fan activity so it will be on and waiting when you want to turn it off.

I can’t figure out a way to create an activity that sends only an “off” command when starting the activity.

When I create an activity within harmony, it looks like it automatically has a startup and shutdown routine and there is not a way to remove “power on” from the startup nor “power down” from the shutdown.

Scott,

Where do you find the switches menu? I am using the iOS app and I can’t find a menu that has switches as the header. All I find in the Logitech smart app for SmartThings is a list of activities that it let’s me import, and then when I get to Alexa, it has imported them as scenes.

Since the fan is an IR device, it will be classified as an entertainment device, not a smart home devices. That’s just Harmony does it.

With entertainment devices, switching to any activity which doesn’t require that device will turn that device off unless you gave it a special power options to stay on.

So if you didn’t use the special power options, you just need to change to any other activity that doesn’t include the fan. And the fan should turn off.

I have a Harmony activity which includes my fire TV, but does not include my television. All that activity does is turn on the fire TV. However, because it is not turning on my TV, my fire TV actually won’t come on.

So I can just turn on that scene and Alexa and any scene that was previously running that didn’t include the fire TV will turn off.

So that’s one way to do it.

But mostly I use IFTTT because it’s just more logical. I set it up in the echo IFTTT channel so when I say " echo, trigger shut down" it triggers the power off sequence in Harmony, the same thing that pressing the power off button on the button remote would do.

I don’t know why “power off” isn’t exposed in other ways, you would think it would be. But it does work through IFTTT.

Or you can use the switching to an alternative activity.

Beautiful!! Now I’m on the same page with you. So I can create an activity that doesn’t include the fan and essentially put a single ghosts device in that activity and when I switch to that activity, it will turn the fan off.

Sometimes I just overthink things.

Thank you so much JD!!

1 Like

In my instance I will be including this process inside of an Alexa routine so the Alexa routines don’t really support ifttt but I see your use case there also.

1 Like

Just remember it has to be an entertainment Device activity, not a “smart home” Device activity.

It’s one of those things that doesn’t really make sense, but it works. :stuck_out_tongue_winking_eye:

The menu I was showing was within the SmartApp for the Amazon Alexa integration. If you aren’t using the Alexa Integration within SmartThings then you wouldn’t have this as an option.

You can get around that by having a virtual switch coming on in SmartThings be the “if” in the IFTTT applet with the Harmony power off as the “that.” Then you can include that virtual switch in the echo routine. So that’s a workaround for getting to IFTTT from an echo routine.

And if you use the power allowance feature in smart lighting to have your virtual switch always turn itself off after one minute it will be ready to turn on again the next time.

So it’s just an alternative method, if you’d rather use your ghost device harmony activity that will work too. :sunglasses:

Oh, I understand now. I guess I have them all defaulted to shared.

Niceeeeeee… So many options. Makes me :grinning:

1 Like