GoControl WT00Z Light switch controlling 2 bulbs through SmartLights, can't seem to get working

Hi guys, we’ve had a non functional light switch in our living room originally assigned to control a sconce which has long since been removed. I ran some Romex up into the box so I have line, neutral and ground in the box, just no load. Due to this somewhat unique arrangement I went with a Gocontrol Z-Wave WT00Z-1 switch as this seems to be exactly the type of situation it was designed for. I purchased a Sengled Element Classic E11-G13 Zigbee bulb and put it in the floor lamp nearby.

Both devices paired with Smartthings fine and I can turn them both on and off individually via the app. I’m having trouble associating the switch with the bulb. I tried using the built in Smart Lights Smart App. Once that’s in place if I go into the app and turn on and off the switch the associated bulb switches on and off. However, if I use the switch, nothing happens. The light on the switch that indicates if the switch is on or off changes as expected but the bulb doesn’t switch on and off. Any ideas whats going on?


This is what you want. This switch will send, using local processing, instant on/off status to the hub.

I have 3 WT00Z-1, they work great, but they are previous generation and they are meant for zwave to zwave which is not your scenario.

Many people have used the GoControl model for exactly this scenario. It doesn’t matter what the manufacturer intended it for -– because it does have a Z wave radio and it is seen as a controllable device by the hub, the hub should be able to determine that the switch has come on and then send a message to any other controllable device, including a zigbee bulb. Again, people have been using exactly that device in this fashion for several years.

So the first question is whether the cloud knows that the switch was turned on. Rather than trying to use the app to turn on the switch, use the switch and see if the status changes in the app on the things list. If it does, then smartlights should work.

If the status doesn’t change in the app, there’s a different issue and we will have to look at that. There are a number of different options that can be used then.

But you don’t need to buy a different device. For example, this switch could be defined as a button controller and associated to the hub itself and that would work.

But first just check and see if the status changes in the app when the switch is used at the wall.

Also note that some community members have been reporting problems with exactly that model that just started about two weeks ago when the hub firmware was updated. The same switches worked just fine before that. So that may be a factor as well.

1 Like

Thanks SO much for your feedback. I just started noticing that the status of the switch in the app does not update at all when I use the physical switch.

Another point of interest is that the switch is recognized in smartthings as a “ZWave Device”. I tried changing it to various Zwave Dimmers in the IDE but no luck.


Thanks Dave! I actually have that switch sitting here too. I got it as a back up to the GoControl since it doesn’t offer dimming. I’ll try it if I can’t get the Go Control working.

Also interesting, while the status does not update in the app at all, the Live Logging in the IDE is recognizing a button press:

9:40:11 PM: debug Parse returned null
9:40:11 PM: debug parse()>>; zwave.parse(zw device: 0F, command: 5B03, payload: B7 00 01 )
9:40:08 PM: debug Parse returned null
9:40:08 PM: debug parse()>>; zwave.parse(zw device: 0F, command: 5B03, payload: B6 00 02 )

Yeah, something has changed, either in the DTH or in the platform and I’m not sure what. Hopefully some other people who have had it working for a while without direct association will chime in and we’ll get some more clues.

1 Like

Which version of the app are you using, classic or as STSC?

I’m using classic… but the status of the bulb doesnt seem to be updating in the IDE either.

OK, I don’t have one of those devices to test with now, so let’s see who else has current information.

So I also noticed GoControl has 2 very similar switches. The WT00Z5-1 (the one I have) and the WT00Z-1. Maybe I got the wrong switch?

Just another note, I installed the GE switch @professordave suggested earlier in the thread and it works perfectly.


That’s the Z wave plus version. Could be something different, certainly association changed.

1 Like