Globe Suite and ST Integration

Had some issues with lights being offline and some other issues.
Deleted all lights for Globe Suite and ST.
Added lights back into GS but no matter what I do i cannot get them back into ST.
I can manage them from the GS app manually (turn on and off etc).
The GS service gets connected in ST but not one single device gets brought over.
Tried all I can think of including creating new GS and ST accounts and using a different phone to set it all up.
Seriously considering getting rid of the hub and motion sensors and sending back to Samsung (I have already printed the return labels).

Is anyone else having any issue the the integration between GS and ST?

1 Like

I do exactly experience the same… everything worked two weeks ago - no problems.
Now i got a new device and connected everything again - no chance. Tryed multiple times with globe suite and with tuya…

Integration to alexa smart home and ifttt works - so it has to be smartthings…

1 Like

Thanks. Yes I just found another post about it too. Towards the bottom of the thread (below) someone has exactly the same as me. Devices going off-line so they removed the GS service to try and fix. Re-adding it does not bring any devices over. Just a blank list. I agree, seems to be ST. Hope they can fix it soon.

The cloud to cloud integrations in the new V3 app are done by the device manufacturers unless it is a device on the official compatibility page. Which global suite isn’t. :disappointed_relieved:

So the integration code belongs to global suite, and they have to be the ones to fix it. The best thing to do is to contact their tech-support.

1 Like

OK thanks. I just hope who ever is at fault, that they crack on with getting it fixed. Not really a big fan of this cloud thing at all and as for cloud to cloud. Crazy idea. Too many points of failure for my liking (my own connection going down and breaking things is bad enough but to have to rely on other 3rd parties is not so good)…
I would call them but would not know where to start and am sure others have made them aware by now. Seriously thinking of sending the ST kit back as not for for purpose. I just love the idea of automation and not just asking Alexa to turn the lights on. Why on earth can it not all be done local?

1 Like

I submitted a ticket with ST. Emailing with customer service representative. He’s looking into it. Last email I sent over was a video of me trying to add globe suite and there being an empty list and switching app showing all the plugs in globe suite app.

Will post here updates as I get them.


If you want Alexa to run locally, you have a very limited set of devices you can use. You have to start with an echo device that has a built-in zigbee hub, such as the Show 2nd or 3rd generation (but not the Show 5) or the Echo Plus. Then there are a few zigbee bulbs, switches, and plug in pocket sockets that can be joined directly to that echo device. But it’s not very many, and it’s not a lot of commands available.

Otherwise, Alexa itself will always require a cloud connection. That is true of most other voice assistance as well, including Google home and Siri. Voice processing is just a very computationally heavy feature, and it’s much more efficient to do it in the cloud.

Setting voice options aside, there are several Home automation platforms that run locally after initial set up. Apple’s HomeKit is an obvious choice. (I myself prefer echo for voice processing, so I buy devices that work with both Alexa and HomeKit.) but there’s also vera, Hubitat, Homeseer, Indigo, etc.

But in all of those cases you are going to have fewer devices to choose from than with smartthings. The cloud is what enables a lot of integrations for devices using different protocols, including manufacturer – proprietary ones. So it comes down to what your own priorities are. :sunglasses:

1 Like

Thanks JD… , a lot for me to think about. I guess I am just going to have to accept that the cloud is a necessary evil (for automation) and try to embrace it. Just seems to be so many issues with my ST account. Only had the hub and motion sensors for a week and don’t think I have had a day yet without some issue. Hopefully once they are all sorted things will run more smoothly.

Any updates?

Still having this issue where ST won’t recognize my devices upon linking.

There are ups and downs in this business. Tuya and Globe Suite integration is quite new to ST. And there are always teething problems at the beginning.

I am just glad for this forum. I got a new color light from Amazon (lumiman) and like many cheap Chinese Wi-Fi lights they are controllable from global suite! I was all excited following a guide… when the list kept coming up blank :frowning: … I can confirm this is broke as well!

1 Like

Got the same problem since friday.
Removed global suite from smartthings, when I try to re-link them, it work but nothing show up in smartthings.

Sorry to hear that but it seems now it is the same for everyone.
Were you the same? Devices going offline so tried to resolve by removing the integration? I don’t think this was the wrong thing to try. Probably and eventually all devices would have gone offline and we would be in the same situation.
Hopefully there will be an update soon and @Julio8a will post it as soon as.

In the mean time I am deleting the GS integration in ST and adding it back several of times a day. If this ever works I shall of course post here to let everyone know.

1 Like

I try the same, removing and adding a few times a day. 24 hours since I replied to the ST rep. Haven’t heard anything back yet. Probably won’t hear back till Monday. :man_shrugging:

1 Like

My existing connections still work but I’m not risking relinking :wink:

1 Like

Still no device link between GS and ST. GS works on it’s own. ST works with other manufacturers eg TPLink. Not sure why it is a specific GS to ST issue. Only bought the devices last week. Was working fine yesterday.
Using Alexa automation instead until the ST link gets fixed. Seems to be working well. Alexa found the new TPlink plug automatically.

I found issues and am still having issues with Global suite, a few days ago a wifi lamp i have showed off line in the ST old app but in reality still works fine, the cloud integration is odviously having issues, I’m leaving it alone as there is nothing I can do to fix it

It still works in automations, just shows offline

It looks like issue is a bit different for everyone. Mine showed as offline and would not turn on with motion Detector but would with alexa. Strange.

How do you “remove” and re-link global suite in the smarthings app?

Using the new app.

From your Home screen click on the menu (looks like 3 lines/bars. 30% from top-left of screen).
Then click on the cog icon that appears at top-right.
Then select Connected Services.
Then select menu from top-right (3 dots) and choose delete.
Then click on the minus sign (-) for the service you wish to remove.

To add it back and your devices, from your Home screen, click on the plus sign (+).
Then click on Device.
Change option to By Brand.
Scroll down to Globe Suite and select it.
Click on Lighting.
Changed the location and room as needed.
Click on Next.
Enter your Globe Suite credentials.
Click on Link Now.
Click on Authorize.
Click on the cross(X) in top left of screen.
When it’s working you will see a success message and your devices listed (but at the moment the list will be blank).
Click on Done.
Move your devices to rooms as required.