Getting Echo to recognize a Virtual Switch?


(Mike Kelley) #1

I understand how to create and use a virtual switch, but when I ask the Alexa app to find devices it won’t find that switch (so I can’t group it or otherwise use it). I’m obviously missing a crucial step here – anyone want to enlighten me? (The following quote is from the forum FAQ here that is obviously NOT true – because that virtual switch I’ve created does NOT look like any other device – or at least Alexa can’t find it).

“The main point is that once you have created the virtual switch over on the smartthings side, it looks just like any other device connected to your network.”


(Darc Ranger) #2

Did you add the switch the the Alexa smartapp under your SmartThings App? That is usually the most common step people still forget to do.


#3

This step has bit me countless times.


(Mike Kelley) #4

Um, not quite sure what you mean by “add the switch the the Alexa smartapp”? I have the Amazon Echo as a Smart App in my Home screen, but other than that I don’t know what to do.


#5

Open the smartapp. In there you should see switches that you’ve already added. Click the green circle with plus sign and add the new virtual switch.


(Mike Kelley) #6

Doh.

Okay, I didn’t even know I could open that Echo app. Sorry, slllllllooooowwwly learning things.


(Michael Deffendall) #7

Ok, I don’t even see my Echo on the My Home screen. And if I try to add it using add a thing, all I get is an option to buy one. I am certain I am doing something newbie dumb, but I have no clue what to do next. Any help is appreciated.


(Mike Kelley) #8

On your phone, on the Smartthings App, there will be an option called “Automation” and under that you will see the tab “SmartApps”. THERE is where you will find the Echo device, and all you need do now is just enable Alexa to discover all devices, scenes and routines.


(Michael Deffendall) #9

@Kelleytoons Thanks for indulging the newbie question.

Ok, well I did that much right and already had Alexa as a SmartApp in Automations, and I did already have the “find all devices, scenes and routines” selected. She already had seen my “real” devices. So I unselected the “all” switch and manually selected the devices I want her to find, to include my virtual switches. We’ll see how well that works tonight when I get home.

Thanks again.
Michael


(Mike Kelley) #10

Remember you also need to tell Alexa to do it – just say “Alexa, discover my devices” and she’ll run through the process (you need to do this every time you add a new one).


(Michael Deffendall) #11

Thank you again @Kelleytoons.

Alexa found my Virtual switch and I was able to activate it. She complained that she couldn’t talk to Smartthings, but the action triggered by turning the switch on worked. So, as per normal, Alexa is more confused then she thinks she is. :laughing:

Michael


(Al) #12

I have a Garage virtual button and a virtual switch and Alex won’t recognize them. I turned off the “Allow Alexa Access all…” but the virtual devices do not show up under Switches for me to select. The devices work fine under smart things.
Any idea what am I doing wrong?
Also same applies to Google Assistant, it can’t see virtual switches either.
Thanks in advance.


(Mike Kelley) #13

You defintely should turn “Allow Alexa access all” – what happens when you have that on and you tell Alexa to find your devices? Does she report the correct number?

I have many such switches and Alexa finds them all.


(Al) #14

Thanks for the reply. I always had “All …” before, but reading this thread thought may help to select manually, but even in smartthings app they don’t show up for selection. So I set it back to All.
I use iOS Alexa app “add device”, it searches but does not report any new devices. All the real devices, about 4 dozen, still there as before. As mentioned I am using a virtual button to switch a relay back and fort my garage door’s remote. And also have a community provided garage door virtual remote. Both work as expected in smartthings, other than not showing up under the smartthings Alexa smart app.


(Dan) #15

A Virtual BUTTON is not the same as a Virtual SWITCH. BUTTON devices won’t show up the Alexa SmartApp. SWITCH devices will.

Try creating a Virtual Switch to see if it shows up.


(Al) #16

OK thanks, I will investigate.


(Michael Deffendall) #17

I have Simulated Momentary Button tiles that I use for various toggle switches and Alexa sees them with no issue.


(Dan) #18

I just tested this by manually adding a “Simulated Button” to my account. I then went into the Amazon Alexa SmartApp to see if I could add it. It is nowhere to be found.

BUT - If you select the “Momentary Button Tile” Device Handler, then it will show up for Alexa.


(Lee) #19

Ive fpund os you turn alex app off it gives you a list of your devices. Then add in whatever you need to and allow alexa to use again. Worked for me with virtual switches.


(Michael Deffendall) #20

Yes, that’s the one I use.