Get ready to make the switch!

I know I’ve given up. Stripped my ST hub down to be a basic Z-wave / Zigbee controller, letting other things handle the automations until my Hubitat gets here. Been here since the start, but this was the final straw. ST support has been garbage and takes way to long to get an agent who is capable to actually help with something more advanced then just uninstalling/reinstalling the app. This migration was a joke and should have never been pushed on us until it could handle everything we could already do.

10 Likes

I purchased a Hubitat C7 a few weeks ago and am in the process of migrating. I was a long term SmartThings user and really loved this system, but I’m sad to say I’ve lost faith in it, and in the direction the owners are taking it. Frankly, the first couple of days after I got the Hubitat I though I had made a mistake. It takes some getting used to! But now after several weeks I couldn’t be happier, and seeing and experiencing all of the latest ST outages and this complete mess of a migration, and knowing there are much bigger and messier migrations to come next year… I’m glad I’m out. I hope in a few years the growing pains are over and I can consider using whatever ST has morphed into sometime in the future. But for now I see only retrograde steps, upsets, outages, and frankly nothing that makes me feel excited. With Hubitat I see a team of enthusiasts, an exciting product, and a sense of direction. It feels fun again.

10 Likes

Thanks @DThompson10 your experience gives me hope that I’ve made the right decision.

2 Likes

I’m considering making the same move as I just can’t get any of my devices migrated to the new app. No idea how, no examples, templates or documentation that I understand (and I consider myself reasonably technical having written 6 different devices handlers!).

The biggest thing that’s pushing me is that every few days my LAN connected devices stop updating and all changes/updates are lost from this point onwards until I restart the ST hub. Totally lost about what is going on but my home is certainly not smart any more, just incredibly annoying!

6 Likes

Have you posted your questions here? Custom Capability and CLI Developer Preview

2 Likes

2 posts were merged into an existing topic: Alternative Hubs

Does anyone know how to create a virtual switch in the new app?

Apparently I need a dozen to get everything working again, and the ones I created with ‘Alexa virtual device Creator’ are not usable on the new app!
Then when I try to do it the old way in the soon to die IDE it says.

Access Denied

We’re sorry, but you are not authorized to perform the requested operation.

I know - I just don’t get why they can’t just add the information - it’s incredibly annoying not to have the ability to know why something happened (Yes, I know I can go to the IDE - but that’s not the point).

2 Likes

update,
I figured this part out at least

I Had to use incognito mode on the web browser

2 Likes

Yep. And why this is necessary sometimes has never been explained. Just another frustration.

2 Likes

With all these changes I am trying to use Modes to help coordinate changes between STHM, new Automations , Webcore and ActionTiles

Couple issues…
-changing mode names in new app does not update the modes for my location that show in the IDE. Also changing them in IDE didn’t update new app either. Neither seemed to update ActionTiles
-would be nice if the current Mode showed at the top of the new app home screen in the under-utilized empty space (between location name and temperature maybe???)

It appears that the new app uses a different databases to store things (device existence, device names, room assignments, device history, etc). The Classic app and the IDE use the “legacy” databases. There seems to be multiple back-end services that exist to synchronize changes from one set of databases to the other set. At times this synchronization either gets delayed or breaks. This may help explain what you are seeing.

1 Like

…And they seem to get out of sync a lot. I still haven’t figured out which activities force a sync.

2 Likes

STHM and location modes seem totally screwed for me.

My arrive home automation doesn’t switch disarm STHM but my leave home switches the STHM to arm.

Secondly if I create a new automation which has a precondition of the “Away” location mode, I can then switch the location mode on the “Then” section.
But if I remove the precondition I am not given the option to add it back in

2 Likes

That’s expected behavior - and part of the modification they made to allow location mode to be both in the IF and THEN parts of an automation - their first iteration didn’t allow it (to prevent race conditions) and they quickly heard from the community that it was necessary and so they changed it… .BUT ONLY IF the location mode is set as a precondition.

This one just needs to be looked at from a troubleshooting perspective, what automation is disarming STHM, screenshot?

Thanks @nathancu,

This is the routine:

And looking at the messages it shows that the routine runs but the security isn’t disarmed so 8f you see below it clearly shows the routine runs but the security is triggered when I open the door

Looks setup correctly - Looks like you get to have fun with support.

1 Like

Yeah I have already raised a support ticket but not expecting much, all I ever get is “Your query has been forwarded to the correct department”

I can really see people’s pain now, I am very new to SmartThings (Started in the new app)…

But recently with the outages and all the basic automations not working as expected I am getting really annoyed to the point where my home was smarter before SmartThings.

4 Likes

Short version: “Is there a white list”?

Longer: In the spirit of getting ready, I decided to refresh my ZW network. I noticed a warning/error message (“Could not update neighbors”) with one of my devices, a FS20Z-1 relay, so I decided to remove/re-add the device in an attempt to fix.

What an aggravating experience. I could not get the device to remove - tried all the suggestions in the related posts (this device is known to be tricky to unpair apparently), tried a secondary controller which always works with my other devices, no joy. I could force removal in IDE, but since I can’t unpair the device itself it could not be re-added… After 1.5hrs of various different attempts, I’ve decided the device itself must have become defective and want to just to replace it with a new fan switch.

So my question is - how do I know the product will be on the “white list” for ST supported devices post IDE/groovy sunset? I’m looking at basic fan control switches, which I would hope are just natively supported but not sure how to verify that pre-purchase.

1 Like

Well, I made the switch over the weekend. I’ve had to clean up a few things around routines that didn’t go quite right but that wasn’t too hard. The dumb things is it appears you can only use a scene in one automation. For instance, changing to night mode and away mode is supposed to turn off all lights. However the All Lights Off scene could only be used with one, the other I had to duplicate turning all the switches off.
The SMH is another. I created three simulated switches, one for each alarm mode. Then created and automation that when I turn on a switch, the automation set’s the SMH to that mode and turns off the other two switches. And for each mode I created an automation that if the mode changed, such as the night mode turning on armed stay, the automation would turn on that switch. That way the switches stay in sync with the SMH mode. Thankfully I only had one webcore piston that disarmed SMH by code so it didn’t create a lot of grief, I just changed it from using the set smh command to turning on the disarm switch.
I also did have to re-authorize some things like IFTTT, Sharptools etc if they didn’t work.

2 Likes