GE Switch with Add-On (3-way) status issue


(John) #1

Hey all,

Tonight I installed the GE In-Wall On/Off switch with Add-On switch for a 3 way light. Everything is working fine, except one thing.

When I turn on/off the light via the add-on switch, Smartthings will not update unless I manually press refresh. If I turn on the Primary switch, it updates near instantly. I’ve only let waited about a minute or so but considering the primary is instant, I’m assuming there’s an issue.

Has anyone come across this? Any ideas on what this issue can be? The only thought I have is mixing up the wiring? I just don’t know if that would cause this delay or not.

Thanks!


(Bobby) #2

I never noticed until you brought it up. There is a lag, but my add-on uptaded itself within 20 seconds. This is not worse than any other switch that doesn’t send instant update to the hub.


(John) #3

Yeah…mine isn’t updating at all from what I’ve seen. I’ve waiting about 3 minutes and no change unless I hit Refresh. I could live with 20 seconds!

[edit] I just turned it on via the slave and left it for about 30 minutes. No status change reported.


(John) #4

Anyone have any suggestions on this or do you think i received a bad switch?


(Jason "The Enabler" as deemed so by @Smart) #5

Do both switches actually turn the lights on and off?


(John) #6

Yes, both switches control the lights.

If I use the Primary switch, it can turn on/off the light from that switch and it can also perform the opposite action of the Add-On. So if I turn the light on from the Add-On, I can turn it off from the Primary.

Like wise, if I turn the light on from the Primary, I can turn it off from the add-on. The add-on can also individually turn on/off the light on it’s own.

If I perform and action with the primary switch, smartthings update’s within 2-3 seconds. If I perform an action with the add-on switch, smartthings does not update.


(Dennis ) #7

Did you include it without the add on switch wired in? if so redo exclude / include again.


(John) #8

Nope, I didn’t include it to ST until after I wired both switches. The light fixture was off when I included it… (well, it turned on then off due to the up and down action on the switch…)

I have since, excluded and re-included it. Still nothing.

As far as the process went; The light started in the off position. I set the ST app up to search for new devices, I went to the PRIMARY switch and flicked it up, waited 5 seconds, flicked it down. It included itself so I assumed all was good. I didn’t miss a step, did I?


(Glen McGowan) #9

Anyone found the solution? I’ve had my switches installed for almost a week now and noticed the same behavior. It’s only when I use the Add-On. As far as I’m aware the add-on switch is just a momentary “button” that signals the primary switch to do all the work.

I’ve tried:

-Excluding and including by pressing Primary switch.
-Excluding and including by pressing the Slave (Add-On) switch.


(John) #10

Unfortunately, I have not been able to figure this problem out. It is increasingly annoying and almost makes the slave switch useless, but at this point I’ve just been living with it since I cannot figure out a solution to the issue.


(Jason "The Enabler" as deemed so by @Smart) #11

This is interesting as mine do this as well, but not as bad.
The master updates immediately but the six can take a minute or two. Mine varies on the length of time. I also do not have to manually refresh, it does eventually update.

I have to ask though, other than just not updating right away, how is this affecting your system? I’m curious because it has not impacted me.


(Glen McGowan) #12

I’ve sent a support request to Jasco about this issue. We’ll see what they say.

@bamarayne Mine never update. If it’s not too much trouble, what are your switch models? My switches were the previous model with the big ugly bright LED. Lowe’s had the 3-way kit on clearance so I bought them thinking it was a good deal.

Primary: 45609 (ZW4001)
Add-On: 45610 (ZW2002)

For me it’s the out of sync condition between the device and the hub that causes a facial tick and an itch near my brain stem. I haven’t automated these particular lights so haven’t noticed any ill effects. However, I don’t want to assume that it won’t be a problem for me later.

If it really was an immediate problem I could use Pollster to keep hitting the device for status but, I want my hardware to work as expected. I bought it with the expectation that it will work a certain way, when it doesn’t I either fix it or replace it.

If Jasco comes back with a statement that its by design, these switches are going back.


(Jason "The Enabler" as deemed so by @Smart) #13

Mine are the exact same switches, I made out like a bandit on the Lowe’s clearance.

I actually never noticed it until you posted this. I went and checked mine this morning and there is a very significant delay.

I have the following set up:
3-way - 5 separate circuits
4-way - 2 separate circuits

These are where I am using the aux switches. I have all of the circuits on automation and have never had a problem, that I’ve noticed. I do not use my app unless I have to. My entire system is voice activated.

Though, this could be the reason that echo fails to turn on/off certain lights when requested.

I’m going to keep an eye on this and I’ll report back if that is what I am experiencing.

Other than that possibility I’ve noticed nothing else.


(Glen McGowan) #14

So far here is how the conversation with Jasco is going. I can’t say I’m incredibly impressed so far, but, Jasco has a good reputation for great customer support. Hopefully this doesn’t end with me ripping the switches out and returning them to Lowe’s

Me:

I purchased three (3) of the 3-way On/Off Light Switch Kits (45638) from Lowe’s which include a Primary switch and an Add-On switch. They all paired with my hub (Smartthings) perfectly and switch the loads with out issue.

However, I’m having a problem with status updates with the Add-On switch.

When the Add-On switch is manually pressed the lights come on indicating the primary successfully received the request from the Add-On switch, however the primary never sends a notification to the smart hub indicating that the light has been switched on. If I manually switch the lights on from the Primary switch the lights come on and the hub receives the proper notifications.

All three kits behave the same way. It appears the Add-on is triggering the primary to switch on the load but not triggering the primary to update the hub. I’ve tried various ways of excluding and re-including the switches with no changes. If the Add-On is slaving off the Primary I would expect that any action performed on the Add-On also triggers the same from the Primary.

How do get the Add-On to trigger the primary to send the proper notifications to the hub?

Jasco Support:

Thank you for contacting Jasco Products Company.

First things first our switches do not send ant notifications to the hub saying that the status has changed. What is happening is the hub sees that the status has changed from on to off or off to on. Unfortunately no one of our Z-wave switches whether they are the old or new versions send notifications to any hub/controller.

If you need further assistance, you can contact us
by e-mail at support@jascoproducts.com
phone at 1-800-654-8483 option 1,
Monday – Friday, 8:00 a.m. – 5:00 p.m. CST.
To respond, please select “Reply” in your e-mail software, and be sure that the past e-mail is included in this reply.

Me:

Maybe “notification” was the wrong word. Whatever technical term you want to use, the switch is sending unsolicited messages to the hub when the switch is physically pressed.

Here is the log, If I manually press the primary switch the primary tells the hub that it’s been turned on (via Z-Wave message). I see nothing when I press the Add-On (Slave) switch. All I want is for the Add-On to perform exactly as the primary. If you’re saying this isn’t possible then I will return them and look for another solution.

Note that the primary device sends the following Z-Wave specific “ On” message when the switch is manually pressed:

command: 2003, payload: FF

When the primary is manually turned off the primary sends a the following z-wave specific message for “Off”:

command: 2003, payload: 00

The hub is “seeing” the status change because the switch is telling the hub that the status has changed.


(Glen McGowan) #15

This tells me the Primary proactively notifies the hub when you manually press the switch. However, when you manually press the Add-On no update happens and the only update you get is when the hub polls the device (my theory).

Why the !@#$% would they work differently if the Add-On is just a physical extension of the primary?


(John) #16

@mobious Thank you for the updates! I really appreciate you contacting Jasco on this! I didn’t even think to do that, though if I didn’t, I didn’t even know enough that you can get all the details on the actual Z-Wave messages being sent!

Please keep us posted, I would love if this worked the way it should


(Glen McGowan) #17

Thanks for starting the thread. None of would have noticed.

I have received a response to my last follow-up. I’ll definitely post the conclusion.


(Curt) #18

Folks,
I had this problem with a three way. It turned out to be a wiring issue. With a combination of switch flips, i was losing power to the primary switch.

Play with it. Watch the blue light on the switch.

Btw. My issue was due to the builder tying a switch into the line wire.


(Jason "The Enabler" as deemed so by @Smart) #19

Did you get this fixed? What was the problem, exactly?
This is on every one of my multi switch ups. But my house is less than two years old.

Not sure what kind of electrical problem would cause this.


(Glen McGowan) #20

Current status with Jasco:

Jasco:

I know it looks like the primary switch is sending out its status but it doesn’t, what you are seeing is the hub changing the status when it sees the switch being turned on/off whether it was done manually or remotely. The add-on switch does not send or receive any Z-wave signals, it only communicates with the primary switch only. the hub should be seeing that when you turn the lights on from the add-on switch because it’s the primary switch that is doing the actual work. This all falls under the hub since again because it’s the hub that is “polling the switch” meaning that it updates its status when the hub notices that it has changed.

Me:

Are you saying it’s the hub polling the device periodically for changes that picks up the state change? This would imply the hub is polling the device somewhere close to every second or two.

It still wouldn’t explain why the state changes for the add-on isn’t happening. It implies the primary isn’t updating its status properly when the add-on is toggled.

I fully understand the Add-On is just a $0.25 momentary switch which closes a contact on the primary and signals the primary to do all the “work”. You guys did a great job with the price mark up. :slight_smile:

They are obviously the experts about their own devices, but it really looks like the primary is sending unsolicited state changes to the hub in this case. I’m having a little trouble believing that the hub is constantly polling the device at a rate frequently enough to give the appearance that the device is notifying the hub.