GE Link Bulbs no more useful than standard LED's?

only if you dont copy and paste that as well. but you dont need the zigbee id. I completely delete it as it’s not used.

I’ve been steadily moving all of my links to lamps. I’ve never had a failure in a lamp and my lighting scenes have greatly improved in success rate.

unplug your hub for 2 hours, all the link bulbs will disconnect and not reconnect until you do it manually. This is a guaranteed way of causing the issue.

Also have a kid play with the light switch, the 5 3 second on-off reset cycles reported int he documentation is not truthful. if you rapid fire the lamp on-off-on-off you will trigger the repairing sequence and it will fall off your network.

Luckily I have only 4 of them when they were clearanced out at $9.00 each from a local store with all the wink stuff they stopped carrying. I will be changing them over to Osram Lightify bulbs as those are the most stable of any brand of bulb I have used. The other advantage of switching away from the GE bulbs is that you get bulb software updates from SmartThings on officially supported bulbs. GE Links will never get an update through a ST hub.

1 Like

I’d like to get three more of the BR30 style if on clearance somewhere or used. I see them for $16 and such, but I’m in the market for maybe $9 each at most, since the next usage is a ‘nice to have’ scenario. If anyone has that and wants to get rid of them, send a PM.

Many people seem to have issues with the GE Link bulbs disconnecting and dropping and it seems platform independent - I’ve seen complaints from both Wink and ST users. For what it is worth, I’ve used GE Link bulbs with my Wink hub since October or November of 2014 and they’ve been rock solid.

I’d like to add some to my SmartThings hub, but I do have one question though - is there a need to use a custom device type with the GE Link bulbs or does ST have a reliable device type already installed? I’ve currently got most of my GE Links on a Wink hub but I have some spares I’d like to put on my SmartThings v2 and may move the Wink bulbs over as well. I saw Drewbert34’s screenshot and noticed he is using a “My GE Link Bulb v2” device type and just wondered where he got it.

Give me a sec and I’ll update this post w/link…

1 Like

Thanks! I saw that code earlier but wasn’t 100% sure if it was the same code.

Some people have tons of problems, some people don’t have any. I’ve been (knock on wood) lucky so far and haven’t had them drop off randomly ever.

1 Like

Hi Brad, the stock GE Link devicetype now includes almost all of the custom code, so you could really go either way. I think we updated the custom type with the new UI style, and ST hasn’t done that yet.

Don’t forget if you have a v2 hub, the stock device type will run local with automations, but the custom one will not.

1 Like

There can also be channel issues, and since the SmartThings hub does not allow you to change the Zigbee channel, and its own channel is randomly assigned at the factory, that’s something that can affect some users and not others. And also depends on local interference.

My GE links drop off much less often when they are attached to a link hub than they were when they are attached to my SmartThings hub.

1 Like


I have better experiences depending on my wifi channel. Also, with my neighbors equipment getting better, it appears their broadcast range has increased, further compounding plausible zigbee bulb reliability.


I have issues with zigbee devices on one side of the house, including the SmartThings arrival sensor, many weekday afternoons starting right around 3:40 PM. It seems really clear that one of my neighbors has boosted Wi-Fi and a kid that gets home from school around then. :flushed:

Exactly why I love z-wave and cannot completely comprehend the zigbee push. I wish I had z-wave bulbs for my lamps…maybe one day.

1 Like

I finally started getting GE Link issues on the ST V2 hub just like I did with my Wink hub, strangely once the first failed, several have since failed in quick succession, what I have personally had success with is switching the light off at the switch for 15 minutes+ and then turning it back on.

Seems they integrate themselves back in to the mesh and start responding again without doing anything else.

1 Like

This might be of interest:


Awesome, that was the page I was asking you about in PMs. As always, @JDRoberts to the rescue!


Agreed. I really don’t understand how anyone can push Zigbee as more homeowners are getting high-powered WiFi.

I installed an Amazon Fire stick a few months ago, which only works on 2.4 Ghz and my entire Zigbee network went to hell. Ultimately, I just pulled the stick and everything started working again. That thing must spam the spectrum. Now I try to keep any 2.4 Ghz device out of the house and only use the 5GHz band on my router.

But after that incident, I won’t buy another Zigbee device. I dread the day I get a cord-cutting neighbor who is streaming a lot of video over WiFi. I’ll probably have to toss every Zigbee device I own.

(PS. Per previous discussion, the “IDE trick” works for both Zigbee and Z-wave.)

1 Like

I regret that I have but one like to give this post

Problem is Zigbee requires very advanced users. you need to connect to the IDE and search for your Zigbee Channel being used, then go online and learn about zigbee and Wifi overlapping then connect to your wifi devices and move all of them away from the wifi channel that your zigbee network lives in. I did this and it increased the reliability of my zigbee network along with buying 6 zigbee repeater outlets and clustering them in trouble spots in the home.

In other words, 95% of consumers will never ever be able to do this. Honestly ST could have made it a LOT more reliable by only using channels that sat in the main wifi overlaps or outside of wifi’s band, ch 15,20,25,26 are the only useable zigbee channels, and honestly I consider 15 and 20 to be barely useable. Having a “wispy” tol to sniff and show me the spectrum use going on in my location I see a lot of noise there. - for more information…

Oh also turn off 802.11n support if you only have a 2.4ghz wifi router, it blows up the whole wifi band as it will start consuming most of it.

Just the above will make most people say, “OK, I’m not interested”

1 Like

Wow, I must be extremely lucky then. I took all 7 bulbs out of the box, put them in lamps, saw them blink, added to ST, and not one has dropped off yet. I didn’t even know they were in the same spectrum as wifi until I started reading this. It just worked for me, and I have two wifi networks (channel 1 and 6) running in the house.

1 Like