GE addon switch does not turn off light

I just installed two switches along with the addons.

Seems to work other than the addon switchs. They turn on lights, but not off. Using my phone, motion sensor, and main switch works fine. Is this by design or what. Can someone answer?

I’ve got a few of these switches installed and they work fine. Dumb question, but do you have the traveler wire connected on both ends? Assuming it’s wired correctly, it may be a defective switch.

That may be my issue. I only have;

2 black
1 white
Could not find a traveler (red)

House was built in 58.

There was a extra white wire I found in the main box, the was not connected to anything, so I striped it and used it as my neutral wire for my main boxes/switches. (Two different lights.)

Both light kitchen and dining room lights function the same.

Thank you for the help

Bryan Tuttle

Sounds like you have it wired wrong. Are you saying the add on switch will turn the light on but not off?

Your probably going to have to provide more detail about your wiring before anyone can help you much.

You need to make sure you wired it right. These don’t wire up like normal switches. There are decent drawings online.

The main switch must be right since it’s working. You need a wire (traveler) can be red,white,black it’s hard to say without seeing what’s there. It runs from the screw that says no 120v to the second switch. Then you need a neutral on your second switch to complete the curcuit.

The main switch runs the load. The remote switch just tells the main what you have pressed so the main knows what to do.

1 Like

As a note, based on wiring diagrams I’ve found that you may not need a traveler for the GE add-on switch. If both the power (neutral line) and load to light are available in the same gang box, no traveler is needed.

Edit: Clarification I meant no third line (AKA second traveler) is needed. Just a neutral and “traveler”

I’d have to see that. Yes you do not need the traveler if your only using the main switch. As it evident by the original post. His main switch works but not the remote switch that is the 2nd switch in the 3 way wiring system.

My GE switches I wired in a 3 way circuit. Had to have a wire from the main switch to the remote switch. If you don’t have that how will the main switch know what the remote switch is doing. They do not talk to each other through the mesh network. I am pretty sure the remote (2nd switch) doesn’t have a radio.

Just my 2 cents worth of info. I’m not an electrician.

Here is more info that may help us all.

Let me clarify as my nomenclature was confusing. I meant above that you only need two lines, not three as a standard switch would need. I have the situation I described above with one of my smart GE switches and an add-on. The add-on switch needs only two lines. A neutral line and a line from its “traveler” to the traveler of the smart switch.

The third line is only needed if you need to send a load from the smart switch to the light load in the other gang box. On the diagrams it is labeled as traveler 2. So in my case since the power and light load were in the same box, I only used two lines to connect my add-on switch as a second traveler was not needed.


Did you ever get this solved? I have the same issue with an add on I installed today. I’ve installed many of these in the past and don’t recall this behavior. The main switch works fine; the add-on will turn the switch on, but not off. Maybe I swapped the locations of where the main and add on should be? (Does that even matter? I just usually tie the line and load together in the box where the add on is, which seems to always work fine…).

Thanks for any help as to how you solved this!

I had this issue last night.

Old 3way switch had red traveler, then a traveler 2 and a common.

At first I tried tying the traveler 2 and the common together with a jumper and ran the jumper to the switch. This however caused this issue of the 3way being able to turn the light on but not off.

To fix this I instead left traveler 2 and common tied together but instead put the jumper to the neutral wires that were tied together in the box (not to the old switch at all). It then worked as expected.