GD00Z-4 cannot sync with ST

Sorry for the duplicate post - I do not seem to get any response from replying to previous posts.
I cannot get the GD00Z-4 to sync with ST hub. I installed the tilt=-sensor and the unit and powered it up (yes, battery-tab is removed form the tilt-sensor) I first tried to sync in the garage while pressing the sync button - nothing, not being discovered by ST.
Then I removed the unit and moved it closer to the hub(living room), to ensure it gets a good signal - I left the tilt sensor on the garage door.
I tried everything, I even hold the button (till it beeped) - does this mean it is now expecting to re-sync with the tilt-sensor?
I even hold the sync button until it beeps constantly. Still cannot sync with ST.
I even pressed the sync button five times, it beeped and flashed red once. Still cannot connect to ST.
I recycled the power a few times, in between the above steps.

Why cant ST see this unit? All my other devices works without any problems.
What should I do next? Remove the tilt-sensor from door and bring it closer to the unit and try sync that first, before I try to sync with ST?
Does the sync between the tilt-sensor and the unit needs to be established first, before it can connect to the Z-wave / ST network?

When you say “closer”…how close do you mean? Z-Wave door openers, locks, etc need to be extra close to the hub in order to allow them to join your network. When I setup my GD00Z-4 I had to have the unit practically touching the hub before that step worked.

There was a review I found on Amazon that got me going, I’ll paste it below. I had my unit and my tilt senor in the living room with me, right next to the hub. My unit was sold as new, but it was used and someone had set it up before me.

I had to do several rounds of factory resetting, excluding, pairing tilt sensor, pairing to hub. Took a good hour of trying, but it finally connected.

Here’s the info I used to get going.

5 stars for functionality, 2 stars or less for product support. First off, I should say that I purchased this from Amazon WarehouseDeals as Used-Very Good. Ok, I have to say I was hesitantly excited about getting this product after reading so many reviews. My brother purchased one about a month ago and had no problems setting it up and getting it working. I however, did not have the easy setup. After several hours and searching online for help (other than GoControl grrr…) I was able to get it up and running. Here are some of the things that I ran into and the answers I found to help me:

*** The Controller did not sync to my SmartThings hub ***
As was suggested by the manual and other reviewers, you are encouraged to plug in the Controller near your SmartThings hub before you connect it to your garage door unit. This I did but it would not find or sync when I did a “Add a Thing” in the SmartThings app. I finally got it to work by whats called “Excluding” or resetting the device. I found instructions about this on the SmartThings website ( These is how you do it:

To reset the GoControl Linear Garage Door Opener (GD00Z-4)

If the GD00Z-4 was not discovered, you may need to reset, or “exclude,” the device before it
can successfully connect with the SmartThings Hub. To do this in the SmartThings mobile app:

  1. Tap the menu (Android) / More (iOS)
  2. Tap the Hub (it may be “Hub is Online”)
  3. Tap Z-Wave Utilities
  4. Tap General Device Exclusion
  5. When prompted, press and release the link button on the GD00Z-4

After the app indicates that the device was successfully removed from SmartThings, follow the first
set of instructions to connect the GoControl Linear Garage Door Opener.

*** Status in SmartThings app showed as Unknown ***
After connecting the Controller to the garage door unit and plugging it in, the status would not change from Unknown in the app. I removed it (un-synced it) from the app and re-synced it again but it still showed as Unknown. I even bought a new battery for the Tilt Sensor just to make sure. However, again after some searching, I found some discussion and instructions about re-pairing the Controller and Tilt Sensor and found that this made it work! The discussion is found here (Linear GD00Z-4 Z-Wave - Stays as "Unknown") and the steps that got it to finally to show up in the app for me were these:

To “re-pair” or pair the Controller and Tilt Sensor

  1. Make sure the Controller is plugged in to power and connected to the Garage door unit
  2. Make sure the Tilt Sensor is on your garage door (as instructed)
  3. Press and hold the Link button on the side of the Controller for 7 seconds until it beeps
  4. Open the garage door (the Controller should beep and flash a light)
  5. Close the garage door
  6. The status in the SmartThings app should now be updated (no longer Unknown).

I hope this helps! And I hope this lasts longer than a year as some reviewers have written about. Although, I wonder if it may appear as the Controller breaking but that perhaps the battery in the Tilt Sensor needs to be replaced and/or a re-pairing between the Controller and Tilt Sensor needs to be done. Good luck!

Factory reset is done with the 5 presses:

Do a factory reset on the unit prior to adding it.
a. Power the unit up
b. tap the link button 5 times in rapid succession
c. beeps will indicate that the unit has been restored to factory settings

1 Like

In the same room, about 6-8ft from the ST hub.
Is that good?

Well, when I compare that distance with what I said about my own experience…

…I have to go with, “No”.

I got it working. Thank you.
I think the magic was getting the tilit sensor synced up and then did an ST exclude.
That did the trick (and the 6-8 feet distance did work fine)

Thanks for your help!

hello guys,

I’m trying to pair gocontrol but the smartthings cant find it.

I tryied to exclude the device but the exclusion proces cannot be finished. its just loading for 5 - 10 minutes.

how many minutes in loading mode for exclusion are ok?

How far away from your ST hub is the GoControl unit when you’re trying to pair them?

practicaly touching…

I just payed for rboy device handler rboy : Z-Wave Garage Door Opener with Switch Capability]

published it but linear cannot be finded

then I added the device from smartthings ide choosed [rboy : Z-Wave Garage Door Opener with Switch Capability

and when I search for devices in smartthings app it was visualized but now its not working with status unknown.

offtopic: actualy i havent succes with other z-wave device thats not paired but cannot be excluded. (aeotec energy meter v.1) may be device exlusion cannot work with my hub but why? :frowning: