FortrezZ Water Flow Meter

This is great, thanks!

Hi John,

Now that I have SharpTools handling water flow notifications, I would really like to turn off the Smartthings “leak” notification that gets sent every time the water runs, but I cannot find a way to do this.
Attached screenshot shows the Water Meter notification is turned off, but that doesn’t seem to have any effect. I set the two values in “settings” to the max, but that also seems not to have any effect. Is there any thing else I can try?

IMG_B08B4FE95B9C-1.jpegIMG_A920B9CECA08-1.jpeg

Thanks,
Michael

PS: I’m not sure one really needs to wire in the wet notification into the Edge driver since anyone who wants this function can set it up as a ST routine:

IMG_F961C8ABACB4-1.jpeg

You have the one place identified, but within the Home Monitor application where you set up smoke, security, and leak detection, did you have the Leak Detection set up to always include all leak detectors (default), if so, you need to remove the meter from there.

I had to write that capability into the driver so that it would be exposed for automations because it’s not there by default. The driver doesn’t do any notifications, it just creates the event so that you can use a routine/automation.

Thanks! That worked…no more notifications!

1 Like

My fortrezz flow meter seems to have come back to life reporting flow today (after months of updating temperature only). I had been meaning to do an exclusion and repairing as I think the Edge switchover process hadn’t happened correctly? Not sure if today’s new activity on the device is related to the recent hub firmware update that somehow improved the connection?

I’m getting the same leak notification of the fortrezz water sensor being wet every time water runs also.

But in Smartthings home monitor, I have not included that device with the rest of my leak sensors for monitoring (and my leak Sonos audio notifications do not play when the fortrezz sends the notification message, further suggesting that it’s not coming from the home monitor).

On the device settings page I see the 3 options that do not appear to address wetness notifications.

Any other ideas?

Also, is there an edge Device or setting that allows resetting the total number of gallons now?

Thanks especially to John for keeping this device relevant!

Hi @Natec

I’m not sure why it would just start working, but I would have to imagine that it’s related to getting the proper Edge driver assigned to the device.

Since you don’t have it in Home Monitor, the only place left to check will be under Notification Settings and to disable the device there. It can be found this way:

Menu (bottom right of the app) → Notifications → tap on the three vertical dots and then tap on Notification Settings → find your water meter and turn off notifications for it

My driver doesn’t expose the reset command in the mobile app (so someone doesn’t accidentally reset the meter), but there are now two ways to reset this meter. One is described above in my first post. The other and very handy solution is with the new web app ST just released. If you’ve not seen that yet, you absolutely need to start using it:

To send or control any device via the new advanced user app, go to Devices and find your meter. Scroll down until you see Commands. Click on “resetEnergyMeter” and it will be reset immediately.

Glad to hear that its’ working for you!

1 Like

Thanks for creating this driver. It appears that you updated it recently, in June or so.

I have SmartThings integrated with Home Assistant.

Your updated driver still works perfectly within SmartThings. And, it had been working perfectly in Home Assistant before the update, creating a sensor entity in Home Assistant for water flow named “FortrezZ Flow Meter Power Meter” (sensor.zz_water_flow_meter_power_meter).

However, now it no longer updates that value. It’s stuck at the same value and does not change as the flow change. If I install different edge drivers, I can get it to update to the current flow state at the time the driver is reinstalled; however, it fails to update further.

Any suggestions? Very much apperciated!

Hi @FortranFour ,

My new Edge driver for the flow meter now uses custom capabilities and doesn’t update attributes for either ST’s “powerMeter” or “energyMeter” capabilities. That’s why any data related to power or energy don’t get updated.

What other drivers have you tried? The only other one I know that could still work would be ST’s “zwave-electricity-meter” driver that may expose energy and power meter data coming from the meter.

I don’t use Home Assistant, nor am I familiar with how HA and ST are integrated. Should that integration be updated for the meter’s new capabilities?

Thanks, much appreciated. The ST driver “Z-Wave Electric Meter” reports cumulative consumption using the “Power meter,” with units of Watts, equivalent to gallons. The “Energy consumption” does not seem to update. While total usage is communicated to Home Assistant, rate of flow is not. (There is however a capability to take a derivative in Home Assistant and compute it.) I think that updating the overall Home Assistant Integration with SmartThings would prove challenging. Is there anyway that you could repost the older version of your driver, so that I can resume using it?

Hi @FortranFour,

My driver was last updated almost a year ago on 2022-09-16 at around Noon:

Advanced web app:

Mobile app:

I never had an edge driver that exposed power or energy meter capabilities, so perhaps you were using my groovy DTH up until June? If your device was updated in June, did you already have my edge driver enrolled and then let ST auto migrate you from the groovy handler to this edge driver?

Ah, yes, thanks for jogging my memory. Per our exchange last September, posts 528-531, above, I see that I indeed had been using your custom groovy DTH and installed your edge driver in anticipation of the migration, which evidently did not take place until June. I humbly submit that the future is Home Assistant. Is there any way I can persuade you to update your edge driver to restore exposing the power and energy meter capabilities?

Hi @FortranFour, I have plans to update my driver as soon as a couple other projects wrap up so i can add your request to my changes. I can update this post when it’s done.

3 Likes