Fire Tablet Setup Script for ActionTiles [BETA UPDATE 12-4-18]

The script does not root your tablet.
It’s basic function is to make side loading the apps easier. And if you’re on an old enough firmware version it will remove Amazon apps.

Truthfully, if you are just running ActionTiles, the script is not needed at all. I used it on all of my Tablets because Ineas able to load LANnouncer. Now with Echo Speaks, that is not needed any longer.

Script is still good though to load the Google Apps.

1 Like

Thanks Ron! do you need the script to run LANnouncer? I am not an alexa house so Echos are not an option.

you can sideload it manually or you can use the script and save yourself some time trying to find the APK to download it and then side-load.

thank you apron7676, I just ordered my HD8 so I will give it a shot
Thank you!


I have added a little low-key announcement about ActionTiles being now available in the Amazon Appstore.

Please click below for details. Cheers!

1 Like

Hmm. Game changer? Only thing that would make this better if there was a holiday deal on action tiles right now!

15% off Location/Hub Licenses using Code: HOHO15P - Expires Dec 28, 2018.


I have some questions about getting going with my new, unopened, 2018 (I assume; just got it directly from Amz in Nov.) Fire 7 Tablet…

Q1: do i need to root it?
I recall discussions a while back (maybe a year or two ago or more) rooting being a way of getting these things to a state where we can actually use them like we would any otherwise ‘normal’ Android tablet.

Is that no longer necessary, and will this script do enough for me?

Q2: If I’m going to be using Echo Speaks instead of LANnouncer, and the newly released ActionTiles app (assuming I can get it on there…can I?) instead of Fully, will I still benefit from using this script, or is there a better way of going about what I want?

Curious on how I can get my ring cameras into action tiles, if I still need to sideload the third party app?

aron7676 I am running the script on a brand new 8th gen HD8. There are tons of failures and after the first go through I do have Google Chrome on the system but all of the side loaded apps look to fail (LANNouncer etc.)
“enabling sideloading apps”
“the syntax of the command is incorrect”

Also, at the initial running of the script it asked which generation I have, it only goes to 7, and I have an 8… does this not work for Gen 8? (I have the updated script FireUtility.bat with date 12/6/2018

Beta script is still being worked on in my not so ample free time.

If it installed play store you should be able to get the extra apps that way.

Thank you Aron7676! This is all much appreciated

this utility is not installing the google play services, says its missing

Beta version?

yes, but i just downloaded the latest services and inserted into the apps folder and it worked

@aron7676 I am trying to use the script on Fire 7 (5th edition) and I am getting “Failure [DELETE_FAILED_INTERNAL_ERROR]” on many of the processes I have tried.

Removing ads:

Removing preloaded apps (this is a continual scrolling of may errors):

I can paste more, but its all the same. Any ideas?

I ran into a problem Fire tablet running fire OS fails to install Google Play services. Tried the Beta and prior version. The rest of the script except other programs option 8 ran ok.

Any suggestions I need Lannaounce and it will not load .

I had the same problem, i downloaded the most recent services apk and renamed it to “GPServices-7gen-3.apk” and put it in the apps folder. its a work around. looks like a broken link to the apk in the script but this will do the same thing.