Fibaro Roller Shutter 2 - Problem with routines in Smartthings

I can’t get my Fibaro Roller Shutters to work with routines in Smartthings. They work fine in the app when I choose open or close. But when I try to make a simple routine to e.g close all shades in the kitchen, nothing happens. I am using the official Fibaro DH. Here is what I have tried:

Automation --> Add a routine --> Open or close Windows Shades --> “Blinds Kitchen 1” and Blinds Kitchen 2" --> Action: 100% open --> Save

I made routines with different shades, open/close, even chosen the alternative “garage door” for the shade. But nothing happens when I test the routine, the shades don’t move an inch. I also tried all the operating modes in the settings for the DH.

Does anyone have a clue what’s wrong with my setup? Do any of you have Fibaro Roller Shutters that work with routines in Smartthings? How? What DH do you use?

Any help or suggestion would be highly appreciated! Thanks!

Here are some screenshots:

I just tried the DH made by @julbmann and now at least I am able to see my shades in ActionTiles and control them with Google Home. However, they still won’t work with a simple routine. Has anyone faced a similar problem? I would love to be able to make a routine that would open or close the shades at a certain time…


Same problem here.

did you manage to find a fix for routines?

Unfortunately no. I still don’t know how to make them work with routines. I contacted Fibaro support and Smartthings support also, but they couldn’t help either. They told me to ask the community, but no luck here either…

set the fibaro as dimmer light and it will work - i just did right now

Yeah, thanks! However with this DH you can’t properly control the blinds. I have venetian blinds, and the slats won’t close when I use the dimmer light DH. I guess it’s maybe possible to tweak it to close the slats also, but I don’t know how to do it.

@Torigo i have same problem, i have modified source to work.
Get this (note at this time only smartthings classic control blind)

Thank you for your help @Mauro_Celli!
I tried using your modified DH and it worked on some of my blinds, but for some weird reason not on all of them. It really makes no sense. I set your DH for 8 of my blinds, made a routine to open all blinds, but only 3 opened. All settings were the same. I don’t understand why.

However, I have found a temporary solution. I changed the DH to Z-Wave Switch Secure. Now I am able to use both routines and Google Home to control the blinds. Though it lacks individual blind settings, at least now the blinds automatically open and closes according to my routines and they also work with both ActionTiles and Google Home.