Fibaro RGBW + Smartthings + Echo, Alexa doesn't like green?

This is a peculiar glitch, and perhaps this is the wrong forum for it, but here goes.

I have a Fibaro RGBW working great with smartthings. Through the Smartthings app I can control the full RGB spectrum, as well as the white channel, brightness, everything. Binding was easy, works great.

Amazon echo picks up the device via Smartthings and can control it, including setting colors by voice command “Alexa, set lightstrip color to blue”… Except that she won’t set it to green (or really anything between cyan and yellow).

She doesn’t misunderstand the command - this isn’t a voice recognition fail. She hears me and says okay, the same way she does for other valid colors. So, for example, I’m not getting an error like I would if I said “set lightstrip color to monkey”. However, even though she understands and acknowledges the command, she won’t actually change the color to anything cyan through yellow.

I have no problem setting those colors from the smartthings app, so this isn’t a channel wiring issue.


Hmm, we don’t have one of those to test but have you watched Live Logs to see what command is being sent?

Hi, I just wanted to say that i am having a similar issue with google home and fibaro RGBW,
Its not a wiring issue as i can control it in smarthings


  • i can set color to blue in smarthings= works fine
  • Ask google to change to blue (initially a different colour) = nothing happens
  • Ask google to change to red = get colour red

ill try to log it tonight and ill report back


Ok so i tried with google home
This is the order in which i executed my test

  1. Change Counter Lights to red = red
    2.Change Counter Lights to blue = No change
    3.Change Counter Lights to yellow = green

Note through the smarthings app, i have no such problem, its only via google home

e9383d6b-90ca-420d-845d-913d3f888d9e 8:26:01 PM: debug off()
e9383d6b-90ca-420d-845d-913d3f888d9e 8:25:18 PM: debug setColor: [hue:16, saturation:99]
e9383d6b-90ca-420d-845d-913d3f888d9e 8:25:18 PM: debug on()
e9383d6b-90ca-420d-845d-913d3f888d9e 8:25:03 PM: error groovy.lang.GroovyRuntimeException: Ambiguous method overloading for method java.lang.Float#minus.
Cannot resolve which method to invoke for [null] due to overlapping prototypes between:
[class java.lang.Character]
[class java.lang.Number] @ line 722
e9383d6b-90ca-420d-845d-913d3f888d9e 8:25:03 PM: debug setColor: [hue:33, saturation:99]
e9383d6b-90ca-420d-845d-913d3f888d9e 8:25:03 PM: debug on()
e9383d6b-90ca-420d-845d-913d3f888d9e 8:24:56 PM: error groovy.lang.GroovyRuntimeException: Ambiguous method overloading for method java.lang.Float#minus.
Cannot resolve which method to invoke for [null] due to overlapping prototypes between:
[class java.lang.Character]
[class java.lang.Number] @ line 722

Comparing a command from Google Assistant to a command in the app, it looks like the command from Google Assistant is failing to send the full command for setColor.

For example, I see the setColor generating from Google Assistant as “setColor([hue:33, saturation:99])” while the command from the app sends “setColor([hue:83, saturation:100, level:25, hex:#fa00ff, rh:3e, gh:00, bh:40])”.

I’ve flagged the issue and will follow up on it during working hours tomorrow.

1 Like

If I can figure out how to find the log file when I get home tonight (I looked briefly this morning and couldn’t find it), I’ll send along the logs from my amazon echo.

Well, one of our best engineers happened to take a look and found the issue. The fix should be released in the next week or two. The issue actually isn’t that only hue and saturation are being sent but rather the way they are being parsed. This is limited to the Fibaro RGBW, which isn’t technically certified as a Works with SmartThings device, but good to get it fixed regardless!


Thanks for the quick updates! Looking forward to it

A fix for this should have gone out this afternoon. Please give it a try and let me know, thanks!

1 Like

Work wonders! THanks!


How do we get this fix? Is there an official Smartthings device handler I should be using?

The Fibaro RGBW isn’t officially compatible but we do have a device handler for it.

Did your device(s) pair with this device handler?

Thanks, I don’t think there was a device handler last year when I set mine up. I’ve tried a few from git hub, and currently use Todd Wackford’s as it has a button for white that only uses the warm white LEDs rather than making white by using the RGB LEDs.

To change colours using Alexa I had to use Todd’s Turn on Police Light When Switch Is On App, installing an app for each colour I wanted to be able to turn on. This works fine “Alexa, turn on magenta” But with the recent Alexa updates I’ve found I can ask Alexa to set the lights to Magenta which is more natural. But I find that if warm white is on then the RGB LED’s turn to magenta but the warm white LED’s also stay on. And there is no way to ask Alexa set the lights to warm white, so I still have to ask her to turn on the warm white switch.

How would I try the device handler you mention, would I need to remove the DTHs from my IDE, remove and re-add my device? Or is there an easier way. And does it have a warm white button?

I’m not sure about the warm white button but you can login at and change the device type from the dropdown list.

I cannot see this device handler mentioned by Brad could you please post me a link to this, I can can see fibaro devices not the rgbw, but a separate rugby controller but not fibaro.

Also can one use some of the programmed sequences through googlehome

Great it is sorted. Thanks