Fibaro RGBW sets off lights everywhere, but only when physically activated


(Paul Reid) #1

I’m hoping someone can help me here.

I have a bunch of GE dimmers, which all work fine. I also have 4 Fibaro RGBW devices for my low voltage lighting (LED strips for certain areas, kitchen cabinets, etc.)

Everything used to work well, but over the last several weeks I’ve noticed that if I turn on one of the Fibaros with the mobile app, everything works as it should. However, if I turn on one of the Fibaros from my wired switch, not only does the light the Fibaro is connected to turn on, but about 30-60 seconds later, a whole bunch of other lights will turn on (ones connected to the GE switches). It’s super weird. In most cases, if I turn off the Fibaro and wait 30-60 seconds, all the other lights will turn off, too.

I should note that all of the Fibaros turn on different random lights, too. It’s not all the same lights - but once a particular Fibaro has randomly selected some lights, it’ll stick with them. For example, my downstairs hallway Fibaro will always turn the upstairs bathroom light on and off (in addition to the light it’s supposed to be controlling), and my laundry room Fibaro will always turn the front door and front entrance light on and off.

I don’t have any SmartApps or routines or groups associated with the Fibaros (other than the Amazon Echo), so I’m not sure how this is happening.

I did notice that if I turn on a Fibaro from the mobile app, I can see it in the live logging in the IDE. If I use the physical switch, nothing is logged. I’m sure that’s related somehow. It’s almost as if the Fibaro is not talking to the SmartThings hub at all when I use the manual switch, and then somehow telling other switches to turn on and off - totally without SmartThings help - yet nothing like that was ever configured. The Fibaro RGBW’s were just set up to act like a dimmer for low voltage loads - nothing fancy.

I did use a third party device handler at one point for the Fibaro RGBW’s (since it allowed me to control the 4 loads independantly, which was helpful in some cases), but even switching everything back to the built-in device driver doesn’t solve the issue.

Does anyone have any ideas as to what can be done about this? It’s driving me crazy when I turn on the kitchen counter lights, and 30 seconds later the whole upper floor’s lights are on (living room, front door, kitchen, kitchen bar, bathroom, and stairs).

Any help or suggestions would be appreciated. I’m kind of stumped as to what to do about it, at this point.

Thanks!


(Paul Reid) #2

I did some testing, and even when the SmartThings hub is disconnected (and powered off), the Fibaro RGBW still activates the random lights. It looks like this is a “feature” of the Fibaro RGBW called “associations”, where the controller can send commands to other Z-Wave devices on the same network directly, bypassing the SmartThings hub entirely.

How these damn things got themselves configured for random lights, I have no idea, but that’s what they’re doing. The question is now, how do I tell them to knock it off without yanking them out of the wall, resetting them, deleting them from the network, then re-configuring them all from scratch again? I know this feature can be configured with Fibaro’s own software (Home Center), but for those not using Home Center, there doesn’t appear to be a way to reconfigure them - and they seem to somehow just configure themselves for whatever reason. That’s pretty unacceptable from a rather expensive device.

Does anyone have any ideas of how this feature can be turned off, or at least reconfigured, without Home Center?

Thanks!


(Paul Reid) #3

Ok. I fixed my own problem. I was right - it is the associations feature in the Fibraro RGBW controller talking to my other switches directly. I still don’t know how this got randomly configured - best I can guess is that it happened during one of the Z-Wave network repairs I ran from the SmartThings hub while trying to sort out some problems.

The solution was to use David Lomas’ excellent Fibaro RGBW Controller, which gives you a whole bunch more control than the default controller that SmartThings uses. One of the things it adds is the ability to configure associations. I just had it wipe the existing associations on all of my devices, and poof - all fixed! Plus I get way more control over the 4 channels on the controller, and reporting on power, etc. So much better!

Big, huge, amazing thanks to David for his hard work on the code. You saved me! Cheers!


#4

I’m glad you got it figured out! :sunglasses:

“Association” is a feature of the Z wave standard, it’s just that not all manufacturers implement it on all devices.

If the devices do support Association, you can set them up with the Z wave tweaker, with some device-specific device type handlers, or with some physical devices (such as a minimote)…

I’ve never heard of an association being set accidentally during inclusion, but I suppose anything is possible. Did you by any chance use a Minimote during the process? That’s the most common way of accidentally setting associations.

You can See whether or not a device is capable of using association by looking at its official entry on the Z wave alliance website:

http://products.z-wavealliance.org

And you can see whether associations have in fact been set for a device by using the Z wave Tweaker:


(Paul Reid) #5

Hi, JD.

Thanks for the reply. That’s great information - especially the device handler. That could come in very handy at some point, I bet.

I don’t have a Minimote, so that can’t be the issue. The problems started when I added my second Fibaro RGBW. It was acting weird, so I ended up removing and re-adding it a couple of times, then doing a Z-Wave repair a few times (which never seems to finish. I left it for hours at one point, and still it never finished). I then added my other Fibaro RGBW’s, but noticed weird lights going on and off via associations I never configured on all of my Fibaro RGBW’s - including the original one I installed months earlier, which had always worked fine. It took me quite a while to get time to really look into it, and that’s when I discovered the associations thing and nailed down the problem. Why it happened, though, is a mystery.

Thanks again for the help, JD. It’s much appreciated.


(Paul Reid) #6

Hi, everyone,

Just an update on this, since I’ve been dealing with it for some time now. These Fibaro RGBW controllers constantly associate themselves to random switches in the house. It’s extremely frustrating, to the point that I’m about to remove every one of them and burn them in the back yard. When the do this, I have to go into the SmartThings IDE, find the offending controller, edit the preferences, then just save (no changes). Nothing ever shows in the associations, but doing this process clears the associate that these devices just randomly set themselves up with. It’s totally random what switch a given Fibaro will attach itself to. Sometimes it’s just one, and other times it’s several all at once. Just out of nowhere. Nothing has been fiddled with in terms of the SmartThings setup - they just do this all by themselves. It’s incredibly maddening!

Has anyone else experienced this type of issue? Surely I can’t be the only one. I have a half dozen of these things controlling low voltage lighting in various areas of the house (kitchen cabinet lighting, etc.) and they all seem to do this now and then. Sometimes they behave for weeks or months, and other times they screw themselves up a day or two after I fix them.

Any ideas or advice anyone has is most welcome. I’m just about out of ideas at this point.

Thanks!


#7

I believe @RobinWinbourne May have some of these devices, he has a lot of Fibaro kit, so just tagging him to see if he has any comments.

Also tagging @duncan just in case he has any ideas.


(Robin) #8

I had a couple of the Fibaro RGBW modules, but no GE switches and I never connected the Fibaros to physical switches (they worked solely off motion / contact sensors).

I never had this issue and can’t explain it.

Maybe try a different handler… this one by @zcapr17 works really well so worth a shot.


(Alwas) #9

I had the same thing, about a month ago, my extractor fan would turn on by itself, until I eventually realised it was when I toggled the kitchen switch with a Fibaro on it, VERY disconcerting.


(Robin) #10

I do find this very odd… I had over 60 Fibaro devices across the full range… I used association on purpose for various things but never had an association setup itself.

The only way I know to create an association (bar using a minimote) is to do it via the ST hub / DTH capable of triggering those commands.

I did once have two zwave Swiid cord switches associate with each other, but I was linking them both to the hub at the same time so that may have had something to do with it… what was odd is that the Swiid devices are gen 1, so direct association should have been impossible!! Never figured it out and couldn’t replicate either!!


(Paul Reid) #11

Thanks so much for the help and tagging in some people who might have some experience with these, JD. It’s very appreciated!


(Paul Reid) #12

Hi, Robin,

Thanks for the suggestion. That is the controller I’m using, actually. The one SmartThings uses natively is a little too simple to really control the Fibaro, so I had installed that controller to gain some extra control over things. I wonder if it’s possible that the controller is causing this? I hadn’t considered that. I assumed it was the hardware itself doing something insane. Maybe I’ll contact @zcapr17 and see if he has any ideas, since he’s obviously been into the guys of the whole thing.

Thanks again for the advice, Robin.


(Paul Reid) #13

Hi, Alwas.

Yeah! It’s like having a ghost in the house laugh.