Fibaro Motion Sensor won't install

Hello, thanks for the help.

I’m trying to install the Fibaro Motion Sensor and am having no luck. Initially, it just installed as a door/window sensor. I’ve tried setting up a device handler and reinstalling, and it seems to load OK, but the readings I get always show motion and vibration. The ‘configure’ button won’t activate anything, but the “Live Logging” in the api shows the button being hit.

Any ideas what I need to do. I’m guessing I missed a step somewhere in the setup.


Checkout this thread.

Thanks, Tim, I appreciate it. Unfortunately, this is all I get. Is there a step I’m missing, maybe?

Hi @Pau22 it may be possible you have the new firmware sensors (v.3.2)

to find out if you do you need to look at the Raw Description in the IDE

the new one is

if its the old one it will be


if you do have the new one then there are two options

The device type by @Fuzzyligic

Which is the only one which works in the UK at the moment or

Or an early version by Smartthings

If you have the old one the @CyrilPeponnet Device type above should work

There’s an issue currently with an internal ST function being evaluated in seconds vs the requested milli seconds, the configuration section of this device relies heavily on this function, so it’s not likely to run all the requested configuration changes until this issue is resolved, which AFAIK is next week some time…

Appreciate it. It is the new firmware. I put the new code it and I’m getting a different look to it, along with the lux, but the motion and vibration are still the same.

I’ll give it a few days to see if the issue Mike referred to is fixed.


After playing for a little bit, the lux and temperature seem to be working. The motion and vibration still show constant movement.

I have the same issue with constant motion , were you able to fix this ?

Yes, but I can’t remember what solved it. I reset the fibaro and reinstalled the code here and it just worked.

This is the code I’m using: