Fibaro Motion sensor Lux Level Reporting?

Does anyone else use Fibaro motion sensors? I Installed it yesterday and I have noticed that its only reported 1 Lux Level in that time. Temp and motion reporting works like a charm but not Lux. I’ve looked at the driver code and it appears to be correct on the surface (i’m not a Groovy coder yet).
Anyone else seen this??

I too have these sensors and for a while I thought the same, it was stuck on a lux level around 58 and the motion was sticking on in SmartThings but I could see the LED reacting properly on the unit itself. The lux level has been updating properly since I’ve moved the hub into its originally intended place which is closer to the sensor in question. It’s likely to be a range thing for yourself, if you can’t move the hub Aeon sells a Z-Wave extender on Amazon for £29, try moving your hub closer first though if you can.

Bear in mind as well that the Fibaro Motion Sensor utilises hysteresis for value reporting. The smaller the hysteresis threshold, the more granular the reporting. By default it won’t wake and broadcast a value unless the light changes by 100 lux.

the default level is 200 lux, but in any event, there’s several community device types that allow you to change the reporting parameters.

Ah, is it? Thanks Mike! It seems like a slightly odd design choice on the part of Fibaro - 200 lux is quite a swing, if you’re planning to use it for context-aware lighting or anything like that.

Hello , just wounded did you sort fibaro sensor and lux level? Seams I have same problem

You need to create a custom device type, the default value for lux change is 200, which unless the sensor is facing a window which gets a lot of light, is unlikely to happen very often.

Check out the device type in this thread, it allows you to tweak all the parameters:

[BETA] Fibaro Motion Sensor - New device-handler with all settings and auto sync feature


maybe that stupid question but how i can create that? do i need to edit device? can you give me instruction step by step?

Within the IDE click on ‘My Device Handlers’ then add new device handler. Select the ‘From Code’ option and then copy the code from This Link and paste it into the the code window. Then click the ‘Create’ button, next you need to click the publish link and then save.

Now click on the ‘My Devices link’ and select the Fibaro motion sensor from the list, click on ‘Edit’ and then change the ‘Type’ to the Fibaro motion sensor at the bottom of the list (all custom device types are added to the bottom of the list). Click save and now you should have access to the custom settings.

1 Like