Fibaro motion sensor grrrrr

Thank you so much ! i got it ! you dont know how long i have been trying to get this to work right ! thanks again

Was it that easy? Go into the IDE published that code, under create new device handler, add in that code then delete the sensor through the app and readd it?

First you wanna delete the sensor from the z wave network once it’s unpaired. Go into the IDE copy and paste the code . Create, then set home, save and publish then once that’s done re add the sensor into the zwave network make sure the sensor is right next to the hub when this is done. Then it should work

Which code did you use? Was this in the add device handler part?

I used this code . https://github.com/CyrilPeponnet/smartthings/tree/master/device-handler/FibaroMotionSensor

Yes in IDE click on the device handler .

I set everything up last night but the sensor still isn’t sensitive enough only detecting me from 6 to 8 feet away. Messed with how it was mounted and everything still not happy, and all my settings are the lowest they can go. I have 25 dollar sensors that pick me up in my living room anywhere I’m at and are 10 times more sensitive,however this one has trouble at 8 feet something is still wrong here. And yes I made sure it was synced.

Also make sure before you copy the code to click on raw , I think it’s on the right side . Once you click on raw copy it

I struggled with this as well until it was suggested that you set the motion sensor up to pick you up crossing the path of it rather than from straight ahead. Depending on the location that may not be possible. I moved mine from the end of the hall to the opposite end so it picks me up walking into the hallway as I pass in front of it. That solved my issue. I do agree they don’t pick up well when walking towards them. I have a Iris detector that picks up EVERYTHING and I find it to actually be worse, because I can’t make it not pick up my dogs and cat. Also, the signal from the Fibaro does seem to be slower than the Iris. So it really depends on your application and what is acceptable.

Thanks again, is it worth all the hassle of setting this up? Is there much within it that you can change?

Yes their is a lot of settings you can change . I’m working on mine now and looks like I’m getting closer to what I wanted

Mines really sensitive and picks me up from a good distance, it’s mounted at the top of the stairs on the roof and wil pick me up at the bottom of the stairs, I haven’t however installed this additional thing, looking at whether it’s worth it?

Brilliant, ill try again, the sensor has to be unpaired from smart things doesn’t it?

Yes (20 characters )

I’ve been through both this and the previous long thread, still struggling.
Temp, batt and lux work ok- but no vibration or motion detection.
In UK, so no github integration- have manually copied raw of Cyril’s code in as a new device handler and published for myself.
Then excluded, hit B button three times and Smartthings confirms exclude.

Every time when I sit Motion Sensor on top of hub and hit b button three times it’s found as a Fibaro smoke detector.
I then go into IDE, change it to the Fibaro motion sensor I’ve published which is at end of list, go into app, press b button 3 times and hit configure and I get this:-

016dc541-d5b0-4c11-9449-f5a2ac9b9169 14:57:20: debug ==> New Zwave Event: zw device: 14, command: 9881, payload: 00 71 05 00 00 00 FF 07 00 01 03 , Battery: null
016dc541-d5b0-4c11-9449-f5a2ac9b9169 14:57:10: debug === Parsed 'zw device: 14, command: 9881, payload: 00 84 07 ’ to [[‘displayed’:false, ‘descriptionText’:Dine Motion: SecurityMessageEncapsulation(commandByte: [], commandClassIdentifier: 132, commandIdentifier: 7, reserved13: 0, secondFrame: false, sequenceCounter: 0, sequenced: false), ‘isStateChange’:false, ‘linkText’:‘Dine Motion’]]
016dc541-d5b0-4c11-9449-f5a2ac9b9169 14:57:10: debug Catchall reached for cmd: SecurityMessageEncapsulation(commandByte: [], commandClassIdentifier: 132, commandIdentifier: 7, reserved13: 0, secondFrame: false, sequenceCounter: 0, sequenced: false)}
016dc541-d5b0-4c11-9449-f5a2ac9b9169 14:57:10: debug ==> New Zwave Event: zw device: 14, command: 9881, payload: 00 84 07 , Battery: null
016dc541-d5b0-4c11-9449-f5a2ac9b9169 14:56:53: debug Looking for current value of parameter 83
016dc541-d5b0-4c11-9449-f5a2ac9b9169 14:56:53: debug Looking for current value of parameter 42
016dc541-d5b0-4c11-9449-f5a2ac9b9169 14:56:53: debug Looking for current value of parameter 14
016dc541-d5b0-4c11-9449-f5a2ac9b9169 14:56:53: debug Looking for current value of parameter 9
016dc541-d5b0-4c11-9449-f5a2ac9b9169 14:56:53: debug Looking for current value of parameter 8
016dc541-d5b0-4c11-9449-f5a2ac9b9169 14:56:53: debug Looking for current value of parameter 2
016dc541-d5b0-4c11-9449-f5a2ac9b9169 14:56:53: debug Looking for current value of parameter 1
016dc541-d5b0-4c11-9449-f5a2ac9b9169 14:56:53: debug Configuring Device For SmartThings Use

After a lot of attempts and reading threads, I’ve managed to get mine to work. I deleted the sensor from SmartThings, copied the raw file above and published to home, readded my sensor and it’s working perfectly.

Do you have UK V2 hub- just wondering if the UK “lock” from github, etc is making a difference.

I still seem to have ghost config, this at bottom of IDE my device screen and I get a few "null’s in the app device config:-
excessTemperatureSignalingInterval null
lackOfZwaveRangeIndicationInterval null
smokeSensorSensitivity null
soundNotificationStatus null
temperatureReportInterval null
visualIndicatorNotificationStatus null
zwaveNotificationStatus null

When it’s working what do you see in the device handler, I’ve seen oauth being yes at points and session as “home” at times, here is what I have now:-

I’ve definately set my devices to use it correctly and then reset device, so I’m baffled…

Mines V2 UK version and had no issues what so ever, that’s very strange!!

I deleted the preferences under device type- looks like these were rolled over from when Smartthings thought it was a smoke detector. Configure is looking a bit healthier now but still no motion detect.

I’m still learning logs but looks as though it may be auth related- here is a motion off followed by a motion on event:-
d46804c0-2afd-4aae-a628-9351e818efc8
22:28:34: debug === Parsed 'zw device: 1A, command: 9881, payload: 00 71 05 00 00 00 FF 07 08 00 ’ to [[‘displayed’:false, ‘descriptionText’:LR Motion: SecurityMessageEncapsulation(commandByte: [0, 0, 0, 255, 7, 8, 0], commandClassIdentifier: 113, commandIdentifier: 5, reserved13: 0, secondFrame: false, sequenceCounter: 0, sequenced: false), ‘isStateChange’:false, ‘linkText’:‘LR Motion’]]

d46804c0-2afd-4aae-a628-9351e818efc8
22:28:34: debug Catchall reached for cmd: SecurityMessageEncapsulation(commandByte: [0, 0, 0, 255, 7, 8, 0], commandClassIdentifier: 113, commandIdentifier: 5, reserved13: 0, secondFrame: false, sequenceCounter: 0, sequenced: false)}

d46804c0-2afd-4aae-a628-9351e818efc8
22:28:34: debug ==> New Zwave Event: zw device: 1A, command: 9881, payload: 00 71 05 00 00 00 FF 07 08 00 , Battery: 1457907844025

OK, so making some progress. I’ve updated the fingerprint with the data from my device’s raw and Smartthings now correctly recognises my Fibaro motion sensor when paired and assigns the my Fibaro motion detector device handler without messing about having to change device type in IDE:-
fingerprint deviceId: “0x0701”, inClusters: “0x5E,0x20,0x86,0x72,0x5A,0x59,0x85,0x73,0x84,0x80,0x71,0x56,0x70,0x31,0x8E,0x22,0x30,0x9C,0x98,0x7A”
}

Also, my MSR is 010F-0801-1001 versus 010F-0800-2001 in Cyri’s device handler.
I think this suggests that Cyril was maybe using an earlier’ different device. The devices I have are Z-wave Plus, part number FGMS-001 EU V3.2 (29 Jan 16)

My z-wave induction is fairly brutal, but I understand now that it seems to be just the “basic” set that isn’t working for motion/ vibration- looking through some other handlers the command “9881” in previous post above seems related.

Cut all the above- turns out a new device handler is underway- I hadn’t found that thread!
Refer here:-

1 Like

Anyone else having issues with:

  1. Temperature not updating? It shows the same value since I first synced the Fibaro Motion Sensor.
  2. Lux variable only changes with very high changes, e.g., taking the sensor from a dark room to the sunny window. But if the change happens slowly over a lot of hours (e.g. sunset) the lux doesn’t change.

Thanks.
João