Fibaro Dimmer Double Click Action

Thank you for the help!

Also, to add - configuring the dimmer 2 on an Android does not work for me either, exactly as described.

Thanks John, glad we both achieved what we wanted too :slight_smile:. And thanks for reporting the error on Android. Unfortunately I don’t have any android device handy to test it out myself, but I already received quite a few complaints. I am going to escalate it to SmartThings support.

@hajar Thank you very much for this, it is an amazing feature!

I am using a single gang momentary switch wired two way to another single momentary switch.

That was great for turning the light on and off and dimming. But your device handler and app has taken it to the next level.

My aim was to be able to turn multiple table lamps off without having to visit each lamp and half blind myself reaching for the switch. With your code a double click turns the lamps on or off while leaving the single click and hold press for controlling the ceiling light.

I had it all working great but then I thought I would try and get a triple click to turn the ceiling light and lamp off. I’m not sure what I have done, but now a single click makes the light turn on for as long as the button is pressed and then go off again. If I quickly press it again the light will stay on. But that also activates the lamp to come on.

Do you know of a parameter or other reason this might be happening? I was thinking of resetting the dimmer but haven’t got around to getting the tools out yet.

@Manxman27: I definitely have set it up on my dimmer to have triple click on S2 to switch off all lights in the house. But I do have toggle switch.

My suggestion would be to check the Dimmer manual for parameter 28, which talks about what scenes to expect in momentary switch. Then try the taps on your switch and see what scenes you are seeing activated (ignore your lights, just check what’s happening in the SmartThings app) and then based on that you will know what is happening and what events to assign to what scenes.

Thanks, I’ll carry on experimenting over the weekend. I triple clicked on S1 which shows – instead of a scene number.

I didn’t really need it as a double click followed by a single would do what I want to achieve, I just wanted to learn how to use your app.

If its – it means no scene is activated for that action. So not triple click on S1 unfortunately for the momentary mode then.

Sorry wrong place for post. Edited.

Amazing work!
I have installed the device handler and both smart apps.
I can see that you can set scenes reflecting switch type and find the number of scene in the manual.
But… you say that:

Open ST app and enter the settings of the device, where you should see all dimmer settings configurable. Adjust them to what you are usually using. If unsure, check which parameters were set in your previous device type. For momentary switch you need to set parameter 20 to 0. In order to enable scenes you need to set parameter 28 to 1

Cant find anywhere in the app where i can set, switch type, force bypass and such.
Since I am not a DEV, I am a bit unsure where to change those values in the device handler.

Could you please clarify for a technical guy, but still not a DEV :slight_smile:

When you’re looking at the device in the app, just hit the cog icon. You can change all of the parameters in there.

1 Like

You were right, a bit shameful i didn’t think of that.:sweat:

Hopefully this weekend I’m going to wire in my dimmer 2 to standard UK toggle switch with no neutral. In UK we don’t have github, I’m pretty keen to ST and not a coder, but have managed to manually add some stuff.

Can you confirm the link to the current code please and the procedure, is it something like this? Appreciate all help and links, thanks

So the procedure for the dimmer 2 is…

-Wire in (still have to do this!)
-add to ST (how initially?)
-change handler with code in the IDE
-change parameter as I have non dimmable LEDs

In the UK (as I am also) we do have access to Github, we just don’t have Github integration. This means that when a dev updates their code it doesn’t automatically update for us, we have to cut their new stuff and paste it into the IDE space for our controller/smart app.

Fortunately, this handler doesn’t change much at all, and works well. The only caveat being that you need to view and save the parameters on an apple device before you can use the functionality on an Android. Other than that, it works very well.

Adding to ST is very simple (as mentioned before). Just set ST to look for new things, and flick the switch a few times. You’ll also need to change parameters for your switch, as you’re using a toggle and not a momentary. After the device is added, you just need to change the device type to this one, and you’re set.

What a shame we don’t have Github integration. I keep on asking for it, but there is no reply from ST other than we will mention it on community site if it is going to happen, basically admitting that its not even in the plans…

Also huge shame for having to resort to an iOS device to set device parameters and not being able to do it on Android. If I knew what to fix I’d definitely fix it, but it does seem to be a purely Android app issue, since the code follows ST documentation. If anyone ever can point me at the resolution I’d be happy to make an update.

1 Like

@hajar, I’m pretty sure you’re not the only one. I’ve heard similar things said about other custom apps. I think the resolution of this one lies in the android ST app.

Thanks for this Hajar

I have installed your app. I have changed the switch type to 1 (toggle) and parameter 28 to 1.

when i turn it off and on rapidly twice or three times there is no event logged about scenes.

Any ideas?

Andrew

Hi

This looks great, but I’m having a problem getting it going.

I have Fibaro 2s working with roller blind switches. These work fine using the handler by @rmbhatia. I use auto configuration (parameter 13) and then have to tweak the minimum brightness to avoiding flickering (I have LED lights) but then all good.

When I use this, the lights can come on but if I fade up the lights go out, flash a bit, go out, etc. I’m assuming the default parameters aren’t good for my lighting setup and are overriding those previously set by auto calibration.

If I leave parameters blank on your settings screen, and only set param 28, will that leave existing parameters as they were and just overwrite parameter 28? I’m hoping this would resolve my issue by leaving all the levels, leading/trailing edge, etc, in tact.

Many thanks
Giles.

Hi @gileshoughton,

No, leaving parameter settings blank will only revert them to default values, but not the ones that are set by autocalibration. Auto-calibration sets a number of parameters (check the manual to see which ones). In order for those parameters to be set by auto-calibration and not by the device handler, you need to make sure in the device handler you set all those paramteres to a setting that would allow them to be set automatically (again check the manual for what that setting is, it might be different for each parameter). You then must also set the autocalibration parameter to be on. After you have done that auto-calibration will set the parameters that you wanted to be set by auto-calibration and device handler will not override those parameters.

Hope this helps
H

Curious about on thing.
Have someone found a way to trigger pistons in Core with Scene activation functionality with this Device?

I’ve only just got into CoRE myself due to the lack of GitHub integration in the UK. However I do control scenes with a double click.

I use SwitchMania, which created a ‘night mode’ virtual switch. This effectively gives me scene activation without CoRE.

I think it would certainly be possible to involve CoRE in this though.

1 Like

Yeah this would go from “some to the whole world” for many off ST users.