Fibaro Dimmer Double Click Action

so from what i understand the latest code @hajar, doesnt work properly without some kind of IOS device? ive never owned an ios device so there would be no way for me to get this to work?

You need to open the configuration on an Apple device once, just once (ever) and it will then work with Android.

Not @hajar’s fault, but an anomaly with the ST android app I believe.

frustrating, so i have to sign in to smart things on an IOS device? gonna have to sign a friends phone in and then sign them out again has anyone submitted a bug report?

obviously not blaming @hajar, who i thank for writing the code

I’ve not been in this situation with the latest Android ST App, and it sounds like the issue may have been resolved.

Seem to be getting the Android error here, not sure if its the same.
I went into ‘my devices’ in the IDE and set the parameters manually, they weren’t showing any as set in there.
No red sections in the in the Android app for the device now (I select the device and click the cog in top right, not ‘Configure’. I still cant click done in there, only option is back, or at the bottom clicking Replace, or Remove (red buttons). Clicking Replace shows a new screen saving ‘Device not considered failed’, and no option to do anything but click back!

Other issue that i seem to have is clicking ‘Configure’ on the device in the app doesn’t do anything. The live log gives the following
9:55:23 PM: error java.lang.NullPointerException: Cannot invoke method toInteger() on null object @ line 689
9:55:23 PM: debug configureAfterSecure()

Any clues, or is it a case of needing to find an iOS

Great work btw @hajar, thank you for your efforts.

I get the same error on iOS (10.0.2)

java.lang.NullPointerException: Cannot invoke method toInteger() on null object @ line 689

Thanks @hajar. I installed this today and it works perfectly. I’m planning to use it to make a double-click of the light switch in my hallway turn off all the lights in the house.

Hi. I also get the message “please fill out all required fields” even though they are all filled out. On Andriod. Any ideas?

I overcame this by setting the parameters in IDE. Combined with your SmartApp, this is exactly what I was looking for. Thank you.

Hi @gileshoughton, did you get this sorted? I’ve just got around to playing with this device and I’m getting the same problem you had.

The explanation by @hajar doesn’t tell me what parameters to set initially and I’m not understanding.

If I set parameter 13 to force auto-calibration it appears to calibrate but does not reset the parameter after and the light does the go out, flash a bit, go out, etc thing…

F

Edit/ Was it setting 35 Auto-calibration after power on to 1?
That set as well as 13 seems to allow calibration - But I have to then reset both manually!!

I’m afraid not. I had never idea what to set so as good as it looked, I stuck with what I had that was working fine.

With Core you don’t need the app to use S2 with scenes. Just use attribute “scene” on the switch in Core.

2 Likes

Hey @anon36505037, the short answer is yes, it should be possible. Switch actions generate scene events, while mobile app does not use scenes, but works directly. So you could use that fact to achieve what you want. But I suspect it would require some coding.

Robin

Don’t know if you have seen my request yet, installed 3 more dimmers today, 2 working Ok, third not working in smart things but is working with wall switched, can you help again please?

Thanks
Roger

1 Like

Don’t know what ide or dh is, the other two just worked after I had added them on smart things but unfortunately, doesn’t matter what I do the landing light won’t, I have gone through all the setups of the other working ones and the landing light has exactly the same settings but still no good.

Any ideas?

Roger Dunnaker

Thanks for the reply, yes didn’t understand what the initials meant, done that and the dimmer is correctly labelled, I’m not sure if the lamp is dimmable but changed that parameter for both sand it still not working for smart things, I’m going to try to reset it today and see if that works but if not I’m afraid that I wouldn’t have any further ideas

Roger Dunnaker.

Robin

Thanks, have managed to fix it, had to remove it physically and reinstall then re-pair and input all parameters manually, anyway, now working with only one problem, it flickers once before coming on and once before going off, probably a change in one of the parameters but I think I’ll leave it as is for the time being.
Once more, thanks for your help

Roger Dunnaker.

Hi, Can I start by saying this is amazing and looks like exactly what I need. I’m having a little trouble with the configuration though. I’ve got 2 physical toggle switches one connected to S1 and the other to S2 the common on both is connected to Sx (I believe this is the correct way to wire this).

I’ve installed the device handler and the scene smartapp, when I toggle S1 I get two different Scene IDs being broadcast and when I toggle S2 I get another 2 different Scene IDs broadcast.

I’ve used the scene smartapp and successfully got S2 to switch on a philips hue lamp, but I can’t figure out how I stop it from also turning on the light which is physically connected to the fibaro dimmer. Both S1 and S2 switch the main light, can I stop S2 from activating the physical relay in the fibaro? Should I not have connected the common from my second switch to Sx (I can’t see how a single wire connected to a switch would do anything)

Hope this makes sense! Any help would be much appreciated.

Thanks,
Matt

Ignore me I was being stupid, it wasn’t updating the parameters I had changed and it worked fine once I enabled 28 and disabled 26. I’m getting some odd behaviour though after first updating the config the light will turn to 1% when first powered on. I can live with this but it seems odd, any idea why this might be happening? Means if I have a power cut potentially all lights will be at 1% next time I try to turn them on.

Hi, I’ve had my Fibaro 212’s for a couple of weeks now and am using hajar’s device handler, which generally works great (big thanks!). I’m having two problems, ones just annoying but the other’s a right pain. I’ve seen similar posts on other threads but my scenario seems a bit more repeatable so let me describe in ase it helps someone figure out the issue…

First the minor one… when i have the dimmer set to a high-ish value and turn it on by just tapping the tile, I see the slider drop DOWN to a lower value briefly then slide back up to the original. It almost always goes back to the right value in the end, but just looks confusing. I’m wondering if the command to get the current level is firing too quickly whle the dimmer is still adjusting the level?

Now the bigger problem… if I go into the settings and adjust any of the parameters and hit done to send them off to the device, the settings seem to take effect but it starts misbehaving on fundamental dimming capability. Its as though it forgets what the brightness range is - dimming to anything below about 70% ish still works (though the resulting brightness seems off) but anything about about 70% and it seems to trigger an overload and shut itself down. Sometimes it then comes back on, but stops at a lower brightness. Spent ages in the code trying to “fix” it, but now I’ve figured out a solid way of getting it back to normal. I have param 35 set to 2 to force auto-calibration at each power up, i turn off the power to the circuit and back on again. Dimmer recalibrates and starts working normally again (and any other parameter changes have taken effect OK).

Well I guess it isn’t a “big” problem in the sense one shouldnt need to change parameters too often, but it seems the parameter setting routine is somehow leaving the dimmer “confused”. I might be suffering more than most as my load is 4x50W halogen which at full power is 200W, close-ish to the limit of 250? I’ve looked at the code and can’t see any obvious bug (I’m a programmer but more c# than groovy!) but I’m wondering if one of the params is being set to the wrong byte size of something like that, and I note some other device handlers do more type conversions in their settings.

If anyone has any suggestions it would be appreciated.